diyAudio

diyAudio (https://www.diyaudio.com/forums/index.php)
-   Car Audio (https://www.diyaudio.com/forums/car-audio/)
-   -   Again needing help fixing Orion HCCA 225 Digital Reference (https://www.diyaudio.com/forums/car-audio/323494-help-fixing-orion-hcca-225-digital-reference.html)

Chopperbuilder 5th June 2018 02:29 AM

Again needing help fixing Orion HCCA 225 Digital Reference
 
I posted on here a few weeks back asking for help fixing my Orion HCCA 225 Digital Reference amp. With Perry & Tim's help I was able to fix the problem it had.
apparently it needs a little more TLC. Recently I noticed when you first power it up it takes 3or 4 minutes before it starts amplifying the music...it does play music through it when it first powers up but it takes 3 or 4 minutes before it starts amplifying the music. As if it's warming up. If I shut it down for little bit and turn it back on it works fine still. Only after it has sat for a while does it do it. Op-amps maybe??? I greatly appreciate any help I can get.

Perry Babin 5th June 2018 02:34 AM

There are two 2n5639 transistors on the board. They are the muting transistors. The third leg will be at approximately -15v when the muting is released. If the third leg takes a long time to go well below 0v, there is a problem with the mute drive circuit.

Chopperbuilder 5th June 2018 03:19 AM

1 Attachment(s)
I just tried to check them and apparently a couple hours isn't long enough for it to sit as it worked perfectly. I'll try again tomorrow. Just to make sure...it's the two transistors I have circled it the pic, right?

Chopperbuilder 5th June 2018 05:33 AM

So I was testing the transistor that is toward the top of the pic. It was taking a long time to drop voltage. About 3 minutes in it had only reached -10v. At this point I moved the test lead over to the third leg of other transistor and the amp immediately dropped volume, the reading on that leg -3.3v. I moved back to the first transistor and it was now at -6.5v. So I moved back to the 2nd transistor again and the volume cut completely out this time.

I pulled that transistor and checked it. It is definitely bad. Going to replace them both tomorrow. Do you think it could just be those resistors causing the whole problem?

Perry Babin 5th June 2018 08:25 AM

1 Attachment(s)
Those are jfets. They appear shorted (10 ohms?) source to drain normally.

Does the voltage on pin 3 drop as expected without the transistors in the circuit?

If not, I'd suspect one of the components indicated in the attached photo.

Chopperbuilder 5th June 2018 11:34 PM

1 Attachment(s)
Hey Perry, I found and fixed the no sound problem. It was a resistor right behind one of the 2n5639 transistors you first mentioned (see attached photo).
So as to the original problem...I replaced both of those transistors as well as the one you pointed out in your pic, along with the capacitor(the big resistor ohmed out good). After replacing those the problem seems to have gotten worse as it doesn't reach full volume output at all now. The third leg on the two 2n5639 transistors is only dropping to a max of -6.12v(that was after 7 or 8 minutes of play). Also that voltage intermittently(very briefly - half a second) jumps up and then drops again...of course the sound drops and rises with it.

Perry Babin 7th June 2018 02:55 AM

With the two muting transistors out, does it reach expected output level?

With the muting transistors out. does pin 3 drop farther?

Are you sure that you reinstalled the transistors the same way they came out?

Chopperbuilder 7th June 2018 04:00 AM

No, with the muting transistors out it does not reach the expected output level. Although it is closer to the expected level with them out -12v.
The 2n5639 transistors are obsolete so I had to replace them with NTE467. The info I found on the NTE467 is that it specs are identical to the 2n5639 as well as the leg orientation being the same. I did install them the same as they came out.

Perry Babin 7th June 2018 09:09 AM

With the muting transistors out, the amp is playing as loud as it can. That depends mainly on the gain setting. What makes you think it's not as loud as it should be?

Chopperbuilder 7th June 2018 02:54 PM

Sorry, for the miscommunication. With the muting transistors out it is playing loud as it should be. With them in it is not.


All times are GMT. The time now is 04:28 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 18.75%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio

Wiki