diyAudio

diyAudio (https://www.diyaudio.com/forums/index.php)
-   Multi-Way (https://www.diyaudio.com/forums/multi-way/)
-   -   Help! 2x15 with C/o (https://www.diyaudio.com/forums/multi-way/252866-help-2x15.html)

SkoobaStevens 14th March 2014 03:22 PM

Help! 2x15 with C/o
 
Hey all, I have a problem.

I have a pair of Peavey PV215's. Recently we rented them out (Just say no) and something happened to one of them. I was not around when the incident occurred, but here is what I know.

1. They are 2x15 with Horn
2. The speakers cut out, but don't make a blown speaker sound, or any sound.
3. The Horn still works, but sounds like crap and is quiet.
4. No, trying different cables, inputs or power amp and mixer outputs didn't fix anything.

Does anyone have any suggestions as to how i can diagnose the problem?

Thank-you for your time
-Skooba

Top Shelf 14th March 2014 09:22 PM

Welllll ... not to be an **** , but I'm ASSuming you had a proper rental contract and C.C. /cash based damage deposit system in place? If not well you'll def. have one next time you rent out .right?
First off do a visual inspection of the crossover board to see what is burnt and /or blown apart. Next check the wiring between the crossover board and all the drivers. Then do the smell test near the voice coils of all the drivers. Then get a multimeter and check the resistance across all the voice coils. This will probably entail you having to remove the drivers and the crossover board from the enclosure.


All times are GMT. The time now is 10:50 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 17.65%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio

Wiki