Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Hypex SMPS400A180
Hypex SMPS400A180
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 17th June 2014, 09:08 AM   #1
DanielIt is offline DanielIt  Italy
diyAudio Member
 
Join Date: Feb 2014
Location: Italy
Default Hypex SMPS400A180

Hi. I have one monitor speaker that have 2 bridged UcD180 modules on 8ohm load for bass and 1 of same module on tweeter duty with this power supply.After 2 years of working ,last week on power up it wont work.As an electrical engineer myself i found that on power up 2 transistor of the supply board poppd up.The 2 in question are T7 and T14. The first is an smd part and i cant read it what it was,with some intuition and a little schematic i draw i think is an high voltage pnp part.The T14 is an npn KSP44.I already emailed hypex to ask what part number it is so i can change it myself and no answer for now.I must mention that the fast 5A fuse is working,the bridge rectifier too and the caps are good.Is only missing the low voltage startup part.
I ask is anyone have a module at hand if can make an macro picture of the tiny transistor to see the number printed.
Thank you in advance.
Daniel
  Reply With Quote
Old 17th June 2014, 10:20 AM   #2
JonSnell Electronic is offline JonSnell Electronic  United Kingdom
diyAudio Member
 
JonSnell Electronic's Avatar
 
Join Date: Dec 2012
Location: The Jurassic Coast, England. GB
Normally the SMD tuning capacitors crack on the board and then it overheats and dies. Hypex will not supply any information.
T7 has 1Bt printed on it. Have you checked U1 with a power supply to see if it oscillates? The two transistors feed U1.
__________________
Support for Fender, Marshall and all Valve Equipment; Audio Innovations, Audiorama FU29, Quad and Leak. www.jonsnell.co.uk
  Reply With Quote
Old 17th June 2014, 10:32 AM   #3
DanielIt is offline DanielIt  Italy
diyAudio Member
 
Join Date: Feb 2014
Location: Italy
U1 is not alimented.in hes path is T10 marked BCP56 that is another NPN transistor and it seems measured still good.I am gonna remove another transistor 1Bt from the board to see what type is and try to change it accordingly.Thank you for your big effort,will let you know how it goes when the KSP arrive in a few days.
Daniel.
  Reply With Quote
Old 17th June 2014, 10:41 AM   #4
DanielIt is offline DanielIt  Italy
diyAudio Member
 
Join Date: Feb 2014
Location: Italy
Measuring another transistor marked 1Bt on the board is seems to pe an PNP device,as i was suspecting according to the schematic used.I do not have an osciloscope to see if U1 is swinging.
  Reply With Quote
Old 17th June 2014, 10:51 AM   #5
DanielIt is offline DanielIt  Italy
diyAudio Member
 
Join Date: Feb 2014
Location: Italy
By measuring another 1Bt transistor on the board it looks like an PNP device.I could supply the U1 with 12V to see if it oscilates but i dont have a scope to see it.Any other way to aknowledge if it oscilates?
  Reply With Quote
Old 17th June 2014, 12:09 PM   #6
JonSnell Electronic is offline JonSnell Electronic  United Kingdom
diyAudio Member
 
JonSnell Electronic's Avatar
 
Join Date: Dec 2012
Location: The Jurassic Coast, England. GB
It oscillates at anything from 45kHZ to 300kHZ depending upon load. A scope is required.
Do you have a schematic you could email me please?
__________________
Support for Fender, Marshall and all Valve Equipment; Audio Innovations, Audiorama FU29, Quad and Leak. www.jonsnell.co.uk
  Reply With Quote
Old 17th June 2014, 12:30 PM   #7
DanielIt is offline DanielIt  Italy
diyAudio Member
 
Join Date: Feb 2014
Location: Italy
i only have drawn the 3 transistors i could reverse engineer from the board.From the hypex website i could get that the board is switching at 100khz.I will try to draw it in eagle to see if i can.
  Reply With Quote
Old 17th June 2014, 12:57 PM   #8
DanielIt is offline DanielIt  Italy
diyAudio Member
 
Join Date: Feb 2014
Location: Italy
I made a quick drawing in eagle of the primary circuit.The diodes are only simbolic,there is a bridge rectifier and filter,and are all good.There are too many smd components on the board,that for reversing and making a full schematic would mean to desolder them all and throw away the board in the end.My scope is to try and repair it as it is with the only 2 transistors,otherwise will buy a new one hopping it will be exactly the same and will work in my powered speaker.
Attached Images
File Type: jpg Schematic.jpg (97.7 KB, 368 views)
  Reply With Quote
Old 7th July 2014, 08:37 AM   #9
DanielIt is offline DanielIt  Italy
diyAudio Member
 
Join Date: Feb 2014
Location: Italy
Back on the right track today.Even if it was more than 3 weeks ago i had a very pleasant surprise today when i received an email from Hypex customer service.I had brough a new supply from then 3 week ago and was very happy that i received it within 2 working days and my cab was working again.Now i have the part list of the transistors i need to repair my old one and keep it as spare.The 2 transistor are
T7 - BC846BW and T14- KSP44.
Hope this will be usefull for anyone with same problem.
  Reply With Quote
Old 28th May 2020, 04:59 AM   #10
arnoldsq is offline arnoldsq
diyAudio Member
 
Join Date: May 2020
I know this is resurrecting a really old thread, but you wouldn't happen to have T37's part number would you?
  Reply With Quote

Reply


Hypex SMPS400A180Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: 2 NEW Hypex SMPS400A180 power supplies supernet Swap Meet 2 12th February 2014 11:02 PM
Hypex Ucd400Hg with HxR vs. Hypex NC 400 Bennoman75 Class D 0 29th October 2013 10:12 PM
Question for those who have tried hypex smps with hypex modules avian Class D 12 3rd March 2009 09:30 AM
Hypex UcD 180AD + signal wires, Power Supply ST, Hypex Transformer TR100A c10h12n2 Swap Meet 7 7th July 2007 03:55 PM
FS: Hypex UcD 400/180AD, hypex toroid Archmage Swap Meet 4 14th November 2006 04:23 AM


New To Site? Need Help?

All times are GMT. The time now is 02:26 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright ©1999-2020 diyAudio
Wiki