Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Planars & Exotics ESL's, planars, and alternative technologies

Martin Logan ReQuest query
Martin Logan ReQuest query
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th February 2018, 01:05 AM   #1
mobyd is offline mobyd  New Zealand
diyAudio Member
 
mobyd's Avatar
 
Join Date: Sep 2004
Location: Auckland
Default Martin Logan ReQuest query

I have a ML ReQuest crossover which allegedly was hit by lightning. A lot of semis on the high voltage sensing board were destroyed. I have replaced these but the board still does not work. It powers up the HT for a while at startup and then cuts off. Feeding signal does not retrigger it like it should. The board is shown only as a block in the crossover schematic. Does anyone have a schematic?. ML tech support is a dead letter box.
Cheers
Mike
  Reply With Quote
Old 10th February 2018, 01:20 AM   #2
bolserst is offline bolserst  United States
diyAudio Member
 
bolserst's Avatar
 
Join Date: Jun 2005
Location: Fort Worth, Texas
Can you post a pic of the board?
Based on the ML museum timeline, it is likely one of the MLPS10x series of boards.
If so, circuit should be very similar to attached.

NOTE: If your Request is an import from a country with 60Hz mains, you may need to bypass the frequency sense portion of the circuit. See post here: ML Aerius import from USA
Attached Images
File Type: png SL3_Bias_schematic.png (102.6 KB, 121 views)

Last edited by bolserst; 10th February 2018 at 01:25 AM.
  Reply With Quote
Old 10th February 2018, 02:57 AM   #3
tyu is offline tyu  United States
diyAudio Member
 
Join Date: Jul 2009
here a pic....of the bias board
Attached Images
File Type: jpg reQuest%20tweak%20photo%201[1].jpg (93.5 KB, 119 views)
File Type: jpg reQuest%20tweak%20photo%202[1].jpg (122.7 KB, 119 views)
Attached Files
File Type: pdf request_xo.pdf (9.8 KB, 20 views)

Last edited by tyu; 10th February 2018 at 03:11 AM.
  Reply With Quote
Old 10th February 2018, 03:24 AM   #4
mobyd is offline mobyd  New Zealand
diyAudio Member
 
mobyd's Avatar
 
Join Date: Sep 2004
Location: Auckland
Quote:
Originally Posted by bolserst View Post
Can you post a pic of the board?
Based on the ML museum timeline, it is likely one of the MLPS10x series of boards.
If so, circuit should be very similar to attached.

NOTE: If your Request is an import from a country with 60Hz mains, you may need to bypass the frequency sense portion of the circuit.
Thanks so much - this contained everything I needed to get things ticking again.
Yeee-hah!
Cheers
M

Last edited by mobyd; 10th February 2018 at 03:54 AM.
  Reply With Quote
Old 10th February 2018, 02:07 PM   #5
bolserst is offline bolserst  United States
diyAudio Member
 
bolserst's Avatar
 
Join Date: Jun 2005
Location: Fort Worth, Texas
Well that was quick!
What did you determine had gone wrong?
  Reply With Quote
Old 10th February 2018, 05:58 PM   #6
mobyd is offline mobyd  New Zealand
diyAudio Member
 
mobyd's Avatar
 
Join Date: Sep 2004
Location: Auckland
Quote:
Originally Posted by bolserst View Post
Well that was quick!
What did you determine had gone wrong?
Once I bypassed the frequency sense circuit, it worked like a bought one.
What a strange bit of engineering - to include something to prevent operation
on 50Hz mains (but allow it on 60Hz).
Thanks for your help.
M
  Reply With Quote
Old 10th February 2018, 06:11 PM   #7
bolserst is offline bolserst  United States
diyAudio Member
 
bolserst's Avatar
 
Join Date: Jun 2005
Location: Fort Worth, Texas
Excellent!
I just included that note about 50Hz/60hz as an afterthought...glad I did.
I seem to recall reading in Stereophile that ML was included country specific power supplies to help their foreign distributors cope with grey market sales.
  Reply With Quote
Old 7th March 2020, 07:37 AM   #8
Alh is offline Alh
diyAudio Member
 
Join Date: Sep 2017
Thanks guys for sharing such useful information.

As a matter of interest, have you noticed that the speaker binding posts polarity is reversed on the ReQuests?!

The +/- posts connected to -/+ internally ???!!!
  Reply With Quote

Reply


Martin Logan ReQuest queryHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Martin Logan ReQuest Xover & power supply aagas Swap Meet 3 7th March 2020 12:37 PM
MARTIN LOGAN REQUEST PANELS + WOOFERS retiredelectrician Swap Meet 3 30th March 2013 03:12 AM
Aleph2 or Aleph-X for Martin Logan Request? Salomon Pass Labs 2 20th June 2009 11:42 AM
martin logan's dsiroky Pass Labs 17 16th April 2007 10:13 AM
martin logan csl flodge Planars & Exotics 12 13th November 2005 02:59 PM


New To Site? Need Help?

All times are GMT. The time now is 05:40 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright ©1999-2020 diyAudio
Wiki