Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Planars & Exotics ESL's, planars, and alternative technologies

Acoustat Answer Man is here
Acoustat Answer Man is here
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 1st August 2020, 07:58 PM   #2471
Mikerodrig27 is offline Mikerodrig27  United States
diyAudio Member
 
Join Date: Aug 2014
Location: Albany, OR
Quote:
Originally Posted by hhhh View Post
Thanks AAM, a pair of Spectra 11s went for CDN$299 near me.
These Acoustats hit outside their weightclass when it comes to what they seem to sell for used. I bought my pair for $80. Of coarse they need a decent amount of repair work, they are cosmetically in good condition. I can see the real potential even with them not being completely fixed yet.
  Reply With Quote
Old 3rd August 2020, 05:16 PM   #2472
AcoustatAnswerMan is offline AcoustatAnswerMan  United States
diyAudio Member
 
AcoustatAnswerMan's Avatar
 
Join Date: Feb 2011
Location: Chandler Arizona
Quote:
Originally Posted by Mikerodrig27 View Post
Do you have any information on the bias pots used on the spectra 11 boards? I would like to replace mine. The stuff they wipe on top has gotten between the dial and it's body which makes it very hard to turn.

Thanks!

Sorry, I don't have any specs on the trim pot, but it's a pretty generic style. You should find a replacement at Digikey or Mouser.
  Reply With Quote
Old 3rd August 2020, 05:18 PM   #2473
AcoustatAnswerMan is offline AcoustatAnswerMan  United States
diyAudio Member
 
AcoustatAnswerMan's Avatar
 
Join Date: Feb 2011
Location: Chandler Arizona
Quote:
Originally Posted by Mikerodrig27 View Post
Do you have any information on the bias pots used on the spectra 11 boards? I would like to replace mine. The stuff they wipe on top has gotten between the dial and it's body which makes it very hard to turn.

Thanks!

Sorry, I don't have any specs on the trim pot. However, it's a pretty generic style, so you should have no trouble finding a suitable replacement at Digikey or Mouser.
  Reply With Quote
Old 3rd August 2020, 09:46 PM   #2474
Mikerodrig27 is offline Mikerodrig27  United States
diyAudio Member
 
Join Date: Aug 2014
Location: Albany, OR
Yes, the only thing I saw was 1k so I assume that is the only spec you need. I will order some if for some reason I strip these.
  Reply With Quote
Old Yesterday, 06:01 AM   #2475
GNWT1 is offline GNWT1  Canada
diyAudio Member
 
Join Date: Feb 2011
Location: Charlottetown, PEI
I have had my Acoustats 6600's for a number of years and worked perfectly, however one of the speakers has very low output any ideas where to start? I do have replacement transformers, ultra sonic supply board and a high voltage board in reserve.
  Reply With Quote
Old Yesterday, 12:04 PM   #2476
Mikerodrig27 is offline Mikerodrig27  United States
diyAudio Member
 
Join Date: Aug 2014
Location: Albany, OR
Quote:
Originally Posted by AcoustatAnswerMan View Post
First of all, all Spectra 11/1100 used the wall transformer power supply. But there was a significant improvement to the supply, and it is essential that you make sure your set is updated to the latest design, before you go "upgrading" or replacing parts. It's easy to do with commonly available parts. See attached docs.

Attachment 864437
o
Attachment 864438

Attachment 864439
I updated the interface as described in the documents. The only change I made was switching the 470uf cap for a 1500uf cap. The bias incresed on both interfaces.

One interface now reads 46 volts and the other reads 78 with the pots maxed out.

What should be my next step? I was thinking of checking the voltage on both the interfaces part by part to see where the drop is. One thing I noticed is that one interface looks like it was built before the other. As in, it has older looking components on the board.

Thanks for all of your help. The speakers are starting to sound pretty good. I just need to get the bias up the rest of the way on the one that is still too low.
  Reply With Quote
Old Yesterday, 12:57 PM   #2477
john65b is offline john65b  United States
diyAudio Member
 
john65b's Avatar
 
Join Date: Jan 2005
Location: Chicago
When I had issues on my Spectra 11, I ended up changing that 8 pin IC (looks like an Opamp). You may just need to make sure it is electrically connected - take voltage readings pin for pin from common ground and compare to the other working interface (bias at 75v sounds about right). may just need to resolder bad 8 pin connection, as I dont think mine needed replacing after replacing it...just a bad solder joint
__________________
I Speak Spanish to God, Italian to Women, French to Men, and German to My Horse. Charles V

Last edited by john65b; Yesterday at 01:00 PM.
  Reply to this post

Reply


Acoustat Answer Man is hereHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
No answer Antoni D The Lounge 2 13th February 2011 06:19 AM
need a tech to answer this one pks71 Car Audio 1 19th November 2004 11:50 AM


New To Site? Need Help?

All times are GMT. The time now is 07:02 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright ©1999-2020 diyAudio
Wiki