Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

PC Based Computer music servers, crossovers, and equalization

Simple DLNA Renderer for Odroid C1+...or not?
Simple DLNA Renderer for Odroid C1+...or not?
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 18th September 2020, 01:55 PM   #31
linuxfan is offline linuxfan  Australia
diyAudio Member
 
Join Date: Dec 2007
Regarding the failure of MPD to auto-start, it may be that there are two different startup methods conflicting with each other.
So I suggest you reverse my earlier auto-start method, by doing this -
Code:
sudo systemctl disable mpd
then autostart mpd from dietpi-services.
  Reply With Quote
Old 18th September 2020, 02:00 PM   #32
masterkw is offline masterkw  Germany
diyAudio Member
 
masterkw's Avatar
 
Join Date: Sep 2020
Briefly in between...

mSD is quite new, all past flash operations were successful. Only the DietPi-image failed. Took the same adapter on macOS and Windows, preparations in same order: deleted old volume(s), create a new one (FAT32) --> balena etcher --> flashing and verification successful.

In the meantime, I'll do my homework...
  Reply With Quote
Old 18th September 2020, 03:10 PM   #33
masterkw is offline masterkw  Germany
diyAudio Member
 
masterkw's Avatar
 
Join Date: Sep 2020
Done all tests/settings (as good as I could comprehend). Started test.mp3 with mpg123.

Sounds "great"... --> *klick*

No more access, i had to pull the plug...
  Reply With Quote
Old 18th September 2020, 03:29 PM   #34
wealas is offline wealas
diyAudio Member
 
Join Date: Apr 2017
I wonder if mpd is scanning your library and using up all the cpu resources. Maybe disable the mpd service and run
speaker-test -c2 -Dhw:1,0
That should put out pink noise one speaker at a time.
  Reply With Quote
Old 18th September 2020, 03:32 PM   #35
phofman is offline phofman  Czech Republic
diyAudio Member
 
Join Date: Apr 2005
Location: Pilsen
Perhaps dmesg output could put more light on the cause. Maybe insufficient USB power causing the USB device disconnect or something similar.
  Reply With Quote
Old 18th September 2020, 04:01 PM   #36
linuxfan is offline linuxfan  Australia
diyAudio Member
 
Join Date: Dec 2007
I see there's an incompatibility between the Audiolab M-DAC and modern Linux kernels
Audiolab Mdac - years have gone by, still linux support broken | pink fish media

The Audiolab M-ONE has a more modern USB interface, but the workaround for the earlier problem might still work -
connect a USB hub between the Audiolab and Odroid-C1.

Last edited by linuxfan; 18th September 2020 at 04:12 PM. Reason: change of details
  Reply With Quote
Old 18th September 2020, 04:27 PM   #37
phofman is offline phofman  Czech Republic
diyAudio Member
 
Join Date: Apr 2005
Location: Pilsen
IIUC the problem described on pinkfish is with the USB controller, not MDAC. But I may be wrong (as usual).
  Reply With Quote
Old 18th September 2020, 04:27 PM   #38
masterkw is offline masterkw  Germany
diyAudio Member
 
masterkw's Avatar
 
Join Date: Sep 2020
Mmm, without having read it, my m-one is so to say a M-DAC with a power amp (firmware is up to date, v.1.32, straight from Audiolab-support).

In the past I've tried several "music distributions": Daphile (on an older AMD Zacate), RuneAudio and Volumio. They all ran out of the box, connected via USB.

BTW, Odroid C1+ is connected to an USB 3.0 (900mA) of my NAS because basic power consumption is only 500mA and only RJ45 and the m-one are plugged in. All other constellations before worked fine. No "lags", smooth library scrolling, fast updating and playback scrolling, etc.

Right now I'm struggling with a MPD/mpg123 error. MPD is active but mpg123 reports error messages (something like "socket"..."access"...). Also I can't remove and re-install MPD (failure reports@Debian-Server)...

I'm a little frustrated, it's weekend...and my wife seems to get ill. I think, I have to set priorities for the moment.

Thank you so far!

Last edited by masterkw; 18th September 2020 at 04:30 PM.
  Reply With Quote
Old 18th September 2020, 07:02 PM   #39
masterkw is offline masterkw  Germany
diyAudio Member
 
masterkw's Avatar
 
Join Date: Sep 2020
But one last sign of life today.

...call me "Mr.-Clean-Install".

Okay, I'm able to reproduce the situation:
  • clean install & config
  • install mpg123
  • comand playback test.mp3 (success by first try)
  • noisy sound, dietpi freezes, have to pull the plug
  • after reboot mpd autostart failed, no restart in present session --> reboot
  • mpd service online
  • connect with MPD-app (iOS)
  • could press play within the first tracks in library
  • it takes a long time...then a flac file comes to the same noisy life
  • reboot...

Due to the fact Archphile (not for C1+) based on Archlinux (C1+-ready image available), I'll try the same procedure with this.

Now, I quit for today
  Reply With Quote
Old 18th September 2020, 07:10 PM   #40
phofman is offline phofman  Czech Republic
diyAudio Member
 
Join Date: Apr 2005
Location: Pilsen
Quote:
Originally Posted by masterkw View Post
but mpg123 reports error messages (something like "socket"..."access"...).
Error messages are there to explain the cause, they are important. They can be copied here from an ssh terminal, e.g., or in many other ways.
  Reply With Quote

Reply


Simple DLNA Renderer for Odroid C1+...or not?Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Network media renderer DAC, ABC-PCB Lazy Cat Swap Meet 12 28th October 2014 10:49 PM
IC/FS:edel media renderer mcluxun Swap Meet 3 25th October 2014 07:23 PM
FS: Edel Media Renderer (New) MisterRogers Swap Meet 1 28th December 2013 11:44 AM
DIY Airplay/DLNA denny9167 Digital Source 0 15th December 2013 06:19 PM
Pull content and Push to media renderer jan.didden PC Based 2 1st June 2013 12:38 PM


New To Site? Need Help?

All times are GMT. The time now is 01:09 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright ©1999-2020 diyAudio
Wiki