Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

PC Based Computer music servers, crossovers, and equalization

BruteFIR & JConvolver Strange Latency??
BruteFIR & JConvolver Strange Latency??
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 20th September 2019, 12:09 AM   #1
AKC360 is offline AKC360  United Kingdom
diyAudio Member
 
Join Date: May 2019
Location: London
Default BruteFIR & JConvolver Strange Latency??

Hello People,

I have a strange problem with high latency for both Brutefir or JConvolver. My Jack settings are low and stable and the latency doesn't seem to tally with the partition size?

My Hardware:
  • i5-8259U - Intel NUC
  • 8GB DDR4
  • PCIe SSD
  • M-Audio - MTrack8

Software:
  • Ubuntu Studio 19.04 - Have tried updated and fresh install
  • Jconvolver 0.9.3-2
  • BruteFIR 1.0o-1
  • Jackd2 1.9.12

Settings:
  • Jack Settings - 48KHz 64Buffer 3Period
  • BruteFIR - 7 Filters each 8192 Taps, These are each split into 512sample partitions
  • Jconvolver - 7 Filters each 8192 Taps, These are split into 64sample partitions


Results:

Brutefir Latency = 104mS, CPU Load = 55-60%
JConvolver Latency = 85mS, CPU Load = <5%

These latencies are measured inside Jack(Not using sound card IO) using a jack signal generator and a jack oscilloscope.


I dont understand why I am getting such long latencies, I would be very grateful if anyone could shed some light on why the latencies are so long and even more grateful if you could share how to fix it!

Thank you in advance,

Alex
Attached Images
File Type: png BrutefirCPU.png (52.0 KB, 30 views)
File Type: png BrutefirLatency.png (63.8 KB, 30 views)
File Type: png Jack Setup.png (82.7 KB, 30 views)
File Type: png Jacksettings.png (70.9 KB, 30 views)
File Type: png JConv Latency.png (63.3 KB, 30 views)
File Type: png JconvCPU.png (61.9 KB, 10 views)
  Reply With Quote

Reply


BruteFIR &amp; JConvolver Strange Latency??Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Brutefir - where has it gone? Daihedz PC Based 9 2nd August 2019 08:16 PM
Help with BruteFIR configuration Crumboo PC Based 17 24th February 2014 06:45 PM
Brutefir or min dsp greasergirl PC Based 4 13th March 2013 05:29 PM
Receiver Latency ? percy Digital Source 0 2nd October 2006 12:22 PM
DEQ2496 latency brucemck2 Digital Source 3 8th January 2006 05:28 AM


New To Site? Need Help?

All times are GMT. The time now is 06:28 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki