Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

PC Based Computer music servers, crossovers, and equalization

Pulseaudio Crossover Rack - multi-way crossover design & implementation with linux
Pulseaudio Crossover Rack - multi-way crossover design & implementation with linux
Pulseaudio Crossover Rack - multi-way crossover design & implementation with linux Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th November 2019, 12:09 AM   #541
AllenB is offline AllenB  Australia
diyAudio Member
 
Join Date: Oct 2008
When Pulseaudio has problems..

1. System is sitting for a while, a channel disappears (no output). I click to remove modules, the new default sink is blank. I try again, it appears. I reload, this doesn't fix the problem. I close the crossover and open again, now it works.

I am OK with some problems. What is the fastest/best way to recover from this?

2. System restart. I need to start paxor and load a crossover before it will work. Is this right, should it just work without paxor running?
  Reply With Quote
Old 20th November 2019, 07:59 PM   #542
Tfive is offline Tfive  Germany
diyAudio Member
 
Tfive's Avatar
 
Join Date: Jun 2018
Location: Straubing
Hey AllenB, sorry for the delay. Forgot to answer...

Please tell me the used pulseaudio version and os.

Also can you please post the output of "pacmd list sinks" at the time the problem ocurrs. And after system startup... And the contents of the file .config/pulse/default.pa when crossover is inserted. Please attach as text files or use a pastebin!
__________________
Want more of the good stuff? -> https://t-5.eu/
  Reply With Quote
Old 21st November 2019, 10:35 AM   #543
AllenB is offline AllenB  Australia
diyAudio Member
 
Join Date: Oct 2008
It's OK, I have good tunes

Buster
PA 12.2
Paxor 1.46

Sinks before load xo.
Sinks and default.pa after load xo.
Sinks when choose 'remove filter modules' and there is no available default master sink.
Attached Files
File Type: txt sinksbeforexo.txt (64.0 KB, 2 views)
File Type: txt sinksafterxo.txt (64.0 KB, 0 views)
File Type: txt default.pa.txt (13.3 KB, 2 views)
File Type: txt sinksnosinks.txt (64.0 KB, 1 views)
  Reply With Quote
Old 21st November 2019, 05:31 PM   #544
Tfive is offline Tfive  Germany
diyAudio Member
 
Tfive's Avatar
 
Join Date: Jun 2018
Location: Straubing
Quote:
Originally Posted by AllenB View Post
It's OK, I have good tunes

Buster
PA 12.2
Paxor 1.46

Sinks before load xo.
Sinks and default.pa after load xo.
Sinks when choose 'remove filter modules' and there is no available default master sink.
ok, Somehow pulseaudio winds up in a state where it doesn't work anymore. can you please post the "console window" output when removing the modules in paxoverrack...
__________________
Want more of the good stuff? -> https://t-5.eu/
  Reply With Quote
Old 21st November 2019, 05:43 PM   #545
Tfive is offline Tfive  Germany
diyAudio Member
 
Tfive's Avatar
 
Join Date: Jun 2018
Location: Straubing
PS: Please check if after removing modules the crossover statements are removed from your ~/.config/pulse/default.pa
__________________
Want more of the good stuff? -> https://t-5.eu/
  Reply With Quote
Old 21st November 2019, 11:19 PM   #546
AllenB is offline AllenB  Australia
diyAudio Member
 
Join Date: Oct 2008
./default.pa, paxor does add and remove the statements the way I would expect it to.

I opened the console, chose remove filter modules, sink was blank so I cancelled, there was no console output until I repeated and chose a sink. I should have tried clicking yes when it was blank, (vague memory I think it won't accept, but I should try again later after it has time to do it again).
Attached Images
File Type: png Screenshot from 2019-11-22 10-07-25.png (118.7 KB, 145 views)
  Reply With Quote
Old 22nd November 2019, 10:07 AM   #547
Tfive is offline Tfive  Germany
diyAudio Member
 
Tfive's Avatar
 
Join Date: Jun 2018
Location: Straubing
From the console log it looks like PaXoverRack removed the modules correctly.

The sink lusts you posted indicate otherwise. Can you please check once again?
__________________
Want more of the good stuff? -> https://t-5.eu/
  Reply With Quote
Old 2nd December 2019, 07:13 PM   #548
dave4 is offline dave4
diyAudio Member
 
Join Date: Nov 2015
Hi, I think have a similar problem to the one below, but am using Linux Mint 19.1 MATE

Quote:
Originally Posted by DRONE7 View Post
Hi Jürgen
I have just installed Ubuntu server and the lubuntu desktop on a Pi 2B
When I try to start PAXR it asks and then downloads the pulsectl no problems but then when it tries to add zodb I get this error...
Code:
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-6wlywkmc/BTrees/
any suggestions ?
PAXR installs fine, but when I try to run it I get the following error -

WARNING:
Could not find python module 'ZODB'.
Should we try to install it for you?
(This may take a few seconds or minutes.

I click yes to install, it appears to fail and I get the following error -

ERROR: module 'ZODB' not found.
Manual installation: 'pip3 install zodb'

Code:
q@q:~$ pulseaudio-crossover-rack
qt5ct: using qt5ct plugin
libpng warning: iCCP: known incorrect sRGB profile
qt5ct: D-Bus global menu: no
Collecting zodb
  Using cached https://files.pythonhosted.org/packa...3-none-any.whl
Collecting zope.interface (from zodb)
  Using cached https://files.pythonhosted.org/packa...ux1_x86_64.whl
Collecting ZConfig (from zodb)
  Using cached https://files.pythonhosted.org/packa...3-none-any.whl
Collecting zodbpickle>=1.0.1 (from zodb)
  Using cached https://files.pythonhosted.org/packa...ux1_x86_64.whl
Collecting transaction>=2.4 (from zodb)
  Using cached https://files.pythonhosted.org/packa...3-none-any.whl
Collecting six (from zodb)
  Using cached https://files.pythonhosted.org/packa...3-none-any.whl
Collecting BTrees>=4.2.0 (from zodb)
  Using cached https://files.pythonhosted.org/packa...ux1_x86_64.whl
Collecting persistent>=4.4.0 (from zodb)
  Using cached https://files.pythonhosted.org/packa...t-4.5.1.tar.gz
    Complete output from command python setup.py egg_info:
    WARNING: The wheel package is not available.
    WARNING: The wheel package is not available.
    ERROR: Failed to build one or more wheels
    Traceback (most recent call last):
      File "/home/q/.local/lib/python3.6/site-packages/setuptools/installer.py", line 128, in fetch_build_egg
        subprocess.check_call(cmd)
      File "/usr/lib/python3.6/subprocess.py", line 311, in check_call
        raise CalledProcessError(retcode, cmd)
    subprocess.CalledProcessError: Command '['/usr/bin/python3', '-m', 'pip', '--disable-pip-version-check', 'wheel', '--no-deps', '-w', '/tmp/tmp1avrwby8', '--quiet', 'pycparser']' returned non-zero exit status 1.
    
    During handling of the above exception, another exception occurred:
    
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-build-l_jlt7lj/persistent/setup.py", line 138, in <module>
        entry_points={})
      File "/home/q/.local/lib/python3.6/site-packages/setuptools/__init__.py", line 144, in setup
        _install_setup_requires(attrs)
      File "/home/q/.local/lib/python3.6/site-packages/setuptools/__init__.py", line 139, in _install_setup_requires
        dist.fetch_build_eggs(dist.setup_requires)
      File "/home/q/.local/lib/python3.6/site-packages/setuptools/dist.py", line 721, in fetch_build_eggs
        replace_conflicting=True,
      File "/home/q/.local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 782, in resolve
        replace_conflicting=replace_conflicting
      File "/home/q/.local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 1065, in best_match
        return self.obtain(req, installer)
      File "/home/q/.local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 1077, in obtain
        return installer(requirement)
      File "/home/q/.local/lib/python3.6/site-packages/setuptools/dist.py", line 777, in fetch_build_egg
        return fetch_build_egg(self, req)
      File "/home/q/.local/lib/python3.6/site-packages/setuptools/installer.py", line 130, in fetch_build_egg
        raise DistutilsError(str(e))
    distutils.errors.DistutilsError: Command '['/usr/bin/python3', '-m', 'pip', '--disable-pip-version-check', 'wheel', '--no-deps', '-w', '/tmp/tmp1avrwby8', '--quiet', 'pycparser']' returned non-zero exit status 1.
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-l_jlt7lj/persistent/
I have tried to install ZODB manually and get the following errors

Code:
q@q:~$ pip3 install ZODB
Collecting ZODB
  Using cached https://files.pythonhosted.org/packa...3-none-any.whl
Collecting six (from ZODB)
  Using cached https://files.pythonhosted.org/packa...3-none-any.whl
Collecting zc.lockfile (from ZODB)
  Using cached https://files.pythonhosted.org/packa...3-none-any.whl
Collecting zope.interface (from ZODB)
  Using cached https://files.pythonhosted.org/packa...ux1_x86_64.whl
Collecting ZConfig (from ZODB)
  Using cached https://files.pythonhosted.org/packa...3-none-any.whl
Collecting BTrees>=4.2.0 (from ZODB)
  Using cached https://files.pythonhosted.org/packa...ux1_x86_64.whl
Collecting transaction>=2.4 (from ZODB)
  Using cached https://files.pythonhosted.org/packa...3-none-any.whl
Collecting persistent>=4.4.0 (from ZODB)
  Using cached https://files.pythonhosted.org/packa...t-4.5.1.tar.gz
    Complete output from command python setup.py egg_info:
    WARNING: The wheel package is not available.
    WARNING: The wheel package is not available.
    ERROR: Failed to build one or more wheels
    Traceback (most recent call last):
      File "/home/q/.local/lib/python3.6/site-packages/setuptools/installer.py", line 128, in fetch_build_egg
        subprocess.check_call(cmd)
      File "/usr/lib/python3.6/subprocess.py", line 311, in check_call
        raise CalledProcessError(retcode, cmd)
    subprocess.CalledProcessError: Command '['/usr/bin/python3', '-m', 'pip', '--disable-pip-version-check', 'wheel', '--no-deps', '-w', '/tmp/tmpaa_3ixx_', '--quiet', 'pycparser']' returned non-zero exit status 1.
    
    During handling of the above exception, another exception occurred:
    
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-build-nw2y6jwk/persistent/setup.py", line 138, in <module>
        entry_points={})
      File "/home/q/.local/lib/python3.6/site-packages/setuptools/__init__.py", line 144, in setup
        _install_setup_requires(attrs)
      File "/home/q/.local/lib/python3.6/site-packages/setuptools/__init__.py", line 139, in _install_setup_requires
        dist.fetch_build_eggs(dist.setup_requires)
      File "/home/q/.local/lib/python3.6/site-packages/setuptools/dist.py", line 721, in fetch_build_eggs
        replace_conflicting=True,
      File "/home/q/.local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 782, in resolve
        replace_conflicting=replace_conflicting
      File "/home/q/.local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 1065, in best_match
        return self.obtain(req, installer)
      File "/home/q/.local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 1077, in obtain
        return installer(requirement)
      File "/home/q/.local/lib/python3.6/site-packages/setuptools/dist.py", line 777, in fetch_build_egg
        return fetch_build_egg(self, req)
      File "/home/q/.local/lib/python3.6/site-packages/setuptools/installer.py", line 130, in fetch_build_egg
        raise DistutilsError(str(e))
    distutils.errors.DistutilsError: Command '['/usr/bin/python3', '-m', 'pip', '--disable-pip-version-check', 'wheel', '--no-deps', '-w', '/tmp/tmpaa_3ixx_', '--quiet', 'pycparser']' returned non-zero exit status 1.
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-nw2y6jwk/persistent/
q@q:~$
I can see there are errors in there but have limited Linux knowledge, could anyone help? Is there more information you will need?

Thanks in advance!
  Reply With Quote
Old 3rd December 2019, 01:45 PM   #549
dave4 is offline dave4
diyAudio Member
 
Join Date: Nov 2015
Hi, I am still struggling to get the program to run,

I wondered if it was a problem with my PC so
I have installed PAXR on a Linux Mint 19.2 Live USB as follows


Code:
mint@mint:~$ wget https://t-5.eu/debian/pubkey.txt -O - | sudo apt-key add -
--2019-12-03 13:12:22--  https://t-5.eu/debian/pubkey.txt
Resolving t-5.eu (t-5.eu)... 178.27.143.52
Connecting to t-5.eu (t-5.eu)|178.27.143.52|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1739 (1.7K) [text/plain]
Saving to: ‘STDOUT’

-                   100%[===================>]   1.70K  --.-KB/s    in 0s      

2019-12-03 13:12:23 (19.0 MB/s) - written to stdout [1739/1739]

OK
mint@mint:~$ sudo bash -c "echo deb Index of /debian repo main > /etc/apt/sources.list.d/t-5.eu.list"
mint@mint:~$ sudo apt-get update
Ign:1 cdrom://Linux Mint 19.2 _Tina_ - Release amd64 20190729 bionic InRelease
Err:2 cdrom://Linux Mint 19.2 _Tina_ - Release amd64 20190729 bionic Release
  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Get:3 Index of /ubuntu bionic InRelease [10.2 kB]
Hit:4 Index of /ubuntu bionic InRelease                        
Get:5 Index of /ubuntu bionic-updates InRelease [88.7 kB]      
Ign:6 http://packages.linuxmint.com tina InRelease                             
Get:7 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]    
Get:8 Index of /ubuntu bionic-backports InRelease [74.6 kB]    
Get:9 Index of /ubuntu bionic/partner amd64 Packages [2316 B]
Get:10 http://packages.linuxmint.com tina Release [24.2 kB]                    
Get:11 https://t-5.eu/debian repo InRelease [13.6 kB]                          
Get:12 Index of /ubuntu bionic/partner i386 Packages [2320 B]
Get:13 Index of /ubuntu bionic-updates/main amd64 Packages [813 kB]
Get:14 http://packages.linuxmint.com tina Release.gpg [819 B]                  
Get:15 https://t-5.eu/debian repo/main amd64 Packages [3973 B]                 
Get:16 https://t-5.eu/debian repo/main i386 Packages [3659 B]                  
Get:17 http://security.ubuntu.com/ubuntu bionic-security/main i386 Packages [413 kB]
Get:18 http://packages.linuxmint.com tina/main i386 Packages [13.7 kB]         
Get:19 http://packages.linuxmint.com tina/main amd64 Packages [14.3 kB]        
Get:20 http://packages.linuxmint.com tina/upstream amd64 Packages [37.3 kB]    
Get:21 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages [589 kB]
Get:22 Index of /ubuntu bionic-updates/main i386 Packages [624 kB]
Get:23 http://packages.linuxmint.com tina/upstream i386 Packages [37.4 kB]     
Get:24 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en [193 kB]
Get:25 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [38.6 kB]
Get:26 http://security.ubuntu.com/ubuntu bionic-security/restricted i386 Packages [4280 B]
Get:27 http://security.ubuntu.com/ubuntu bionic-security/restricted amd64 Packages [14.6 kB]
Get:28 http://security.ubuntu.com/ubuntu bionic-security/restricted Translation-en [4600 B]
Get:29 http://security.ubuntu.com/ubuntu bionic-security/universe i386 Packages [600 kB]
Get:30 http://packages.linuxmint.com tina/import i386 Packages [7228 B]        
Get:31 http://packages.linuxmint.com tina/import amd64 Packages [8435 B]       
Get:32 http://packages.linuxmint.com tina/backport i386 Packages [53.5 kB]     
Get:33 http://packages.linuxmint.com tina/backport amd64 Packages [53.6 kB]    
Get:34 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [626 kB]
Get:35 Index of /ubuntu bionic-updates/main Translation-en [287 kB]
Get:36 Index of /ubuntu bionic-updates/main amd64 DEP-11 Metadata [295 kB]
Get:37 Index of /ubuntu bionic-updates/restricted i386 Packages [9260 B]
Get:38 Index of /ubuntu bionic-updates/restricted amd64 Packages [23.4 kB]
Get:39 Index of /ubuntu bionic-updates/restricted Translation-en [6436 B]
Get:40 Index of /ubuntu bionic-updates/universe i386 Packages [996 kB]
Get:41 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en [209 kB]
Get:42 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [42.0 kB]
Get:43 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 Packages [6116 B]
Get:44 http://security.ubuntu.com/ubuntu bionic-security/multiverse i386 Packages [4292 B]
Get:45 http://security.ubuntu.com/ubuntu bionic-security/multiverse Translation-en [2600 B]
Get:46 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 DEP-11 Metadata [2464 B]
Get:47 Index of /ubuntu bionic-updates/universe amd64 Packages [1032 kB]
Get:48 Index of /ubuntu bionic-updates/universe Translation-en [319 kB]
Get:49 Index of /ubuntu bionic-updates/universe amd64 DEP-11 Metadata [264 kB]
Get:50 Index of /ubuntu bionic-updates/multiverse i386 Packages [6924 B]
Get:51 Index of /ubuntu bionic-updates/multiverse amd64 Packages [8736 B]
Get:52 Index of /ubuntu bionic-updates/multiverse Translation-en [4080 B]
Get:53 Index of /ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2464 B]
Get:54 Index of /ubuntu bionic-backports/universe i386 Packages [4028 B]
Get:55 Index of /ubuntu bionic-backports/universe amd64 Packages [4028 B]
Get:56 Index of /ubuntu bionic-backports/universe Translation-en [1856 B]
Get:57 Index of /ubuntu bionic-backports/universe amd64 DEP-11 Metadata [7976 B]
Reading package lists... Done                                                  
E: The repository 'cdrom://Linux Mint 19.2 _Tina_ - Release amd64 20190729 bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
mint@mint:~$ sudo apt-get install pulseaudio-crossover-rack
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  dh-python fonts-lyx ladspa-t5-plugins libexpat1 libexpat1-dev libffi-dev
  libjs-jquery libjs-jquery-ui libpython3-dev libpython3.6 libpython3.6-dev
  libpython3.6-minimal libpython3.6-stdlib libqt5designer5 libqt5help5
  libqt5printsupport5 libqt5sql5 libqt5test5 libqt5xml5 python-matplotlib-data
  python-pip-whl python3-cycler python3-dateutil python3-decorator python3-dev
  python3-distutils python3-lib2to3 python3-matplotlib python3-numpy
  python3-pip python3-pyparsing python3-pyqt5 python3-qt5-t5darkstyle
  python3-scipy python3-sip python3-tz python3.6 python3.6-dev
  python3.6-minimal ttf-bitstream-vera
Suggested packages:
  libjs-jquery-ui-docs python-cycler-doc dvipng ffmpeg inkscape ipython3
  python-matplotlib-doc python3-cairocffi python3-gobject python3-nose
  python3-pyqt4 python3-tornado texlive-extra-utils texlive-latex-extra
  ttf-staypuft gfortran python-numpy-doc python3-numpy-dbg
  python-pyparsing-doc python3-pyqt5-dbg python-scipy-doc python3.6-venv
  python3.6-doc binfmt-support
Recommended packages:
  javascript-common libqt5sql5-sqlite | libqt5sql5-mysql | libqt5sql5-odbc
  | libqt5sql5-psql | libqt5sql5-tds | libqt5sql5-ibase python3-tk
  build-essential python3-setuptools python3-wheel g++ | c++-compiler
The following NEW packages will be installed:
  dh-python fonts-lyx ladspa-t5-plugins libexpat1-dev libffi-dev libjs-jquery
  libjs-jquery-ui libpython3-dev libpython3.6-dev libqt5designer5 libqt5help5
  libqt5printsupport5 libqt5sql5 libqt5test5 libqt5xml5
  pulseaudio-crossover-rack python-matplotlib-data python-pip-whl
  python3-cycler python3-dateutil python3-decorator python3-dev
  python3-distutils python3-lib2to3 python3-matplotlib python3-numpy
  python3-pip python3-pyparsing python3-pyqt5 python3-qt5-t5darkstyle
  python3-scipy python3-sip python3-tz python3.6-dev ttf-bitstream-vera
The following packages will be upgraded:
  libexpat1 libpython3.6 libpython3.6-minimal libpython3.6-stdlib python3.6
  python3.6-minimal
6 upgraded, 35 newly installed, 0 to remove and 314 not upgraded.
Need to get 79.6 MB of archives.
After this operation, 188 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 Index of /ubuntu bionic-updates/main amd64 libpython3.6 amd64 3.6.9-1~18.04 [1414 kB]
Get:2 https://t-5.eu/debian repo/main amd64 ladspa-t5-plugins amd64 1.14 [50.7 kB]
Get:3 https://t-5.eu/debian repo/main amd64 python3-qt5-t5darkstyle all 0.10 [19.3 kB]
Get:4 https://t-5.eu/debian repo/main amd64 pulseaudio-crossover-rack all 1.46 [298 kB]
Get:5 Index of /ubuntu bionic-updates/main amd64 libpython3.6-minimal amd64 3.6.9-1~18.04 [533 kB]
Get:6 Index of /ubuntu bionic-updates/main amd64 libpython3.6-stdlib amd64 3.6.9-1~18.04 [1709 kB]
Get:7 Index of /ubuntu bionic-updates/main amd64 python3.6-minimal amd64 3.6.9-1~18.04 [1610 kB]
Get:8 Index of /ubuntu bionic-updates/main amd64 python3.6 amd64 3.6.9-1~18.04 [203 kB]
Get:9 Index of /ubuntu bionic-updates/main amd64 libexpat1 amd64 2.2.5-3ubuntu0.2 [80.5 kB]
Get:10 Index of /ubuntu bionic/universe amd64 ttf-bitstream-vera all 1.10-8 [352 kB]
Get:11 Index of /ubuntu bionic-updates/main amd64 python3-lib2to3 all 3.6.9-1~18.04 [77.4 kB]
Get:12 Index of /ubuntu bionic-updates/main amd64 python3-distutils all 3.6.9-1~18.04 [144 kB]
Get:13 Index of /ubuntu bionic/main amd64 dh-python all 3.20180325ubuntu2 [89.2 kB]
Get:14 Index of /ubuntu bionic-updates/universe amd64 fonts-lyx all 2.2.4-0ubuntu0.18.04.1 [155 kB]
Get:15 Index of /ubuntu bionic-updates/main amd64 libexpat1-dev amd64 2.2.5-3ubuntu0.2 [122 kB]
Get:16 Index of /ubuntu bionic/main amd64 libjs-jquery all 3.2.1-1 [152 kB]
Get:17 Index of /ubuntu bionic/universe amd64 libjs-jquery-ui all 1.12.1+dfsg-5 [232 kB]
Get:18 Index of /ubuntu bionic-updates/main amd64 libpython3.6-dev amd64 3.6.9-1~18.04 [44.8 MB]
Get:19 Index of /ubuntu bionic-updates/main amd64 libpython3-dev amd64 3.6.7-1~18.04 [7328 B]
Get:20 Index of /ubuntu bionic-updates/main amd64 libqt5xml5 amd64 5.9.5+dfsg-0ubuntu2.4 [99.5 kB]
Get:21 Index of /ubuntu bionic/universe amd64 libqt5designer5 amd64 5.9.5-0ubuntu1 [2761 kB]
Get:22 Index of /ubuntu bionic-updates/main amd64 libqt5sql5 amd64 5.9.5+dfsg-0ubuntu2.4 [115 kB]
Get:23 Index of /ubuntu bionic/universe amd64 libqt5help5 amd64 5.9.5-0ubuntu1 [133 kB]
Get:24 Index of /ubuntu bionic-updates/main amd64 libqt5printsupport5 amd64 5.9.5+dfsg-0ubuntu2.4 [178 kB]
Get:25 Index of /ubuntu bionic-updates/main amd64 libqt5test5 amd64 5.9.5+dfsg-0ubuntu2.4 [98.2 kB]
Get:26 Index of /ubuntu bionic/universe amd64 python3-sip amd64 4.19.7+dfsg-1 [75.2 kB]
Get:27 Index of /ubuntu bionic/universe amd64 python3-pyqt5 amd64 5.10.1+dfsg-1ubuntu2 [2268 kB]
Get:28 Index of /ubuntu bionic/main amd64 python3-dateutil all 2.6.1-1 [52.3 kB]
Get:29 Index of /ubuntu bionic/universe amd64 python-matplotlib-data all 2.1.1-2ubuntu3 [3774 kB]
Get:30 Index of /ubuntu bionic/main amd64 python3-pyparsing all 2.2.0+dfsg1-2 [52.2 kB]
Get:31 Index of /ubuntu bionic/main amd64 python3-tz all 2018.3-2 [25.1 kB]
Get:32 Index of /ubuntu bionic/main amd64 python3-numpy amd64 1:1.13.3-2ubuntu1 [1943 kB]
Get:33 Index of /ubuntu bionic/universe amd64 python3-cycler all 0.10.0-1 [7622 B]
Get:34 Index of /ubuntu bionic/universe amd64 python3-matplotlib amd64 2.1.1-2ubuntu3 [3907 kB]
Get:35 Index of /ubuntu bionic/universe amd64 python3-decorator all 4.1.2-1 [9364 B]
Get:36 Index of /ubuntu bionic/universe amd64 python3-scipy amd64 0.19.1-2ubuntu1 [9619 kB]
Get:37 Index of /ubuntu bionic-updates/universe amd64 python-pip-whl all 9.0.1-2.3~ubuntu1.18.04.1 [1653 kB]
Get:38 Index of /ubuntu bionic-updates/universe amd64 python3-pip all 9.0.1-2.3~ubuntu1.18.04.1 [114 kB]
Get:39 Index of /ubuntu bionic-updates/main amd64 python3.6-dev amd64 3.6.9-1~18.04 [508 kB]
Get:40 Index of /ubuntu bionic-updates/main amd64 python3-dev amd64 3.6.7-1~18.04 [1288 B]
Get:41 Index of /ubuntu bionic/main amd64 libffi-dev amd64 3.2.1-8 [156 kB]
Fetched 79.6 MB in 60s (1334 kB/s)                                             
Extracting templates from packages: 100%
(Reading database ... 305501 files and directories currently installed.)
Preparing to unpack .../libpython3.6_3.6.9-1~18.04_amd64.deb ...
Unpacking libpython3.6:amd64 (3.6.9-1~18.04) over (3.6.8-1~18.04.1) ...
Preparing to unpack .../libpython3.6-minimal_3.6.9-1~18.04_amd64.deb ...
Unpacking libpython3.6-minimal:amd64 (3.6.9-1~18.04) over (3.6.8-1~18.04.1) ...
Setting up libpython3.6-minimal:amd64 (3.6.9-1~18.04) ...
(Reading database ... 305501 files and directories currently installed.)
Preparing to unpack .../libpython3.6-stdlib_3.6.9-1~18.04_amd64.deb ...
Unpacking libpython3.6-stdlib:amd64 (3.6.9-1~18.04) over (3.6.8-1~18.04.1) ...
Setting up libpython3.6-stdlib:amd64 (3.6.9-1~18.04) ...
(Reading database ... 305501 files and directories currently installed.)
Preparing to unpack .../python3.6-minimal_3.6.9-1~18.04_amd64.deb ...
Unpacking python3.6-minimal (3.6.9-1~18.04) over (3.6.8-1~18.04.1) ...
Setting up python3.6-minimal (3.6.9-1~18.04) ...
(Reading database ... 305501 files and directories currently installed.)
Preparing to unpack .../python3.6_3.6.9-1~18.04_amd64.deb ...
Unpacking python3.6 (3.6.9-1~18.04) over (3.6.8-1~18.04.1) ...
Setting up python3.6 (3.6.9-1~18.04) ...
(Reading database ... 305501 files and directories currently installed.)
Preparing to unpack .../libexpat1_2.2.5-3ubuntu0.2_amd64.deb ...
Unpacking libexpat1:amd64 (2.2.5-3ubuntu0.2) over (2.2.5-3ubuntu0.1) ...
Setting up libexpat1:amd64 (2.2.5-3ubuntu0.2) ...
Selecting previously unselected package ttf-bitstream-vera.
(Reading database ... 305501 files and directories currently installed.)
Preparing to unpack .../ttf-bitstream-vera_1.10-8_all.deb ...
Unpacking ttf-bitstream-vera (1.10-8) ...
Setting up ttf-bitstream-vera (1.10-8) ...
Selecting previously unselected package python3-lib2to3.
(Reading database ... 305519 files and directories currently installed.)
Preparing to unpack .../00-python3-lib2to3_3.6.9-1~18.04_all.deb ...
Unpacking python3-lib2to3 (3.6.9-1~18.04) ...
Selecting previously unselected package python3-distutils.
Preparing to unpack .../01-python3-distutils_3.6.9-1~18.04_all.deb ...
Unpacking python3-distutils (3.6.9-1~18.04) ...
Selecting previously unselected package dh-python.
Preparing to unpack .../02-dh-python_3.20180325ubuntu2_all.deb ...
Unpacking dh-python (3.20180325ubuntu2) ...
Selecting previously unselected package fonts-lyx.
Preparing to unpack .../03-fonts-lyx_2.2.4-0ubuntu0.18.04.1_all.deb ...
Unpacking fonts-lyx (2.2.4-0ubuntu0.18.04.1) ...
Selecting previously unselected package ladspa-t5-plugins.
Preparing to unpack .../04-ladspa-t5-plugins_1.14_amd64.deb ...
Unpacking ladspa-t5-plugins (1.14) ...
Selecting previously unselected package libexpat1-dev:amd64.
Preparing to unpack .../05-libexpat1-dev_2.2.5-3ubuntu0.2_amd64.deb ...
Unpacking libexpat1-dev:amd64 (2.2.5-3ubuntu0.2) ...
Selecting previously unselected package libjs-jquery.
Preparing to unpack .../06-libjs-jquery_3.2.1-1_all.deb ...
Unpacking libjs-jquery (3.2.1-1) ...
Selecting previously unselected package libjs-jquery-ui.
Preparing to unpack .../07-libjs-jquery-ui_1.12.1+dfsg-5_all.deb ...
Unpacking libjs-jquery-ui (1.12.1+dfsg-5) ...
Selecting previously unselected package libpython3.6-dev:amd64.
Preparing to unpack .../08-libpython3.6-dev_3.6.9-1~18.04_amd64.deb ...
Unpacking libpython3.6-dev:amd64 (3.6.9-1~18.04) ...
Selecting previously unselected package libpython3-dev:amd64.
Preparing to unpack .../09-libpython3-dev_3.6.7-1~18.04_amd64.deb ...
Unpacking libpython3-dev:amd64 (3.6.7-1~18.04) ...
Selecting previously unselected package libqt5xml5:amd64.
Preparing to unpack .../10-libqt5xml5_5.9.5+dfsg-0ubuntu2.4_amd64.deb ...
Unpacking libqt5xml5:amd64 (5.9.5+dfsg-0ubuntu2.4) ...
Selecting previously unselected package libqt5designer5:amd64.
Preparing to unpack .../11-libqt5designer5_5.9.5-0ubuntu1_amd64.deb ...
Unpacking libqt5designer5:amd64 (5.9.5-0ubuntu1) ...
Selecting previously unselected package libqt5sql5:amd64.
Preparing to unpack .../12-libqt5sql5_5.9.5+dfsg-0ubuntu2.4_amd64.deb ...
Unpacking libqt5sql5:amd64 (5.9.5+dfsg-0ubuntu2.4) ...
Selecting previously unselected package libqt5help5:amd64.
Preparing to unpack .../13-libqt5help5_5.9.5-0ubuntu1_amd64.deb ...
Unpacking libqt5help5:amd64 (5.9.5-0ubuntu1) ...
Selecting previously unselected package libqt5printsupport5:amd64.
Preparing to unpack .../14-libqt5printsupport5_5.9.5+dfsg-0ubuntu2.4_amd64.deb ...
Unpacking libqt5printsupport5:amd64 (5.9.5+dfsg-0ubuntu2.4) ...
Selecting previously unselected package libqt5test5:amd64.
Preparing to unpack .../15-libqt5test5_5.9.5+dfsg-0ubuntu2.4_amd64.deb ...
Unpacking libqt5test5:amd64 (5.9.5+dfsg-0ubuntu2.4) ...
Selecting previously unselected package python3-sip.
Preparing to unpack .../16-python3-sip_4.19.7+dfsg-1_amd64.deb ...
Unpacking python3-sip (4.19.7+dfsg-1) ...
Selecting previously unselected package python3-pyqt5.
Preparing to unpack .../17-python3-pyqt5_5.10.1+dfsg-1ubuntu2_amd64.deb ...
Unpacking python3-pyqt5 (5.10.1+dfsg-1ubuntu2) ...
Selecting previously unselected package python3-dateutil.
Preparing to unpack .../18-python3-dateutil_2.6.1-1_all.deb ...
Unpacking python3-dateutil (2.6.1-1) ...
Selecting previously unselected package python-matplotlib-data.
Preparing to unpack .../19-python-matplotlib-data_2.1.1-2ubuntu3_all.deb ...
Unpacking python-matplotlib-data (2.1.1-2ubuntu3) ...
Selecting previously unselected package python3-pyparsing.
Preparing to unpack .../20-python3-pyparsing_2.2.0+dfsg1-2_all.deb ...
Unpacking python3-pyparsing (2.2.0+dfsg1-2) ...
Selecting previously unselected package python3-tz.
Preparing to unpack .../21-python3-tz_2018.3-2_all.deb ...
Unpacking python3-tz (2018.3-2) ...
Selecting previously unselected package python3-numpy.
Preparing to unpack .../22-python3-numpy_1%3a1.13.3-2ubuntu1_amd64.deb ...
Unpacking python3-numpy (1:1.13.3-2ubuntu1) ...
Selecting previously unselected package python3-cycler.
Preparing to unpack .../23-python3-cycler_0.10.0-1_all.deb ...
Unpacking python3-cycler (0.10.0-1) ...
Selecting previously unselected package python3-matplotlib.
Preparing to unpack .../24-python3-matplotlib_2.1.1-2ubuntu3_amd64.deb ...
Unpacking python3-matplotlib (2.1.1-2ubuntu3) ...
Selecting previously unselected package python3-decorator.
Preparing to unpack .../25-python3-decorator_4.1.2-1_all.deb ...
Unpacking python3-decorator (4.1.2-1) ...
Selecting previously unselected package python3-scipy.
Preparing to unpack .../26-python3-scipy_0.19.1-2ubuntu1_amd64.deb ...
Unpacking python3-scipy (0.19.1-2ubuntu1) ...
Selecting previously unselected package python3-qt5-t5darkstyle.
Preparing to unpack .../27-python3-qt5-t5darkstyle_0.10_all.deb ...
Unpacking python3-qt5-t5darkstyle (0.10) ...
Selecting previously unselected package python-pip-whl.
Preparing to unpack .../28-python-pip-whl_9.0.1-2.3~ubuntu1.18.04.1_all.deb ...
Unpacking python-pip-whl (9.0.1-2.3~ubuntu1.18.04.1) ...
Selecting previously unselected package python3-pip.
Preparing to unpack .../29-python3-pip_9.0.1-2.3~ubuntu1.18.04.1_all.deb ...
Unpacking python3-pip (9.0.1-2.3~ubuntu1.18.04.1) ...
Selecting previously unselected package python3.6-dev.
Preparing to unpack .../30-python3.6-dev_3.6.9-1~18.04_amd64.deb ...
Unpacking python3.6-dev (3.6.9-1~18.04) ...
Selecting previously unselected package python3-dev.
Preparing to unpack .../31-python3-dev_3.6.7-1~18.04_amd64.deb ...
Unpacking python3-dev (3.6.7-1~18.04) ...
Selecting previously unselected package libffi-dev:amd64.
Preparing to unpack .../32-libffi-dev_3.2.1-8_amd64.deb ...
Unpacking libffi-dev:amd64 (3.2.1-8) ...
Selecting previously unselected package pulseaudio-crossover-rack.
Preparing to unpack .../33-pulseaudio-crossover-rack_1.46_all.deb ...
Unpacking pulseaudio-crossover-rack (1.46) ...
Setting up ladspa-t5-plugins (1.14) ...
Setting up libjs-jquery (3.2.1-1) ...
Setting up python-pip-whl (9.0.1-2.3~ubuntu1.18.04.1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for desktop-file-utils (0.23+linuxmint6) ...
Processing triggers for install-info (6.5.0.dfsg.1-2) ...
Setting up python3-numpy (1:1.13.3-2ubuntu1) ...
Setting up python3-qt5-t5darkstyle (0.10) ...
Setting up libqt5test5:amd64 (5.9.5+dfsg-0ubuntu2.4) ...
Setting up python3-pyparsing (2.2.0+dfsg1-2) ...
Setting up python3-cycler (0.10.0-1) ...
Setting up libffi-dev:amd64 (3.2.1-8) ...
Setting up libqt5printsupport5:amd64 (5.9.5+dfsg-0ubuntu2.4) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Setting up libqt5xml5:amd64 (5.9.5+dfsg-0ubuntu2.4) ...
Processing triggers for doc-base (0.10.8) ...
Processing 38 changed doc-base files, 2 added doc-base files...
Registering documents with scrollkeeper...
Setting up libjs-jquery-ui (1.12.1+dfsg-5) ...
Setting up libqt5sql5:amd64 (5.9.5+dfsg-0ubuntu2.4) ...
Setting up python3-sip (4.19.7+dfsg-1) ...
Setting up libexpat1-dev:amd64 (2.2.5-3ubuntu0.2) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Processing triggers for shared-mime-info (1.9-2) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Setting up python3-lib2to3 (3.6.9-1~18.04) ...
Setting up libqt5designer5:amd64 (5.9.5-0ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Setting up python3-decorator (4.1.2-1) ...
Setting up python3-tz (2018.3-2) ...
Setting up python3-distutils (3.6.9-1~18.04) ...
Processing triggers for fontconfig (2.12.6-0ubuntu2) ...
Setting up python3-dateutil (2.6.1-1) ...
Setting up libpython3.6:amd64 (3.6.9-1~18.04) ...
Setting up fonts-lyx (2.2.4-0ubuntu0.18.04.1) ...
Setting up python3-scipy (0.19.1-2ubuntu1) ...
Setting up python-matplotlib-data (2.1.1-2ubuntu3) ...
Setting up libpython3.6-dev:amd64 (3.6.9-1~18.04) ...
Setting up libqt5help5:amd64 (5.9.5-0ubuntu1) ...
Setting up python3-pip (9.0.1-2.3~ubuntu1.18.04.1) ...
Setting up python3.6-dev (3.6.9-1~18.04) ...
Setting up python3-matplotlib (2.1.1-2ubuntu3) ...
Setting up dh-python (3.20180325ubuntu2) ...
Setting up libpython3-dev:amd64 (3.6.7-1~18.04) ...
Setting up python3-pyqt5 (5.10.1+dfsg-1ubuntu2) ...
Setting up python3-dev (3.6.7-1~18.04) ...
Setting up pulseaudio-crossover-rack (1.46) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
When I try to run the program I get a similar error to the one in my previous post


Code:
 mint@mint:~$ pulseaudio-crossover-rack
qt5ct: using qt5ct plugin
libpng warning: iCCP: known incorrect sRGB profile
qt5ct: D-Bus global menu: no
Collecting pulsectl
  Downloading https://files.pythonhosted.org/packa...3-none-any.whl
Collecting setuptools (from pulsectl)
  Downloading https://files.pythonhosted.org/packa...3-none-any.whl (583kB)
    100% |████████████████████████████████| 583kB 845kB/s 
Installing collected packages: setuptools, pulsectl
Successfully installed pulsectl-19.10.4 setuptools-42.0.2
mint@mint:~$ qt5ct: using qt5ct plugin
libpng warning: iCCP: known incorrect sRGB profile
qt5ct: D-Bus global menu: no
Collecting zodb
  Downloading https://files.pythonhosted.org/packa...3-none-any.whl (412kB)
    100% |████████████████████████████████| 419kB 1.0MB/s 
Collecting persistent>=4.4.0 (from zodb)
  Downloading https://files.pythonhosted.org/packa...t-4.5.1.tar.gz (107kB)
    100% |████████████████████████████████| 112kB 1.1MB/s 
    Complete output from command python setup.py egg_info:
    WARNING: The wheel package is not available.
    WARNING: The wheel package is not available.
    ERROR: Failed to build one or more wheels
    Traceback (most recent call last):
      File "/home/mint/.local/lib/python3.6/site-packages/setuptools/installer.py", line 128, in fetch_build_egg
        subprocess.check_call(cmd)
      File "/usr/lib/python3.6/subprocess.py", line 311, in check_call
        raise CalledProcessError(retcode, cmd)
    subprocess.CalledProcessError: Command '['/usr/bin/python3', '-m', 'pip', '--disable-pip-version-check', 'wheel', '--no-deps', '-w', '/tmp/tmpkgpfm5of', '--quiet', 'pycparser']' returned non-zero exit status 1.
    
    During handling of the above exception, another exception occurred:
    
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-build-cgovrnqu/persistent/setup.py", line 138, in <module>
        entry_points={})
      File "/home/mint/.local/lib/python3.6/site-packages/setuptools/__init__.py", line 144, in setup
        _install_setup_requires(attrs)
      File "/home/mint/.local/lib/python3.6/site-packages/setuptools/__init__.py", line 139, in _install_setup_requires
        dist.fetch_build_eggs(dist.setup_requires)
      File "/home/mint/.local/lib/python3.6/site-packages/setuptools/dist.py", line 721, in fetch_build_eggs
        replace_conflicting=True,
      File "/home/mint/.local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 782, in resolve
        replace_conflicting=replace_conflicting
      File "/home/mint/.local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 1065, in best_match
        return self.obtain(req, installer)
      File "/home/mint/.local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 1077, in obtain
        return installer(requirement)
      File "/home/mint/.local/lib/python3.6/site-packages/setuptools/dist.py", line 777, in fetch_build_egg
        return fetch_build_egg(self, req)
      File "/home/mint/.local/lib/python3.6/site-packages/setuptools/installer.py", line 130, in fetch_build_egg
        raise DistutilsError(str(e))
    distutils.errors.DistutilsError: Command '['/usr/bin/python3', '-m', 'pip', '--disable-pip-version-check', 'wheel', '--no-deps', '-w', '/tmp/tmpkgpfm5of', '--quiet', 'pycparser']' returned non-zero exit status 1.
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-cgovrnqu/persistent/
ERROR: module 'ZODB' not found.
  Manual installation: 'pip3 install zodb'
I try to install zodb manually as suggested



Code:
mint@mint:~$ pip3 install zodb
Collecting zodb
  Using cached https://files.pythonhosted.org/packa...3-none-any.whl
Collecting zc.lockfile (from zodb)
  Downloading https://files.pythonhosted.org/packa...3-none-any.whl
Collecting persistent>=4.4.0 (from zodb)
  Using cached https://files.pythonhosted.org/packa...t-4.5.1.tar.gz
    Complete output from command python setup.py egg_info:
    WARNING: The wheel package is not available.
    WARNING: The wheel package is not available.
    ERROR: Failed to build one or more wheels
    Traceback (most recent call last):
      File "/home/mint/.local/lib/python3.6/site-packages/setuptools/installer.py", line 128, in fetch_build_egg
        subprocess.check_call(cmd)
      File "/usr/lib/python3.6/subprocess.py", line 311, in check_call
        raise CalledProcessError(retcode, cmd)
    subprocess.CalledProcessError: Command '['/usr/bin/python3', '-m', 'pip', '--disable-pip-version-check', 'wheel', '--no-deps', '-w', '/tmp/tmpmkjuyi79', '--quiet', 'pycparser']' returned non-zero exit status 1.
    
    During handling of the above exception, another exception occurred:
    
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-build-db1olk4y/persistent/setup.py", line 138, in <module>
        entry_points={})
      File "/home/mint/.local/lib/python3.6/site-packages/setuptools/__init__.py", line 144, in setup
        _install_setup_requires(attrs)
      File "/home/mint/.local/lib/python3.6/site-packages/setuptools/__init__.py", line 139, in _install_setup_requires
        dist.fetch_build_eggs(dist.setup_requires)
      File "/home/mint/.local/lib/python3.6/site-packages/setuptools/dist.py", line 721, in fetch_build_eggs
        replace_conflicting=True,
      File "/home/mint/.local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 782, in resolve
        replace_conflicting=replace_conflicting
      File "/home/mint/.local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 1065, in best_match
        return self.obtain(req, installer)
      File "/home/mint/.local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 1077, in obtain
        return installer(requirement)
      File "/home/mint/.local/lib/python3.6/site-packages/setuptools/dist.py", line 777, in fetch_build_egg
        return fetch_build_egg(self, req)
      File "/home/mint/.local/lib/python3.6/site-packages/setuptools/installer.py", line 130, in fetch_build_egg
        raise DistutilsError(str(e))
    distutils.errors.DistutilsError: Command '['/usr/bin/python3', '-m', 'pip', '--disable-pip-version-check', 'wheel', '--no-deps', '-w', '/tmp/tmpmkjuyi79', '--quiet', 'pycparser']' returned non-zero exit status 1.
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-db1olk4y/persistent/
I am pretty new to Linux so am I making a simple error in the installation?

Or a major one elsewhere? any guidance gratefully received!
  Reply With Quote
Old 4th December 2019, 05:31 PM   #550
dave4 is offline dave4
diyAudio Member
 
Join Date: Nov 2015
AllenB kindly suggested that as one of the errors refers to wheel files and they use pip that I should install pip, so here is what I did -

Code:
q@q:~$ sudo apt install python-pip
Reading package lists... Done
Building dependency tree       
Reading state information... Done
python-pip is already the newest version (9.0.1-2.3~ubuntu1.18.04.1).
The following packages were automatically installed and are no longer required:
  libclamav7 libllvm7 libllvm7:i386 linux-headers-4.15.0-46
  linux-headers-4.15.0-46-generic linux-headers-4.15.0-47
  linux-headers-4.15.0-47-generic linux-headers-4.15.0-50
  linux-headers-4.15.0-50-generic linux-headers-4.15.0-51
  linux-headers-4.15.0-51-generic linux-headers-4.15.0-52
  linux-headers-4.15.0-52-generic linux-headers-4.15.0-54
  linux-headers-4.15.0-54-generic linux-headers-4.15.0-55
  linux-headers-4.15.0-55-generic linux-headers-4.15.0-58
  linux-headers-4.15.0-58-generic linux-headers-4.15.0-60
  linux-headers-4.15.0-60-generic linux-headers-4.15.0-62
  linux-headers-4.15.0-62-generic linux-headers-4.15.0-64
  linux-headers-4.15.0-64-generic linux-headers-4.15.0-65
  linux-headers-4.15.0-65-generic linux-headers-4.15.0-66
  linux-headers-4.15.0-66-generic linux-headers-4.15.0-69
  linux-headers-4.15.0-69-generic linux-image-4.15.0-46-generic
  linux-image-4.15.0-47-generic linux-image-4.15.0-50-generic
  linux-image-4.15.0-51-generic linux-image-4.15.0-52-generic
  linux-image-4.15.0-54-generic linux-image-4.15.0-55-generic
  linux-image-4.15.0-58-generic linux-image-4.15.0-60-generic
  linux-image-4.15.0-62-generic linux-image-4.15.0-64-generic
  linux-image-4.15.0-65-generic linux-image-4.15.0-66-generic
  linux-image-4.15.0-69-generic linux-modules-4.15.0-46-generic
  linux-modules-4.15.0-47-generic linux-modules-4.15.0-50-generic
  linux-modules-4.15.0-51-generic linux-modules-4.15.0-52-generic
  linux-modules-4.15.0-54-generic linux-modules-4.15.0-55-generic
  linux-modules-4.15.0-58-generic linux-modules-4.15.0-60-generic
  linux-modules-4.15.0-62-generic linux-modules-4.15.0-64-generic
  linux-modules-4.15.0-65-generic linux-modules-4.15.0-66-generic
  linux-modules-4.15.0-69-generic linux-modules-extra-4.15.0-46-generic
  linux-modules-extra-4.15.0-47-generic linux-modules-extra-4.15.0-50-generic
  linux-modules-extra-4.15.0-51-generic linux-modules-extra-4.15.0-52-generic
  linux-modules-extra-4.15.0-54-generic linux-modules-extra-4.15.0-55-generic
  linux-modules-extra-4.15.0-58-generic linux-modules-extra-4.15.0-60-generic
  linux-modules-extra-4.15.0-62-generic linux-modules-extra-4.15.0-64-generic
  linux-modules-extra-4.15.0-65-generic linux-modules-extra-4.15.0-66-generic
  linux-modules-extra-4.15.0-69-generic python-restrictedpython python-tz
  python-zope.annotation python-zope.app.pagetemplate python-zope.broken
  python-zope.browser python-zope.browserpage python-zope.component
  python-zope.component-zcml python-zope.configuration python-zope.contenttype
  python-zope.datetime python-zope.dublincore python-zope.exceptions
  python-zope.hookable python-zope.i18n python-zope.i18nmessageid
  python-zope.lifecycleevent python-zope.location python-zope.pagetemplate
  python-zope.processlifetime python-zope.proxy python-zope.publisher
  python-zope.schema python-zope.security python-zope.size python-zope.tal
  python-zope.tales python-zope.traversing python-zope.untrustedpython
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
So I guess that means it is installed? when I run the command "pip list" I get
Code:
q@q:~$ pip list
DEPRECATION: The default format will switch to columns in the future. You can use --format=(legacy|columns) (or define a format=(legacy|columns) in your pip.conf under the[list] section) to disable this warning.
ccsm (0.9.13.1)
compizconfig-python (0.9.13.1)
configobj (5.0.6)
faulthandler (2.4)
feedparser (5.2.1)
funcsigs (1.0.2)
futures (3.2.0)
mock (2.0.0)
mutagen (1.38)
pbr (3.1.1)
persistent (4.2.2)
Pillow (5.1.0)
pip (9.0.1)
pycairo (1.16.2)
pycrypto (2.6.1)
pygobject (3.26.1)
pyparted (3.11.1)
python-apt (1.6.4)
python-xlib (0.20)
pytz (2018.3)
pyxdg (0.25)
quodlibet (3.9.1)
RestrictedPython (3.6.0)
setproctitle (1.1.10)
six (1.11.0)
transaction (1.4.3)
zc.lockfile (1.0.2)
ZConfig (3.1.0)
zdaemon (2.0.7)
ZODB3 (3.10.7)
zope.annotation (3.6.0)
zope.app.pagetemplate (3.11.2)
zope.broken (3.6.0)
zope.browser (2.1.0)
zope.browserpage (4.1.0a1)
zope.component (4.3.0)
zope.configuration (4.0.3)
zope.contenttype (4.1.0)
zope.datetime (3.4.1)
zope.dublincore (3.8.2)
zope.event (4.2.0)
zope.exceptions (4.0.8)
zope.hookable (4.0.4)
zope.i18n (4.1.0)
zope.i18nmessageid (4.0.3)
zope.interface (4.3.2)
zope.lifecycleevent (4.0.3)
zope.location (4.0.3)
zope.pagetemplate (4.0.4)
zope.processlifetime (1.0)
zope.proxy (4.2.0)
zope.publisher (3.12.6)
zope.schema (4.4.2)
zope.security (4.0.3)
zope.size (3.5.0)
zope.tal (3.5.2)
zope.tales (3.5.3)
zope.traversing (3.14.0)
zope.untrustedpython (4.0.0)
Which lists Z0DB3 as installed but when I run "pip3 list" there is no mention of ZODB at all

Code:
q@q:~$ pip3 list
DEPRECATION: The default format will switch to columns in the future. You can use --format=(legacy|columns) (or define a format=(legacy|columns) in your pip.conf under the[list] section) to disable this warning.
apt-clone (0.2.1)
apturl (0.5.2)
beautifulsoup4 (4.6.0)
Brlapi (0.6.6)
certifi (2018.1.18)
chardet (3.0.4)
command-not-found (0.3)
configobj (5.0.6)
cupshelpers (1.0)
cycler (0.10.0)
decorator (4.1.2)
defer (1.0.6)
distro-info (0.18ubuntu0.18.04.1)
evdev (0.7.0)
httplib2 (0.9.2)
idna (2.6)
language-selector (0.1)
louis (3.5.0)
lutris (0.5.4)
macaroonbakery (1.1.3)
Mako (1.0.7)
MarkupSafe (1.0)
matplotlib (2.1.1)
netifaces (0.10.4)
numpy (1.13.3)
onboard (1.4.1)
PAM (0.4.2)
pexpect (4.2.1)
Pillow (5.1.0)
pip (9.0.1)
protobuf (3.0.0)
psutil (5.4.2)
pulsectl (19.10.4)
pycairo (1.16.2)
pycrypto (2.6.1)
pycups (1.9.73)
pycurl (7.43.0.1)
pygobject (3.26.1)
PyICU (1.9.8)
pyinotify (0.9.6)
pymacaroons (0.13.0)
PyNaCl (1.1.2)
pyparsing (2.2.0)
pyRFC3339 (1.0)
python-apt (1.6.4)
python-dateutil (2.6.1)
python-debian (0.1.32)
python-xapp (1.4.0)
python-xlib (0.20)
pytz (2018.3)
pyxdg (0.25)
PyYAML (3.12)
reportlab (3.4.0)
requests (2.18.4)
requests-unixsocket (0.1.5)
scipy (0.19.1)
sessioninstaller (0.0.0)
setproctitle (1.1.10)
setuptools (42.0.2)
six (1.11.0)
system-service (0.3)
systemd-python (234)
ubuntu-drivers-common (0.0.0)
ufw (0.36)
urllib3 (1.22)
vboxapi (1.0)
xkit (0.0.0)
What should I do? Is there a way to completely reinstall python? Does anyone have any suggestions?
  Reply With Quote

Reply


Pulseaudio Crossover Rack - multi-way crossover design &amp; implementation with linuxHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
analyzing my Linux/ecasound dsp crossover speaker system gibbyj Multi-Way 5 6th August 2017 08:42 PM
Linux + MPD player + dsp crossover via ecasound jplesset PC Based 11 15th September 2013 11:24 PM
Can you use a digital active crossover to design a passive analog crossover ? RickDangerous Digital Line Level 27 1st April 2013 06:59 AM
Active Crossover using PC and multi ch. Soundcard? vision Digital Source 22 8th July 2012 12:59 AM
Implementation of 3 ways speaker with digital crossover ackcheng Multi-Way 4 6th December 2010 04:50 PM


New To Site? Need Help?

All times are GMT. The time now is 12:29 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki