diyAudio

diyAudio (https://www.diyaudio.com/forums/index.php)
-   PC Based (https://www.diyaudio.com/forums/pc-based/)
-   -   piCorePlayer = piCore Linux + Raspberry Pi + Squeezelite (https://www.diyaudio.com/forums/pc-based/275586-picoreplayer-picore-linux-raspberry-pi-squeezelite.html)

myketyson 10th October 2018 12:42 PM

Quote:

Originally Posted by soundcheck (https://www.diyaudio.com/forums/pc-based/275586-picoreplayer-picore-linux-raspberry-pi-squeezelite-post5569404.html#post5569404)
OK. Stupid me. :smash:

Boss/PCM5122 doesn't support DoP at all. I checked the datasheet and
Allo also confirmed it.

What will work though is using the DSDplayer plugin and convert DSD to PCM.
Just tested it!
That'll generate a 352k8 PCM stream from DSD128 material.

Sorry for the confusion.

Enjoy.

Soundcheck, I come to the same conclusion. No way to have DoP on Allo Boss, I spent a lot of time before realizing that... :sigh:

DSD to PCM conversion using DSDPlayer or C3PO plugins on LMS is confirmed.

Thanks for your attention.

soundcheck 12th October 2018 04:47 PM

Folks.

Not sure if it was mentioned earlier - at least I missed it (been too long on vacation).

pCP 4.0 is available since 6 weeks already.

I wasn't aware of it since recently.

Anyhow. I had a look at it now.
And wrote some lines about it. You probably know where to find these lines.


Thx to the pCP team for such a great job again!

lordvader 21st December 2018 12:37 AM

I'm having a similar issue with DSD128.
I have the AUDIOPHONICS DAC I-Sabre ES9038Q2M hat, currently running on piCorePlayer 4.1 (rpi3).
DSDPlay is setup on my LMS, and I'm using the DSD enabled version of Squeezelite.

When I playback a DSD128 file, I see this in the debug logs:

Code:

[20:37:50.458657] decode_thread:75 streambuf bytes: 32768 outputbuf space: 3527999                                                                       
[20:37:50.458674] _read_header:192 id: DSD  len: 28 consume: 28                                                                                           
[20:37:50.458687] _read_header:159 DSF version: 1 format: 0                                                                                                 
[20:37:50.458697] _read_header:169 channels: 2                                                                                                           
[20:37:50.458705] _read_header:170 sample rate: 5644800                                                                                                   
[20:37:50.458714] _read_header:171 lsb first: 1                                                                                                         
[20:37:50.458722] _read_header:172 sample bytes: 216826176                                                                                       
[20:37:50.458745] _read_header:173 block size: 4096                                                             
[20:37:50.458756] _read_header:192 id: fmt  len: 52 consume: 52                                                                                       
[20:37:50.458766] _read_header:179 found dsd len: 433659916                                                                                             
[20:37:50.458775] dsd_decode:768 setting track_start                                                                                                     
[20:37:50.458784] dsd_decode:812 DSD sample rate too high for device - converting to PCM                         
[20:37:50.458793] dsd_decode:817 DSD to PCM output

For reference, this is what I get with a DSD64 file:
Code:

[20:37:33.670269] decode_thread:75 streambuf bytes: 58832 outputbuf space: 3527999                                                                     
[20:37:33.670311] _read_header:192 id: DSD  len: 28 consume: 28                                                                                         
[20:37:33.670325] _read_header:159 DSF version: 1 format: 0                                                                                               
[20:37:33.670335] _read_header:169 channels: 2                                                                                                         
[20:37:33.670344] _read_header:170 sample rate: 2822400                                                         
[20:37:33.670353] _read_header:171 lsb first: 1                                                                                                         
[20:37:33.670361] _read_header:172 sample bytes: 108413088                                                                                               
[20:37:33.670370] _read_header:173 block size: 4096                                                                                                   
[20:37:33.670388] _read_header:192 id: fmt  len: 52 consume: 52                                                                                                   
[20:37:33.670399] _read_header:179 found dsd len: 216834060                                                                                                       
[20:37:33.670408] dsd_decode:768 setting track_start                                                                                                   
[20:37:33.670418] dsd_decode:821 DSD64 stream, format: DOP, rate: 176400Hz

I saw an earlier post about using the audio kernal, but that doesn't seem to be an option with 4.1 (only the real time kernel).
Any help will be appreciated, and if you need more info, let me know :)

paul123 21st December 2018 12:57 AM

The audio kernel, just changed name......it is a Linux-rt kernel now.

AFAIK, DSD isn’t going to work like you want in the i2s bus. Those doing DSD at high rates are using USB.

lordvader 21st December 2018 02:28 AM

I'll try the new kernel - will I need to re-flash the sd card?

The audiophonics product page implies that it can do DSD128 over i2s (for rpi), and their support said that it "works for them" (though not sure if they use piCorePlayer)
>DSD 64/128/256/512 DOP Auto Switch (Max DSD 128 pour RPI)

See here if you're curious

paul123 21st December 2018 12:16 PM

Looking through those docs, that appears to be the card that requires a 3rd party driver, for full support. There are many questions as to the legality of that driver, therefore we do not include it in piCorePlayer.

RDaneel 9th January 2019 03:40 PM

No output via USB?
 
First of all, thank you so much for piCorePlayer! It looks fantastic and may be just what I need. Quick troubleshooting question for the forum:

My player (rPi B+, screen, no HAT) works just fine via the analog headphone output. However, when I try to output via USB, I get no audio. I've enabled USB output in the Squeezelite settings, and my DAC (Schiit Modi Multibit, either with or without the Eitr USB to coax SPDIF converter) seems to think it is locked on a source. However, I get no audio. Even while set to USB output, I can still get audio out of the headphone jack (is that correct), so I know the player is working. It is a known good USB cable (worked fine with my PC), DAC, and amp. I've tried multiple USB ports on the Pi. Others who have posted in this thread have said this hardware works great, so I'm stumped.

Any ideas? Is there a setting I missed? Drivers that need to be installed?

Greg Erskine 9th January 2019 07:21 PM

Hi RDaneel,

Did you try a reboot with the USB DAC installed?

You will need to reset [Squeezelite Settings] page > [Output setting] to your DAC. Look under the more> Help. It should come up with a list of devices.....click on one that looks right.

regards

RDaneel 9th January 2019 08:06 PM

Quote:

Originally Posted by Greg Erskine (https://www.diyaudio.com/forums/pc-based/275586-picoreplayer-picore-linux-raspberry-pi-squeezelite-post5659343.html#post5659343)

Did you try a reboot with the USB DAC installed?

You will need to reset [Squeezelite Settings] page > [Output setting] to your DAC. Look under the more> Help. It should come up with a list of devices.....click on one that looks right.

Greg, thank you so much for your help. I have tried rebooting the player (both a soft reset of Squeezelite and a full reboot of the Pi). Unfortunately, I don't see any entry for my DAC in the audio output device settings. In the list, I see the generic USB audio, HDMI audio, etc., as well as all the typical HAT DACs. On my PC, the DAC shows us as a "Schiit Eitr," but nothing but the default options seems to exist. Hmm... this one really has me scratching my head!

RDaneel 9th January 2019 08:16 PM

Quote:

Originally Posted by Greg Erskine (https://www.diyaudio.com/forums/pc-based/275586-picoreplayer-picore-linux-raspberry-pi-squeezelite-post5659343.html#post5659343)
You will need to reset [Squeezelite Settings] page > [Output setting] to your DAC. Look under the more> Help. It should come up with a list of devices.....click on one that looks right.

Ahh, I misunderstood your instructions. I'm sorry about that. I now see what you mean about the output settings and am trying to get it going...


All times are GMT. The time now is 10:29 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 17.65%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright ©1999-2020 diyAudio

Wiki