Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

PC Based Computer music servers, crossovers, and equalization

Moode Audio Player for Raspberry Pi
Moode Audio Player for Raspberry Pi
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th March 2018, 07:38 PM   #14451
randytsuch is offline randytsuch
diyAudio Member
 
Join Date: Jan 2003
Location: LA
Quote:
Originally Posted by TimCurtis View Post
Hi Randy,

Many files including /boot/config.txt are managed via moOde UI and the underlying code. If they are manually modified then all bets are off and moOde will most likely malfunction and be broken.

In the case of the integrated WiFi and Bluetooth adapters, there are individual ON/OFF settings for these on the System config screen and thus there is no need to manually modify /boot/config.txt to disable either of them.

I use Bluetooth just fine on PI0 and 3B.

-Tim
Cool, thanks for the info.
__________________
My system is here
http://randytsuch-audio.blogspot.com/2005/10/my-system.html
  Reply With Quote
Old 13th March 2018, 08:18 PM   #14452
TimCurtis is offline TimCurtis  United States
diyAudio Member
 
TimCurtis's Avatar
 
Join Date: Jan 2012
Location: Metro-Detroit
Quote:
Originally Posted by User42 View Post
Hello Tim!

I wonder if it is possible to limit the dynamic text size. On Android with expanded keyboard all texts get to tiny, i can't read them anymore.
Post some screen shots.
__________________
Enjoy the Music!
http://moodeaudio.org, http://twitter.com/MoodeAudio
  Reply With Quote
Old 13th March 2018, 09:29 PM   #14453
TheOldPresbyope is offline TheOldPresbyope  United States
diyAudio Member
 
Join Date: Dec 2015
Location: Maryland, USA
Quote:
Originally Posted by mikaella View Post
Hi Tim! Thanks for all your fantastic work! I really love moode!

Is the UI supposed to "just work" when flipped on? I installed the RPi Pixel gui and autostart Chromium in kiosk mode pointing to moode.local to get anything except the command line to show up on screen.

Am I missing Something?

2nd Issue: I cannot for the love of Moode get it to mount a share from my Synology Nas (which I know to be working well from OSMC)
@mikaella

Yes, indeed, it is supposed to "just work". The moOde player and its underlying moOdeOS are an integrated whole, crafted to be completely configurable via the web browser-based UI. Going through this UI to turn on the Local UI display enables Chromium to start in kiosk mode and display on the local screen. I don't own any RPi-compatible touchscreens but I've successfully used a local HDMI display just to test the feature.

Hard to say what mischief you've caused by installing the RPi Pixel UI etc. In effect, you're on your own once you start tinkering inside the moOde "appliance".

As for your Synology NAS, you don't say whether you're trying to mount SMB/CIFS or NFS shares. Regardless, problems with Synology seem to come up regularly. I don't own one so all I can suggest is to either try the hints offered by the clickable "i" bubbles in the moOde UI or search back in this thread for advice. FYI, SMB shares from my Open Media Vault NAS and other servers come up fresh as paint in moOde.

Regards,
Kent
  Reply With Quote
Old 13th March 2018, 09:46 PM   #14454
mikaella is offline mikaella  Romania
diyAudio Member
 
Join Date: Mar 2018
Quote:
Originally Posted by TheOldPresbyope View Post
@mikaella

Yes, indeed, it is supposed to "just work". The moOde player and its underlying moOdeOS are an integrated whole, crafted to be completely configurable via the web browser-based UI. Going through this UI to turn on the Local UI display enables Chromium to start in kiosk mode and display on the local screen. I don't own any RPi-compatible touchscreens but I've successfully used a local HDMI display just to test the feature.

Hard to say what mischief you've caused by installing the RPi Pixel UI etc. In effect, you're on your own once you start tinkering inside the moOde "appliance".

As for your Synology NAS, you don't say whether you're trying to mount SMB/CIFS or NFS shares. Regardless, problems with Synology seem to come up regularly. I don't own one so all I can suggest is to either try the hints offered by the clickable "i" bubbles in the moOde UI or search back in this thread for advice. FYI, SMB shares from my Open Media Vault NAS and other servers come up fresh as paint in moOde.

Regards,
Kent
Thanks @TheOldPresbyope so much for your answer!

I could not find a sure answer whether the UI is built in. It simply doesn't work for me. Have built the moode is image twice from scratch - same result... maybe I'm doing something wrong and have no idea what. Everything works otherwise well > web, sound, files, usb, wifi... even the screen - just no touch UI. Have tried the official Pi Touch 7" & some cheap HDMI Display - same result: no UI.

What I basically tried then was manually installing Pixel desktop enviornment - just the basics: windowserver and chromium - which was installed but not working (maybe moode modifies something there) > I didn't want to modify moode - it's just that I like it best of all pi music players and would really love to get this working properly.

I'll do a 3rd attempt at this tonight...

Re: NAS:
- SMB doesn't work at all.
- NFS works > Synology share is mounted (logged in via ssh: df shows it's mounted + Folders appear under mnt/NAS > just nowhere in the moode file browser or library).
  Reply With Quote
Old 13th March 2018, 10:49 PM   #14455
Serverbaboon is offline Serverbaboon  United Kingdom
diyAudio Member
 
Join Date: Apr 2016
Quote:
Originally Posted by Rucia1 View Post
Originally Posted by Rucia1 View Post
I have a problem with tidal. After entering the recommended playlist, the message "service login or communic"
I have logged a ticket with the UPMPDCLI developer for this.
  Reply With Quote
Old 14th March 2018, 02:03 AM   #14456
TimCurtis is offline TimCurtis  United States
diyAudio Member
 
TimCurtis's Avatar
 
Join Date: Jan 2012
Location: Metro-Detroit
Quote:
Originally Posted by mikaella View Post
Thanks @TheOldPresbyope so much for your answer!

I could not find a sure answer whether the UI is built in. It simply doesn't work for me. Have built the moode is image twice from scratch - same result... maybe I'm doing something wrong and have no idea what. Everything works otherwise well > web, sound, files, usb, wifi... even the screen - just no touch UI. Have tried the official Pi Touch 7" & some cheap HDMI Display - same result: no UI.

What I basically tried then was manually installing Pixel desktop enviornment - just the basics: windowserver and chromium - which was installed but not working (maybe moode modifies something there) > I didn't want to modify moode - it's just that I like it best of all pi music players and would really love to get this working properly.

I'll do a 3rd attempt at this tonight...

Re: NAS:
- SMB doesn't work at all.
- NFS works > Synology share is mounted (logged in via ssh: df shows it's mounted + Folders appear under mnt/NAS > just nowhere in the moode file browser or library).
Post the output from System info and I'll have a look.

U can access it via

Menu, Configure, System
Menu, System info
__________________
Enjoy the Music!
http://moodeaudio.org, http://twitter.com/MoodeAudio
  Reply With Quote
Old 14th March 2018, 06:45 AM   #14457
klicker09 is offline klicker09  Germany
diyAudio Member
 
Join Date: Jun 2017
Default How to setup a Static IP on ETH0

Hello Ttim,

i am testing more to get the DHCP Problem fixed.

But here is my main Problem, when i change dhcpcd.conf to Static IP for ETH0, it will be every time overwritten by the player network configuration page.

Did this mean, that moode is overwritung this file every start?

When this is the case, how could it be possible to setup a static IP?
If i set the ip in the Network Settings of moode to Static it will stop searching for dhcp on boot?

Or is there another way to make it static?

Best regards, Mirko
  Reply With Quote
Old 14th March 2018, 06:50 AM   #14458
Veazer is offline Veazer
diyAudio Member
 
Join Date: Sep 2016
Quote:
Originally Posted by klicker09 View Post
...
Or is there another way to make it static?
Imho, it is preferable to do static IPs from the router using static dhcp entries. This allows you to control all static IPs from a central location.
  Reply With Quote
Old 14th March 2018, 07:04 AM   #14459
klicker09 is offline klicker09  Germany
diyAudio Member
 
Join Date: Jun 2017
Quote:
Originally Posted by Veazer View Post
Imho, it is preferable to do static IPs from the router using static dhcp entries. This allows you to control all static IPs from a central location.

Hello Veazer,

my main Problem is, that i didnt have any Ethernet connection on my PI.
It is installed in the CAR and only Wifi must work.

But when no ETH is connected i have two major Problems:

1. longer Boot time, 1min without ETH. With ETH it Boots in 39 sec.

2. When the start Screen from Moode comes UP, it is only white with no Cover Infos or Title Infos. After a manual Refresh everything is back again.

Because of this Problem, i am looking for a solution to make the boot faster and showing the correct Screen without having to press refresh.
In the Car it is not a good idea to press this tiny buttons to refresh the display.

Best Regards, Mirko
  Reply With Quote
Old 14th March 2018, 07:52 AM   #14460
JonPike is offline JonPike  United States
diyAudio Member
 
Join Date: Feb 2004
Location: Irvine
Quote:
Originally Posted by TimCurtis View Post

Hey @swizzle, if u see this, the step limiter seems like a good thing to do to protect against errant taps. Maybe even volume warning not needed anymore. What do u think?

Thx @JonPike!

-Tim
And, it makes the whole bar area on either side of the cursor a up/down adjustment button. Tap anywhere except the cursor to bump up or down, you don't need to have volume up/down buttons anymore... its pretty slick! Try it out if you can...
  Reply With Quote

Reply


Moode Audio Player for Raspberry PiHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My DAC for the Raspberry Pi usul27 Digital Line Level 156 29th April 2017 11:10 PM
DSP for the Raspberry Pi usul27 Digital Line Level 39 30th August 2016 07:29 AM
Raspberry Pi + CirrusLogic Audio Card = FAIL solderhead PC Based 31 26th January 2016 06:48 PM
RaspyFi/Volumio - Turn raspberry Pi into Audiophile audio Player mikelangeloz PC Based 295 14th June 2014 05:32 PM
miniAMP and raspberry pi kp93300 miniDSP 0 3rd March 2014 03:38 AM


New To Site? Need Help?

All times are GMT. The time now is 04:40 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki