Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

PC Based Computer music servers, crossovers, and equalization

Moode Audio Player for Raspberry Pi
Moode Audio Player for Raspberry Pi
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 4th November 2017, 05:42 PM   #10501
kwatch is offline kwatch
diyAudio Member
 
Join Date: Nov 2010
Quote:
Originally Posted by markstwin View Post
Once you've burnt the latest stretch image to an SD card (I use Etcher on Manjaro) you need to use the trick of copying an empty ssh file and wpa_supplicant.conf to the boot partition
This is the contents of my wpa_supplicant.conf

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
ssid="BTHub-blahblah"
psk="keyblahblah"
}

Good luck
I created the "wpa_supplicant.conf" in boot partition but I don't think it's working. My router's admin screen cannot locate an IP of my Pi Zero W. I could not locate the "wpa_supplicant.conf" in boot partition after booting when I checked SD card using Win 10 computer. It must been deleted or moved to other directory.
  Reply With Quote
Old 4th November 2017, 05:48 PM   #10502
TimCurtis is offline TimCurtis  United States
diyAudio Member
 
TimCurtis's Avatar
 
Join Date: Jan 2012
Location: Metro-Detroit
Quote:
Originally Posted by kwatch View Post
I created the "wpa_supplicant.conf" in boot partition but I don't think it's working. My router's admin screen cannot locate an IP of my Pi Zero W. I could not locate the "wpa_supplicant.conf" in boot partition after booting when I checked SD card using Win 10 computer. It must been deleted or moved to other directory.
Hi,

It automatically gets moved into its home location on root partition

/etc/wpa_supplicant/wpa_supplicant.conf

raspbian - Prepare SD card for Wifi on Headless Pi - Raspberry Pi Stack Exchange

-Tim
__________________
Enjoy the Music!
http://moodeaudio.org, http://twitter.com/MoodeAudio
  Reply With Quote
Old 4th November 2017, 05:57 PM   #10503
josh2000 is offline josh2000
diyAudio Member
 
Join Date: Mar 2010
Thank you, Tim, I repeated the installation and now Shairport is working :-) I just repeat UPNP installation - hope this also helps -Josef
Quote:
Originally Posted by TimCurtis View Post
If you don't get the result below from the "which" cmd then maybe a missed step in the compile and install for shairport-sync.

pi@rp3:~ $ which shairport-sync
/usr/local/bin/shairport-sync

Just rerun the steps for component 4, and then afterwords the "which" command to confirm the binary exists. Then shairport-sync -V to verify the version.

pi@rp3:~ $ shairport-sync -V
3.1.3-OpenSSL-Avahi-ALSA-stdout-soxr-metadata-sysconfdir:/usr/local/etc

////////////////////////////////////////////////////////
//
// COMPONENT 4 - Shairport-sync
//
////////////////////////////////////////////////////////
.
.
.

-Tim
  Reply With Quote
Old 4th November 2017, 06:10 PM   #10504
josh2000 is offline josh2000
diyAudio Member
 
Join Date: Mar 2010
Yes - after repeating the install steps for UPNP - this is also working now :-) Maybe i should first have had breakfast before the build this morning... -Josef
Quote:
Originally Posted by josh2000 View Post
Thank you, Tim, I repeated the installation and now Shairport is working :-) I just repeat UPNP installation - hope this also helps -Josef
  Reply With Quote
Old 4th November 2017, 06:25 PM   #10505
Serverbaboon is offline Serverbaboon  United Kingdom
diyAudio Member
 
Join Date: Apr 2016
Quote:
Originally Posted by TimCurtis View Post
lol, definitely, you are now an official "Linux Enthusiast".

The adv kernels are a separate Source base. Well have to see whether they pop up again.

-Tim
So if i accidently copied them from a previous 'legacy' install into the same location in the Beta then they would not work?
  Reply With Quote
Old 4th November 2017, 08:34 PM   #10506
TimCurtis is offline TimCurtis  United States
diyAudio Member
 
TimCurtis's Avatar
 
Join Date: Jan 2012
Location: Metro-Detroit
Quote:
Originally Posted by TimCurtis View Post
Hi,

There is a small in-place update for Beta 6 that upgrades it to Beta 7, probably the last Beta before production 4.0, which will also be an in-place update :-)

This update fixes some permission issues, removes a bad fat-fingered directory, and has some minor code fixes and updates. It MUST be run from cmd line AND on an un-squashed /var/www !! It might complain about a missing templatesw# directory. This can be ignored. The browser title will revert to "moOde Player" after the update. Use System config to change it.

Also, just to be safe u might want to backup /var/www and /var/local/www directories before applying the update.

sudo /var/www/command/updater.sh r40b6

If u want to examine the update package and its installation script before installing it then run the cmds below.

wget http://moodeaudio.org/downloads/update-r40b6.zip
unzip update-r40b6.zip
cat ./update/install.sh

-Tim
Hi,

Just a friendly bump :-)

-Tim
__________________
Enjoy the Music!
http://moodeaudio.org, http://twitter.com/MoodeAudio
  Reply With Quote
Old 4th November 2017, 08:53 PM   #10507
sfb2 is offline sfb2  Germany
diyAudio Member
 
Join Date: May 2017
Default ES9028Q2M-chinese-board..Settings...

Hi Tim,
got here now working Beta7..wonderful (work, especially for this error-free build-recipe ) as said !!
okay, got here at the moment an ES9028Q2M-chinese-board.."Generic-I2S-Hifiberry-DAC" works NOT (i use "Generic-I2S-rpi-dac" instead)..
so far so good..problem is this rpi-dac overlay is limited to 192khz..
had similar problems on other audio-distros before; was solved by using the "ES9023" without anything else, as setting/dtoverlay..
u had also on the supported Dac-list (Audio-Devices)->26. Generic-4 I2S (es9023-audio) and 27. Generic-5 I2S (simple-es9023-audio)...
i think in this (my) case this 26. (9023-audio) would be the right choice, but it didnīt show up/is not available via "Audio-config->Devices->I2S-audio-device.."
only Generic-I2S 1 and 2 (hifiberry+rpi)..
is this more or less a bug or was it determined before that these options are not available for this special dac-chip (sorry for my bad english, iīm (unfortunately ;-) )german) ?
but many many thx again for this wonderful "Moodeaudio" !!!

Last edited by sfb2; 4th November 2017 at 09:10 PM.
  Reply With Quote
Old 4th November 2017, 09:03 PM   #10508
kwatch is offline kwatch
diyAudio Member
 
Join Date: Nov 2010
Quote:
Originally Posted by TimCurtis View Post
Hi,

It automatically gets moved into its home location on root partition

/etc/wpa_supplicant/wpa_supplicant.conf

raspbian - Prepare SD card for Wifi on Headless Pi - Raspberry Pi Stack Exchange

-Tim
I was able to connect to my network using the latest "RASPBIAN STRETCH LITE". However, I could not make it work on MoodeAudio V.3.8.2.

The followings are the contents ong "wpa_supplicant.conf" in boot partition.
country=GB
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
ssid="KSK-1215-2.4G"
psk="password"
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP
group=CCMP
auth_alg=OPEN
}

Last edited by kwatch; 4th November 2017 at 09:15 PM.
  Reply With Quote
Old 4th November 2017, 09:10 PM   #10509
TimCurtis is offline TimCurtis  United States
diyAudio Member
 
TimCurtis's Avatar
 
Join Date: Jan 2012
Location: Metro-Detroit
Hi @kwatch,

Just use a basic set of params

network={
ssid="YourSSID"
scan_ssid=1
psk="YourPASSWORD"
}

-Tim
__________________
Enjoy the Music!
http://moodeaudio.org, http://twitter.com/MoodeAudio
  Reply With Quote
Old 4th November 2017, 10:03 PM   #10510
kwatch is offline kwatch
diyAudio Member
 
Join Date: Nov 2010
Quote:
Originally Posted by TimCurtis View Post
Hi @kwatch,

Just use a basic set of params

network={
ssid="YourSSID"
scan_ssid=1
psk="YourPASSWORD"
}

-Tim
I tried but did not work.
  Reply With Quote

Reply


Moode Audio Player for Raspberry PiHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My DAC for the Raspberry Pi usul27 Digital Line Level 156 29th April 2017 11:10 PM
DSP for the Raspberry Pi usul27 Digital Line Level 39 30th August 2016 07:29 AM
Raspberry Pi + CirrusLogic Audio Card = FAIL solderhead PC Based 31 26th January 2016 06:48 PM
RaspyFi/Volumio - Turn raspberry Pi into Audiophile audio Player mikelangeloz PC Based 295 14th June 2014 05:32 PM
miniAMP and raspberry pi kp93300 miniDSP 0 3rd March 2014 03:38 AM


New To Site? Need Help?

All times are GMT. The time now is 12:15 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki