Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Pass Labs This forum is dedicated to Pass Labs discussion.

Forte Model 1 wont turn on!
Forte Model 1 wont turn on!
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 15th March 2019, 08:02 AM   #11
Zen Mod is offline Zen Mod  Serbia
Official Court Jester
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain
Forte Model 1 wont turn on!
as far as I know , and you have that info in linked thread - 4 fuses are 2 per channel , situated in rails

so , same value all 4

however , there is some serious problem if you have all of them burned in same moment

suggesting problem which can solve only competent tech , not someone asking questions for most trivial things

that's logical .... I know how to repair an amp , but when I need new spectacles , I'm going to ophthalmologist ..... not trying to learn his trade

__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa... by Mighty ZM
  Reply With Quote
Old 15th March 2019, 06:42 PM   #12
takitaj is offline takitaj  United States
diyAudio Member
 
Join Date: Apr 2012
Location: Maine
To learn is good but takes much time and effort, years. Take ZM's advice and find a decent tech versed in repairing audio amplifiers. Your wallet and perhaps your health is at stake.


TJ
  Reply With Quote
Old 15th March 2019, 06:48 PM   #13
rekupax is offline rekupax  Russian Federation
diyAudio Member
 
Join Date: Dec 2009
Thanks, I've talked with some who is experienced with Forte amplifiers and is willing to check it out. But he recommended to replace fuses first.

Nearly the same time with Forte, my preamplifier lost signal in one channel, 5-10 minutes before Forte got down...
  Reply With Quote
Old 15th March 2019, 07:06 PM   #14
Zen Mod is offline Zen Mod  Serbia
Official Court Jester
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain
Forte Model 1 wont turn on!
in that case , we can resume that preamp malfunction is possible culprit

disconnect preamp and loudspeakers , put new fuses in and power up

do not forget prayer , prior to switching on
__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa... by Mighty ZM
  Reply With Quote
Old 15th March 2019, 08:03 PM   #15
rekupax is offline rekupax  Russian Federation
diyAudio Member
 
Join Date: Dec 2009
Quote:
Originally Posted by Zen Mod View Post
do not forget prayer , prior to switching on
Forte 1 worked like a prayer itself for 10+ years...
I'd better pass to right doctor...
Attached Images
File Type: jpg 2019-03-15_22-34-15_162.jpg (931.0 KB, 78 views)

Last edited by rekupax; 15th March 2019 at 08:11 PM.
  Reply With Quote
Old 15th March 2019, 08:51 PM   #16
Joe Berry is offline Joe Berry  United States
diyAudio Member
 
Join Date: Mar 2001
Location: USA
Quote:
Originally Posted by rekupax View Post
Forte 1 worked like a prayer itself for 10+ years... I'd better pass to right doctor...
I've had the front power switch fail on one of my Forte amps before. You might want to check that as well, especially if you recall the action of the switch getting a bit rough before the problem appeared.
  Reply With Quote
Old 15th March 2019, 09:25 PM   #17
rekupax is offline rekupax  Russian Federation
diyAudio Member
 
Join Date: Dec 2009
What Forte series amps were usually used for in the U.S.?
Rackmount chassis redeem rather professional not home?
  Reply With Quote
Old 15th March 2019, 09:34 PM   #18
rekupax is offline rekupax  Russian Federation
diyAudio Member
 
Join Date: Dec 2009
Quote:
Originally Posted by Joe Berry View Post
the front power switch
When turning it on I hear transformer hum. Less loud as usual, but clearly audible.
So switch is still robust.
  Reply With Quote
Old 16th March 2019, 12:48 AM   #19
rekupax is offline rekupax  Russian Federation
diyAudio Member
 
Join Date: Dec 2009
just put new fuses. it turns on -- indicator lights on. but no sound..
weird.. red indicator still on for 5 minutes after unplugged power
  Reply With Quote
Old 16th March 2019, 12:54 AM   #20
Zen Mod is offline Zen Mod  Serbia
Official Court Jester
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain
Forte Model 1 wont turn on!
time for tech
__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa... by Mighty ZM
  Reply With Quote

Reply


Forte Model 1 wont turn on!Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
RF T1500-1BD CP wont turn off Crazylogix Car Audio 3 17th November 2018 04:02 AM
Help needed to fix PPI 900.4 Wont turn on yusme Class D 0 5th March 2016 11:01 PM
amp wont turn off jdh989 Power Supplies 0 22nd December 2010 08:48 PM
wont turn on IMPALAMAN1 Car Audio 17 1st February 2006 03:53 PM


New To Site? Need Help?

All times are GMT. The time now is 10:45 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki