Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Instruments and Amps Everything that makes music, Especially including instrument amps.

BlackStar ID:100 TVP
BlackStar ID:100 TVP
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th February 2020, 01:43 PM   #1
akitanut is offline akitanut
diyAudio Member
 
Join Date: Feb 2020
Default BlackStar ID:100 TVP

I have a BlackStar ID:100 TVP. When switching the voice control or the TVP control the amp does not stay on the selected setting. If I set the voice to clean , cruch, gain, etc. the control led light with blink between settings. The same happens on the TVP control. At times it will also cut out and no sound will come out of the amp when it is seeking between settings.

So far I have done a visual inspection of the circuit boards. No visual damage. I have also blown out the pots with no results. The front circuit board contains all the controls and pots. attached to the back of this circuit board is a processor board.

Has anyone come across this issue and know what the repair is?

I tried getting a schematic from BlackStar but they won't give it up. Searching the net only turns up a few hits with others having the same problem and no fix.
  Reply With Quote
Old 13th February 2020, 01:47 PM   #2
Pano is offline Pano  United States
diyAudio Moderator
 
Pano's Avatar
 
Join Date: Oct 2004
Location: SW Florida
BlackStar ID:100 TVP
Moved to Instruments and Amps
  Reply With Quote

Reply


BlackStar ID:100 TVPHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Blackstar Issue conorgracey Instruments and Amps 2 22nd December 2017 02:46 AM
blackstar stage 60 diy dazzz Instruments and Amps 0 11th December 2014 09:28 AM
Blackstar combo 20 that squeals brewback Instruments and Amps 14 22nd October 2014 09:12 PM
Maximum power of Blackstar ID series? eem2am Instruments and Amps 19 21st June 2012 08:05 PM
where can i buy a replacement PSU for my Blackstar pedal? mondogenerator Instruments and Amps 6 24th December 2010 02:41 AM


New To Site? Need Help?

All times are GMT. The time now is 02:39 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright ©1999-2020 diyAudio
Wiki