Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Instruments and Amps Everything that makes music, Especially including instrument amps.

Pultec 1A clone high boost filter cap problems?
Pultec 1A clone high boost filter cap problems?
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th August 2019, 12:23 PM   #1
orangehorse is offline orangehorse
diyAudio Member
 
Join Date: Sep 2015
Default Pultec 1A clone high boost filter cap problems?

Hi !

I have problem with the high boost on a 1A clone.
When i turn the high boost its not a smooth response, and i have to turn the knob fast all the way up to to 10 to get it to respond.
Its also scratching when i turn the knob (with no audio playing through of course)
Could it be a cap charging d.c in the high filter section?
Its affecting all KCS selections.
Its old caps, new PEC pots, but carbon.

Help is much appreciated!
  Reply With Quote
Old 13th August 2019, 08:40 PM   #2
orangehorse is offline orangehorse
diyAudio Member
 
Join Date: Sep 2015
Any ideas?
  Reply With Quote
Old 14th August 2019, 03:35 AM   #3
PRR is offline PRR  United States
diyAudio Member
 
PRR's Avatar
 
Join Date: Jun 2003
Location: Maine USA
> Any ideas?

See other forum.
  Reply With Quote
Old 14th August 2019, 01:13 PM   #4
orangehorse is offline orangehorse
diyAudio Member
 
Join Date: Sep 2015
Measured the pot, the pot is bad, almost new. Thought PEC was reliable, could be a monday unit. Nothing wrong with the other pots though...
  Reply With Quote

Reply


Pultec 1A clone high boost filter cap problems?Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
oAudio BASH 500w high-pass/boost filter schematics/sim here s3tup Analog Line Level 2 2nd October 2012 02:08 AM
TDA8920 stability problems w. boost circuit Cyberzim Class D 6 15th September 2010 08:01 PM
[enquiry] Treble Boost/High frequency Boost circuitry elnino86 Parts 2 18th December 2008 12:33 PM
problems with compensation in boost regulator chimi Power Supplies 14 2nd August 2008 08:59 AM
BAM bass boost clone kephaudio Multi-Way 1 26th October 2007 10:47 AM


New To Site? Need Help?

All times are GMT. The time now is 09:48 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki