Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Instruments and Amps Everything that makes music, Especially including instrument amps.

MCP41100 DigiPot Volume Control Noisy Buzz, Fuzz, and Distortion
MCP41100 DigiPot Volume Control Noisy Buzz, Fuzz, and Distortion
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 21st January 2019, 06:06 AM   #1
phildunphy1989 is offline phildunphy1989
diyAudio Member
 
Join Date: Jul 2016
Default MCP41100 DigiPot Volume Control Noisy Buzz, Fuzz, and Distortion

Hi, I just started incorporating digipots into my guitar pedal circuits. I've successfully built one type of circuit whose digipot controls volume and gain, but on my second guitar pedal circuit, I'm running into the following issue:

When the digipot (MCP41100) is set to a lower volume (physical pot is on a Arduino Nano's analog input and dictates the digipot), I get all kinds of nasty buzzy, almost gated or "spitting" fuzz type of distortion. Only when I crank the volume mostly up does it go away, but then I'm left with a huge, overpowering volume.

I've attached the schematic of the circuit and circled where the digipot is in the circuit. Nothing too complicated, just shunting the audio signal to ground. There's already a coupling cap to block DC before the pot input.

Here's what I've already tired:

-another 1uf or 10uf coupling cap after the digipot's wiper
-2.5v bias offset?: 2x 47k resistors forming a voltage divider on the digipot's input, as such (hope I did this right):
--5v ---47k---DigiPotIN---47k---Gnd


I'm not sure why the MCP41100 works on one guitar pedal circuit and not the other, as the digipot/arduino circuits are identical to each other.

Any and all comments are appreciated, thank you!
Attached Images
File Type: gif LovepedalEternitySchematic.gif (10.0 KB, 28 views)
  Reply With Quote
Old 22nd January 2019, 04:28 AM   #2
PRR is offline PRR  United States
diyAudio Member
 
PRR's Avatar
 
Join Date: Jun 2003
Location: Maine USA
> I'm not sure why

On the MCP41100, and digipots generally, the analog pins must stay *between* the supply rails or they distort horribly.

In your LovePedal, Drive and Tone have +4.5V at all ends. But Vol has ZERO VDC on all legs. Any signal swing below zero will distort.
  Reply With Quote

Reply


MCP41100 DigiPot Volume Control Noisy Buzz, Fuzz, and DistortionHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
need schematic for 12au7a distortion overdrive and fuzz prorms Instruments and Amps 4 4th February 2008 05:53 PM
12AU7A: I need fuzz, overdrive and distortion schematic prorms Tubes / Valves 1 12th January 2008 04:14 AM
(Homebrew) Fuzz/Distortion, I need EQ, minus OpAmps Riker Solid State 4 17th July 2007 06:41 PM
Noisy electronic volume control SU-G95 Mailliw Solid State 0 23rd April 2007 07:40 AM
Noisy Motorised volume control bulgin Solid State 5 22nd September 2006 02:46 PM


New To Site? Need Help?

All times are GMT. The time now is 04:03 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki