Go Back   Home > Forums > > >

Elekit News and products from Elekit

Reply
 
Thread Tools
Old 1st January 2021, 07:55 PM   #91
vkung is online now vkung  Canada
diyAudio Member
 
Join Date: May 2005
Location: Vancouver BC Canada
No

I will check each soldering points on the problem side.
IMG_2146.HEIC - Google Drive
  Reply With Quote
Old 1st January 2021, 08:13 PM   #92
soi is offline soi  United States
diyAudio Member
 
Join Date: Jun 2020
Location: SF Bay Area
I don't think so. Without analyzing the schematic in details, I think the voltage reference (U102/U202) is to set a threshold beyond which the 300B bias gets enabled. On the other hand, the SCR is to shut down B+ under fault conditions. Mixing up the two would cause B+ to shut down or B+ to never get enabled.
  Reply With Quote
Old 1st January 2021, 11:42 PM   #93
vkung is online now vkung  Canada
diyAudio Member
 
Join Date: May 2005
Location: Vancouver BC Canada
It is not mixing up..
  Reply With Quote
Old 2nd January 2021, 04:04 AM   #94
CentralCoast is offline CentralCoast  United States
diyAudio Member
 
Join Date: Sep 2019
Location: San Luis Obispo, CA
I spent all day working on the amp. The amp plays fine on both channels after I toggle power a few times.

It has power on issues. I will keep working on it. The 3 amp voltage regulator for the 300b heater filament is getting my attention now.

Several sources indicate that the 300b requires 3 amps or more during cold start. I will continue to work on it.

Since the amp works after finally getting it started, I am focused on turn on transients.
  Reply With Quote
Old 2nd January 2021, 06:17 PM   #95
EvanMcG is offline EvanMcG
diyAudio Member
 
Join Date: Jan 2021
Genelex Gold Lion for 300B and ECC83. RCA for ECC82
  Reply to this post

Reply


Elekit TU8600S triggers current protection on one or the other channel at power onHide this!Advertise here!
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
TU8600s Headphone Settings properlydeafened Elekit 2 27th August 2020 02:45 AM
TU8600S: Are 2A3 tubes viable? scottme Elekit 3 7th August 2020 08:01 AM
Audio Technix 400.1 strong input signal triggers protection barber02 Car Audio 4 18th February 2020 09:12 PM
One channel buzz, other channel normal inlet Tubelab 3 21st January 2013 09:43 PM
CASIO LD-80 - could my triggers be bad? JonnySwitchblade Instruments and Amps 0 9th November 2007 04:57 PM


New To Site? Need Help?

All times are GMT. The time now is 03:38 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Copyright ©1999-2021 diyAudio
Wiki