Go Back   Home > Forums > > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Elekit News and products from Elekit

Reply
 
Thread Tools Search this Thread
Old 9th November 2019, 10:20 PM   #1
HarryY is offline HarryY  United States
diyAudio Member
 
HarryY's Avatar
 
Join Date: Aug 2017
Location: NY
How to fix the slop in the Elekit TU-8500 knobs
Default How to fix the slop in the Elekit TU-8500 knobs

When turning the volume or the selector the shaft moves around in the bushing.
This gives a a less then quality feel to the Elekit TU-8500 preamp.

The fix wound up being very simple. I loosened the screws at the shaft coupler,
removed the knob and shalt, then pushed a piece of flat nylon thread (wire
lacing) through the bushing hole and slid the shaft back through the bushing.

The thread takes up the slack between the bushing and the shalt.

It's a very quick and simple fix that improves the feel of the knobs.


PS: I also put a small dab of silicone grease inside the bushing.

Last edited by HarryY; 20th December 2019 at 04:40 AM.
  Reply With Quote
Old 10th December 2019, 11:43 AM   #2
gpdavis2 is offline gpdavis2  United States
diyAudio Member
 
Join Date: Aug 2004
Location: NJ Shore
Here are a couple of TU-8500 build threads where grommets from Ace Hdwre with a touch of grease were used to solve the slop problem:
Another Elekit TU-8500 Build | Audiokarma Home Audio Stereo Discussion Forums
I built this TU-8500 Stereo Tube Preamplifier Kit. Now for evaluation | Page 2 | Audiokarma Home Audio Stereo Discussion Forums
  Reply With Quote
Old 20th December 2019, 04:38 AM   #3
HarryY is offline HarryY  United States
diyAudio Member
 
HarryY's Avatar
 
Join Date: Aug 2017
Location: NY
How to fix the slop in the Elekit TU-8500 knobs
Quote:
Originally Posted by gpdavis2 View Post
That's also a good idea.
  Reply With Quote
Old 24th December 2019, 09:54 PM   #4
mikejr83 is offline mikejr83  United States
diyAudio Member
 
Join Date: Jun 2019
I thought it was the screws to the shafts and over tightened mine. I stripped the threads on one of the screws on each. IDK if I can even find a set of replacement couplings. Ideas?


Could you post a pic or two of your fix? The slop on this is the only thing that detracts from an otherwise stellar kit.
  Reply With Quote
Old 24th December 2019, 10:17 PM   #5
gpdavis2 is offline gpdavis2  United States
diyAudio Member
 
Join Date: Aug 2004
Location: NJ Shore
Did you look thru the two threads mentioned above in my previous post? One of them has a pic of the installed grommets. Touch of silicone grease to make the shafts non-sticky in the rubber.

If you've only stripped the threads of the screw just run a tap thru the screw holes to clean them of the stripped metal from the screws and put in new screws. Am sure they will be metric thread. If you've stripped the holes, then you will need to get the next largest size tap and run thru the hole and install the matching next size larger screws. Lots of work. I would contact Victor at VKMusic and see if he can sell you a new set of couplers.

Last edited by gpdavis2; 24th December 2019 at 10:19 PM.
  Reply With Quote
Old 25th December 2019, 02:30 PM   #6
mikejr83 is offline mikejr83  United States
diyAudio Member
 
Join Date: Jun 2019
Didn't think of using a tap! I'll try that first.
  Reply With Quote

Reply


How to fix the slop in the Elekit TU-8500 knobsHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Elekit TU-8500 Best buy Award vkung Elekit 6 18th January 2020 10:14 PM
Elekit TU-8500 Phono Amp vkung Elekit 12 3rd September 2019 01:50 PM
Elekit TU-8500 and TU-8500DX 5k7 Elekit 2 30th May 2019 07:00 AM
Problem (my fault!) with Elekit tu-8500 phyciocc Elekit 8 11th March 2019 05:25 AM
Elekit 8500 and 100 k resistor mishap Tuberoller Elekit 10 25th February 2019 04:36 PM


New To Site? Need Help?

All times are GMT. The time now is 03:32 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright ©1999-2020 diyAudio
Wiki