Go Back   Home > Forums > > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Elekit News and products from Elekit

Reply
 
Thread Tools Search this Thread
Old 4th October 2019, 02:52 AM   #1
eiseiaudio is offline eiseiaudio  Australia
diyAudio Member
 
Join Date: Dec 2018
Default Elekit TU-8500DX Selector switch issue

I completed my build of the TU-8500DX and when testing the kit I discovered that I have an issue with SW2 (Input Select); the Rotary Switch used to select the line input. The problem is not a build problem but a defective part.

The unit works perfectly well on Line 1, 2 and phono, however on line 3 only one channel has audio. If I manipulate SW2 slightly away from the "indent" point for line 3 input then I can get audio on both channels on line 3.

What I need is a replacement SW 2 Rotary Switch to fix this problem. Could Elekit arrange for me to receive a replacement switch or send me a part number so I can obtain a new switch from a local supplier?

As an aside the Pre-Amp works really well otherwise, very happy, easy build and sounds great paired with my Elekit TU-8600R 300B Power Amplifier (with Lundahl xFormers).
  Reply With Quote
Old 4th October 2019, 05:05 AM   #2
vkung is offline vkung  Canada
diyAudio Member
 
Join Date: May 2005
Location: Vancouver BC Canada
WHERE YOU BOUGHT YOUR TU-8500?
  Reply With Quote
Old 5th October 2019, 12:30 AM   #3
eiseiaudio is offline eiseiaudio  Australia
diyAudio Member
 
Join Date: Dec 2018
From DIY Audio Store
  Reply With Quote
Old 5th October 2019, 06:08 AM   #4
vkung is offline vkung  Canada
diyAudio Member
 
Join Date: May 2005
Location: Vancouver BC Canada
IT IS VERT RARE
SEND ME YOUR ADDRESS. I WILL MAIL YOU ONE
  Reply With Quote
Old 5th October 2019, 11:32 PM   #5
eiseiaudio is offline eiseiaudio  Australia
diyAudio Member
 
Join Date: Dec 2018
I agree, thanks for your help. I have sent my address via a private message.
  Reply With Quote
Old 9th November 2019, 01:29 AM   #6
eiseiaudio is offline eiseiaudio  Australia
diyAudio Member
 
Join Date: Dec 2018
Default TU-8500DX Fixed

I received the switch from VKung and finally got around to swapping it out today. Everything works just great now, love it, thanks for sending me the replacement switch.
  Reply With Quote

Reply


Elekit TU-8500DX Selector switch issueHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Elekit TU-8500 and TU-8500DX 5k7 Elekit 2 30th May 2019 07:00 AM
Selector switch gimpchop Chip Amps 8 7th April 2018 04:35 AM
Amp Selector Switch - multiple amps, rotary switch peraho Analog Line Level 3 1st April 2015 10:24 PM
onkyo selector switch issue lbreevesii Solid State 0 28th March 2006 10:33 PM
Selector switch on a T-amp? triodesteve Class D 1 31st December 2005 06:04 AM


New To Site? Need Help?

All times are GMT. The time now is 09:39 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki