Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Marantz cd63ki problem
Marantz cd63ki problem
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th February 2020, 06:30 PM   #1
wildoliver is offline wildoliver
diyAudio Member
 
Join Date: Feb 2020
Default Marantz cd63ki problem

I have a 63 KI MK2. I know how plagued with laser issues this model is.

Love it. But since day 1 it's been reluctant to play first time when switched on, needing some gentle coaxing in to life, usually after 5 mins or so it will "go". Symptoms are, turn on, put disc in, press play, usually nothing, you can see the drawer move slightly (closed but seems to want to close a little more, but it is properly closed), keep pressing play and eventually it will start to spin the disc up a little, then a little more, then show a disc registry, and finally will spin up properly, show registry and play. Once your at this stage you can play, stop, skip tracks, swap discs as much as you like, till you switch it off and let it cool down, in other words I reckon if you left it switched on 24/7 it would be fine.

I did buy it knowing this and got it a bit cheaper because of it, and the seller who was honest about the fault threw in the new laser mech he had bought but not fitted.

When you put it in service mode it comes up with code 2. laser focus from memory.

I replaced the laser mech yesterday, now nothing, going through the service tests it performs them all, but put a disc in and nothing, will not play now no matter how long you try.

Please Help!

My issue is I love the CD player but really can't afford to get stuck in to a loop of dumping money in to repairing it, if it's something I can track down and repair myself great, but the thought of being in to a repair for £100 or so to pay someone to do it just makes it impractical, while I don't get anywhere near as turned on by a newer cd6006 uk they get amazing reviews, have a usb input and are around £200ish. Dumping too much in to my poor old KI doesn't make sense.
  Reply With Quote
Old 15th February 2020, 09:35 PM   #2
Puffin is offline Puffin  United Kingdom
diyAudio Member
 
Join Date: Feb 2006
Location: U.K
Is it something to do with the laser voltage? Would you need to tweak it if you fit a new unit. I understand this is quite critical. Another thing it could be given that the drawer is stuttering is a build up of congealed lube and dirt in the runners.

Not in relation to your player, but this link may give you a guide.
Help - CD problem
  Reply With Quote
Old Yesterday, 03:04 PM   #3
wildoliver is offline wildoliver
diyAudio Member
 
Join Date: Feb 2020
Hi Puffin thanks for the reply.

Sadly no the tray moves totally smoothly, I think the issue is probably they all maybe suck the tray in a tiny bit more as part of the lock up to play procedure, and I'm just grasping at straws.

It could be a laser voltage issue, but the only adjustment I can see is a small rotary pot on the laser board, as I've replaced this as a complete unit I doubt it's that as the chances of the old one and new one having the same fault are slim.

I've heard of people bridging a resistor with another resistor and that working, the fault actually suggests a capacitor issue tbh, I don't know I'm at the end of my tether.

I'm loathed to buy another one at circa £100 as it may last days or years with no guarantee as they all seem to die at some point, I'm equally loathed to throw £100 or so at repairing it as knowing my luck something else would fail shortly after. The attraction to replacing with a CD6006 is it's got the USB on the front and I wanted that facility at some point anyway and it's reported to be a nice sounding unit, but it's an ugly beast next to the 63KI. It's also £300 I don't really have to blow on the hifi.

Who knows, I guess I'm just not listening to music anytime soon!
  Reply With Quote
Old Today, 09:49 AM   #4
Extreme_Boky is offline Extreme_Boky
diyAudio Member
 
Join Date: Dec 2003
removed the solder blob?
  Reply With Quote

Reply


Marantz cd63ki problemHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Marantz (CD63KI) how do I lock transport? SteveP02 Digital Source 0 31st May 2015 03:51 PM
Marantz CD63KI Biskit Digital Source 3 6th May 2013 07:21 AM
Marantz CD63KI Not Recognising CDs dlflclhl Digital Source 21 14th April 2013 10:33 AM
Marantz CD63ki problem Andymr2 Digital Source 2 12th April 2013 02:19 PM
Marantz CD63KI - XO clock in, sound bad... Zombie Digital Source 30 2nd April 2008 08:02 PM


New To Site? Need Help?

All times are GMT. The time now is 02:36 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright ©1999-2020 diyAudio
Wiki