Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Original Rega Planet CD Player Problems
Original Rega Planet CD Player Problems
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 20th July 2019, 08:31 PM   #1
Loose wire is offline Loose wire  United States
diyAudio Member
 
Join Date: Jul 2019
Default Original Rega Planet CD Player Problems

Hi all,

Well Here I am with what seems to be a common problem
with this cd player, SKIPPING!. I did go though this machine
changing transport parts with a Sony machine and change a few capacitors
but it works and sounds for awhile but after that skips in a few day's. Does
anyone else have any other ideas about fixing this?. Maybe I missed
something.
  Reply With Quote
Old 20th July 2019, 09:41 PM   #2
Galu is offline Galu  Scotland
diyAudio Member
 
Join Date: Apr 2018
Describe the skipping in more detail, e.g. short distance or long distance - that may help the experts (not me!) better analyse your problem.

There's a few reasons for skipping other than damage to the sled drive mechanism.

Do you have the facility to test things like tracking servo alignment and laser strength?

I presume you've checked for something as simple as a dirty or damaged lens?
  Reply With Quote
Old 20th July 2019, 09:57 PM   #3
Loose wire is offline Loose wire  United States
diyAudio Member
 
Join Date: Jul 2019
Hi, it skips a few selections like end of #1 to #6 it and the sound is garbbled then
play's. I have no facility to test it and I did clean the lens.

Last edited by Loose wire; 20th July 2019 at 09:59 PM.
  Reply With Quote
Old 20th July 2019, 10:23 PM   #4
Galu is offline Galu  Scotland
diyAudio Member
 
Join Date: Apr 2018
I would class that as long distance skipping.

A mechanical fault is the most likely cause, although you say you have changed transport parts.

Check for gummed up lubrication, dirt or foreign objects on the tracks or stuck in the gear teeth, damaged gear teeth, drive belt slipping, parts out of alignment.

That's about all you can do without test equipment, unless someone else has any ideas.
  Reply With Quote
Old 20th July 2019, 11:35 PM   #5
Loose wire is offline Loose wire  United States
diyAudio Member
 
Join Date: Jul 2019
Did all that, I might just sell it as is or maybe find another transport to put in.
  Reply With Quote
Old 21st July 2019, 12:21 PM   #6
dowser is offline dowser  Switzerland
diyAudio Member
 
Join Date: Jul 2006
Location: Zurich
There is a known problem with one of the positive rails - root cause is one of the rectifier diode junctions breaking down. There is more info on PFM if you do a search.

I bought a faulty one - wasn’t the diode but a faulty servo board.

Good luck, well worth fixing - lovely player that while not the best resolving, simply does nothing wrong.

Last edited by dowser; 21st July 2019 at 12:24 PM.
  Reply With Quote
Old 22nd July 2019, 01:58 AM   #7
Loose wire is offline Loose wire  United States
diyAudio Member
 
Join Date: Jul 2019
Had problems today, would not play any of my Blue note CD's. I started to play
with the magnet and clamp and finally took it off and put it back on watching the
depth of the magnet and so far it's working, will keep you updated.
  Reply With Quote

Reply


Original Rega Planet CD Player ProblemsHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rega Planet tap into i2s sckramer Digital Source 0 27th June 2016 11:53 PM
Rega Planet SCHEMATIC Please dognut Digital Source 3 10th December 2010 08:03 PM
Mod a Rega Planet Scytales Digital Source 6 1st January 2010 12:19 AM
Rega Planet 2000 Julius Digital Source 0 29th December 2004 07:23 PM
Rega Planet 2000 Julius Digital Source 4 25th November 2004 10:55 AM


New To Site? Need Help?

All times are GMT. The time now is 02:29 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki