Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Sony CDP 591 recognizes disc but doesn't play
Sony CDP 591 recognizes disc but doesn't play
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 4th November 2017, 10:07 PM   #21
Depaj is offline Depaj  France
diyAudio Member
 
Join Date: Aug 2015
Location: lyon
Quote:
Originally Posted by Mooly View Post
Q203 is the main +5 volt series pass transistor. If there is 5 volts on the collector then its probably OK. The scope should show a clean 5 volts with minimal noise and ripple (<50 mv pk/pk)
Sorry, my bad, Q203 is ok, it's Q202 that is gone. The ripple I see on the scope is about 30mv pk/pk. The +7v is clean as well according to those standards.

All I can do now is replace Q202 and go again from there. Should I try to get a 2SD774 or is there something more common that I can replace it with ? I won't be able to check if I get a signal before I restore the -5v rail.

Quote:
Originally Posted by kevinkr View Post
If you touched up components in the servos (assuming they are analog) or pick up related electronics you may need to clean off flux residue.
I didn't touch anything on the servo board.
  Reply With Quote
Old 5th November 2017, 07:05 AM   #22
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Sony CDP 591 recognizes disc but doesn't play
Pretty much anything suitably rated should be OK for the pass transistor. Try a BD131 or TIP41. Make sure you get the pinouts correct.
  Reply With Quote
Old 5th November 2017, 11:24 AM   #23
Depaj is offline Depaj  France
diyAudio Member
 
Join Date: Aug 2015
Location: lyon
Ok got the -5v supply back and the cd is still reading but I don't get any sound (the hum is gone as well). The voltages on IC306 are good but I have just a lot of noise on the inputs.

The +10v rail drops to about 8.6v when the disc is spinning.

Last edited by Depaj; 5th November 2017 at 11:37 AM.
  Reply With Quote
Old 5th November 2017, 11:49 AM   #24
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Sony CDP 591 recognizes disc but doesn't play
The output IC306 should have full level audio, which is not necessarily present on the inputs.
  Reply With Quote
Old 5th November 2017, 11:52 AM   #25
Depaj is offline Depaj  France
diyAudio Member
 
Join Date: Aug 2015
Location: lyon
I'm only getting noise, whether the disc is playing or not doesn't make a difference.
  Reply With Quote
Old 5th November 2017, 01:32 PM   #26
Depaj is offline Depaj  France
diyAudio Member
 
Join Date: Aug 2015
Location: lyon
D208 and D209 are shorted which puts pin 1 of Q341,342 and 343 at 0v instead of 5.2v and also pulled the 10v rail down to ground through R209 explaining the 1.4v drop.
D209 is a 1ss120, can I just replace this with a regular 1N4148 ? And D208 is a RD5.6ES zener, I guess a regular 500mW 5.6v zener will do here.
  Reply With Quote
Old 5th November 2017, 01:48 PM   #27
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Sony CDP 591 recognizes disc but doesn't play
D209 is shown as a IN4148
Attached Images
File Type: jpg Capture.JPG (69.1 KB, 32 views)
  Reply With Quote
Old 5th November 2017, 01:53 PM   #28
Depaj is offline Depaj  France
diyAudio Member
 
Join Date: Aug 2015
Location: lyon
Those schematics look way better than the ones I have, on mine I had to go and look the part number up in the parts list and there it was stated as a 1SS120. May I ask where you got those ?
  Reply With Quote
Old 5th November 2017, 01:56 PM   #29
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Sony CDP 591 recognizes disc but doesn't play
HiFi Engine. Its free to register

Sony CDP-591 - Manual - Stereo Compact Disc Player - HiFi Engine
  Reply With Quote
Old 5th November 2017, 02:35 PM   #30
Depaj is offline Depaj  France
diyAudio Member
 
Join Date: Aug 2015
Location: lyon
Yes I know that's where I get all my manuals from, but mine doesn't look like that...

Oh wait, I opened it with microsoft edge, with acrobat reader it is waaaay better !!

I will replace the 2 diode tuesday and report back
  Reply With Quote

Reply


Sony CDP 591 recognizes disc but doesn't playHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Why doesn't someone make a modern analog optical disc format for audio? MaximRecoil Analogue Source 47 24th December 2015 03:28 AM
casette player doesn't play Badsearcher Analogue Source 8 16th October 2013 10:12 AM
My sub doesn't play when connected to the stereo. pikipupiba Car Audio 8 10th August 2011 04:39 AM
can a vent which doesn't support sine play music? freddi Multi-Way 3 13th June 2010 06:11 AM
CD Player doesn't detect disc sometimes Gartak Digital Source 4 3rd January 2004 11:58 AM


New To Site? Need Help?

All times are GMT. The time now is 05:29 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki