Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Digital Line Level DACs, Digital Crossovers, Equalizers, etc.

Building with the Soekris dam1121
Building with the Soekris dam1121
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th February 2019, 01:47 PM   #551
dewdrop is online now dewdrop  Singapore
diyAudio Member
 
Join Date: Mar 2004
Location: Singapore
Building with the Soekris dam1121
Quote:
Originally Posted by derekr View Post
Have you grounded RPI to 1121?
Yes I did
__________________
Ed
  Reply With Quote
Old 16th February 2019, 03:14 PM   #552
intense-tavda is offline intense-tavda  Netherlands
diyAudio Member
 
Join Date: Jun 2005
Location: drachten
Hi There!
I got my boards together, I put the comperator board on the spdif point 6 from J2, connected the cd drive and no sound, only the led blinks 10 times and than it stops. Any idea why there is no sound?
  Reply With Quote
Old 16th February 2019, 09:24 PM   #553
derekr is offline derekr  Barbados
diyAudio Member
 
Join Date: Mar 2009
Quote:
Originally Posted by dewdrop View Post
Yes I did
Hmm....then I guess the usual steps - can you confirm (via another DAC) that your RPI is working via its i2s out? Are you measuring plus and minus 5V on the analog power pins on the 1121? And plus 5V on both digital power pins?

Assuming your strapping resistors are all good and going to ground (one or multiple grounds? Not that it should matter but double check them) I’d hook up a terminal program and check you’re getting the correct readout on power up.

Doesn’t hurt to connect the PWR_LED as well. Finally, what’s downstream? Is that amp/speakers or whatever working with output from another DAC?

Good luck.
  Reply With Quote
Old 17th February 2019, 08:28 AM   #554
dewdrop is online now dewdrop  Singapore
diyAudio Member
 
Join Date: Mar 2004
Location: Singapore
Building with the Soekris dam1121
@derekr, I appreciate you trying to help.

I have checked the +/-5V rails and they are all good.

Double checked on:
Raspberry Pi J12 <-> I2S BCLK_I
Raspberry Pi J35 <-> I2S LRCK_I
Raspberry Pi J40 <-> I2S DAT_I

I have added the PWR_LED and it remains unlocked even when there is content playing so it has nothing to do with the downstream equipment.

The next thing is to swap out the Raspberry Pi board with one that definitely works as well as to setup the terminal program to see the board status.
__________________
Ed
  Reply With Quote
Old 17th February 2019, 08:55 AM   #555
bambadoo is offline bambadoo  Norway
diyAudio Member
 
Join Date: Feb 2003
Location: West Coast of Norway
How long cables? And use 3 gnd wires.. i2s is quite difficult in this regard
  Reply With Quote
Old 17th February 2019, 10:23 AM   #556
dewdrop is online now dewdrop  Singapore
diyAudio Member
 
Join Date: Mar 2004
Location: Singapore
Building with the Soekris dam1121
Default Success! Well kind of...

Thanks guys for all the suggestion. Finally gotten the 1121 to play music on 96/24 FLAC and WAV files. Yah!

The culprit was the Raspberry Pi/Moode software. I swapped them wholesale from a working setup. I will investigate if its the board or the software later.

I have a new issue. I tried to use the MoOde 4.4 software to play DSD over DoP , although the LED shows that a locked status, there isn't any music. When I turned off the DoP setting, even though the LED blinks in the unlocked state, there is music but it stutters.

Anyone has experienced this before?
__________________
Ed
  Reply With Quote
Old 17th February 2019, 05:20 PM   #557
derekr is offline derekr  Barbados
diyAudio Member
 
Join Date: Mar 2009
Turn off SoX resampling in Moode.
  Reply With Quote
Old 17th February 2019, 11:30 PM   #558
dewdrop is online now dewdrop  Singapore
diyAudio Member
 
Join Date: Mar 2004
Location: Singapore
Building with the Soekris dam1121
It is already disabled.

But you got me tinkering around the SoX settings and I found that with the multi-threading with SoX enabled and 32 bit/96kHz got it to play DSD. Thanks!
__________________
Ed
  Reply With Quote

Reply


Building with the Soekris dam1121Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Soekris' DAC implementations Eldam Digital Line Level 1112 11th January 2019 06:35 AM
Output stage for the Soekris R2R robertrowett Digital Line Level 122 11th February 2017 11:38 AM
Sorry, need help again...Soekris Dac lock Green77 Digital Line Level 0 8th December 2015 06:49 PM
looking for soekris r2r dac fabrice63 Swap Meet 2 1st June 2015 10:50 AM


New To Site? Need Help?

All times are GMT. The time now is 01:08 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki