diyAudio

diyAudio (https://www.diyaudio.com/forums/index.php)
-   Digital Line Level (https://www.diyaudio.com/forums/digital-line-level/)
-   -   XMOS-based Asynchronous USB to I2S interface (https://www.diyaudio.com/forums/digital-line-level/188902-xmos-based-asynchronous-usb-i2s-interface.html)

qusp 4th September 2012 05:21 AM

the ones in the pic are panasonic PPS ECHU series

wlowes 4th September 2012 01:25 PM

1 Attachment(s)
Thanks qusp.

Also thanks to Reylands for supplying clear circuit diagram of Grundig mod. Just route clock signal from L5 instead of WS.

zibra 5th September 2012 06:57 PM

For sure theres someone whos using WaveIo with Linux right?:)
I have latest Ubuntu 12.04 with3.2 kernel(?) but I got no sound. I have no idea what to do, which command to type etc. For me Linux is very new system and I know nothing. Maybe someone could help me with it please? Could be on PM:)

MrSlim 5th September 2012 07:06 PM

The ALSA sound system may be muted.. There seems to be a "bug/feature" that its always muted on start up. Run alsamixer, and check the volume level. This Thread may help you [SOLVED] ALSA always on mute after startup - Ubuntu Forums

Also, check in your sound settings and confirm that the correct output device is selected..

zibra 5th September 2012 07:14 PM

I dont know how to run alsamixer and type other commands on console. I tried searching solution on website but doesnt work.
There is Luckit USB Audio found on sound settings - I tried both settings and no sound. i also have set sound at 100% and there is no visible mute in system.

wlowes 5th September 2012 07:27 PM

I believe its:
First run "alsamixer" to unmute and adjust the volume for all the channels you want and then run "alsactl store" to save these settings (in /etc//etc/asound.state). "alsactl restore" is used at system startup to restore your settings.

If I recall, mute is toggled in alsamixer in each channel with the M key. We all went through it the first time using WaveIO on Linux. Google around, you will find screen shots.

zibra 5th September 2012 07:30 PM

hmmm, when I typed alsamixer its says: cannot open mixer no such file or catalogue...

kuba@ubuntu:~$ alsamixer
cannot open mixer: Nie ma takiego pliku ani katalogu

MrSlim 5th September 2012 07:35 PM

Quote:

Originally Posted by zibra (https://www.diyaudio.com/forums/digital-line-level/188902-xmos-based-asynchronous-usb-i2s-interface-post3153376.html#post3153376)
hmmm, when I typed alsamixer its says: cannot open mixer no such file or catalogue...

kuba@ubuntu:~$ alsamixer
cannot open mixer: Nie ma takiego pliku ani katalogu

You have to run it as root ( sudo alsamixer)

soundcheck 6th September 2012 12:08 PM

You don't have to be root to run alsamixer.

You need to install alsa-utils.

Afaik alsamixer/amixer are not installed by default on Ubuntu. (You shouldn't need those)

So run:

sudo apt-get -y install alsa-utils

and then

alsamixer



What you could do first, run

cat /proc/asound/cards

or

aplay -l


with those commands, you can see if the card is recognized at all.

Wave-IO should work under Ubuntu, because it's working also on an SB Touch - which also runs a Alsa.

Good luck.

zibra 6th September 2012 03:26 PM

I installed fresh version of Linux Mint13 on formatted SSD drive. It works instantly and I have sound, BUT I still have no Alsamixer.
I typed that command above and received info that I got alsa utils in newest version, but after typing alsamixer there is no such file???

kuba@Kuba ~ $ sudo apt-get -y install alsa-utils
[sudo] password for kuba:
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności
Odczyt informacji o stanie... Gotowe
alsa-utils jest już w najnowszej wersji.
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 16 nieaktualizowanych.
kuba@Kuba ~ $ alsamixer
cannot open mixer: No such file or directory
kuba@Kuba ~ $

Im just afraid that I dont have bit perfect system as I heard that Pulseaudio is something bad like virus for normal purposes:) Anyone had such problem with nonexisting alsamixer at fresh installed system?
Maybe its a little OT but I think there could be many users who could have some problem after changing to Linux.


All times are GMT. The time now is 11:16 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 17.65%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright ©1999-2020 diyAudio

Wiki