Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Class D Switching Power Amplifiers and Power D/A conversion

IcePower 50asx2se one channel stopped working
IcePower 50asx2se one channel stopped working
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 21st May 2020, 01:47 AM   #1
Remlab is offline Remlab  United States
diyAudio Member
 
Join Date: Apr 2011
Location: Oceanside Ca
Default IcePower 50asx2se one channel stopped working

Is it fixable or is it toast? Anyone know?
__________________
It's not what you don't know that causes trouble. It's what you do know that just ain't so..Mark Twain
  Reply With Quote
Old 21st May 2020, 10:28 AM   #2
russc is offline russc  England
diyAudio Member
 
Join Date: Mar 2011
Location: W Yorkshire
No.
  Reply With Quote
Old 21st May 2020, 05:54 PM   #3
Remlab is offline Remlab  United States
diyAudio Member
 
Join Date: Apr 2011
Location: Oceanside Ca
I’ll take that as a no.
__________________
It's not what you don't know that causes trouble. It's what you do know that just ain't so..Mark Twain
  Reply With Quote
Old 21st May 2020, 06:05 PM   #4
plasnu is offline plasnu  United States
diyAudio Member
 
Join Date: Jan 2011
Location: NY USA
Remlab, I also have one channel dead module here. I can buy yours or I can sell mine so that one of us will have luxury mono blocks. LOL. If you're interested, please contact me.
  Reply With Quote
Old 21st May 2020, 07:49 PM   #5
russc is offline russc  England
diyAudio Member
 
Join Date: Mar 2011
Location: W Yorkshire
Sorry, that was a 'no I don't know', not a 'no it can't be fixed'.

Provide as much information as possible so members can help.
Or use it as single channel.
  Reply With Quote

Reply


IcePower 50asx2se one channel stopped workingHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Amp just stopped working audiorp Solid State 5 28th June 2017 02:24 PM
amp stopped working (jl 600/1v2) 4x4audio Car Audio 15 16th November 2015 12:34 AM
Amp Stopped Working twhittle14 Car Audio 30 25th November 2012 04:33 PM
Sub Stopped Working cmcimino Car Audio 4 27th June 2010 04:14 PM
el84 1 channel stopped working help eddiedavies Tubes / Valves 5 2nd April 2007 11:32 AM


New To Site? Need Help?

All times are GMT. The time now is 01:12 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright ©1999-2020 diyAudio
Wiki