Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Class D Switching Power Amplifiers and Power D/A conversion

CxD250-HP / SMPS320 Help!
CxD250-HP / SMPS320 Help!
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 24th July 2018, 01:53 PM   #1
mek1130 is offline mek1130
diyAudio Member
 
Join Date: Jun 2012
Default CxD250-HP / SMPS320 Help!

I quickly plugged in all the aux cable and the units come up. Then it's where the hell are inputs / outputs. Can anbody help? I would very much be less stressed.

Many thanks for your time and effort,
Murray
  Reply With Quote
Old 24th July 2018, 10:41 PM   #2
FauxFrench is offline FauxFrench  France
diyAudio Member
 
Join Date: Dec 2017
Location: The mountains, calm and quiet.
Hi Murray,
I simply don't understand the problem from what you write. Could you please try in a different way?

Are you talking about this amplifier and power supply?
CxD250-HP | Connex Electronic
SMPS320RxE | Connex Electronic
  Reply With Quote
Old 26th July 2018, 06:32 PM   #3
russc is offline russc  England
diyAudio Member
 
Join Date: Mar 2011
Location: W Yorkshire
Ask the supplier if you have no instructions with the unit.
Contact details are on their website.
  Reply With Quote
Old 29th July 2018, 04:01 AM   #4
mek1130 is offline mek1130
diyAudio Member
 
Join Date: Jun 2012
Default CxD250-HP

Yes they are the items. There is also a schematic that I'll try to upload. There are 3 block connectors. There are also leads that have been made to fit the 3 connectors, 1 power, 1 AUX and 1 status. To connect a x320 SMPS to the X250HP AMP is just plug and play. See: CxD250-HP | Connex Electronic
smps320se
The power and the amp appear to run their POST, AMP green light + red light then red out and steady green. I have a 5.5Kh sin input and a 20Mh scope + speaker on the out. I cannot get the amp to produce any out. The sin generator produces a tone on the speaker.

To compilcate this the word Out appears on a single pin on the power input block I+,G,I-,G,Out. This is the pin I'm checking for output but it's awfully placed if it is as the block is for power input. The (3) status block has a I-,G-I+. I'm using this for my input. It's just a guess.

Sorry if this is so vague Murray.
  Reply With Quote
Old 29th July 2018, 02:22 PM   #5
FauxFrench is offline FauxFrench  France
diyAudio Member
 
Join Date: Dec 2017
Location: The mountains, calm and quiet.
Hi Murray,
I would also get irritated if it is not clear how the Amplifier board has to be connected.
I only have the photo (top side) of the CxD250 you link to so my information is limited. BUT, I have a photo of the CxD300 both top and rear side. Lets assume there is some similarity.
Would you have some cheap speakers you can use until we know it works well?
On the CxD300, the green connector is for power connections and speaker output. The amplifier is using a symmetrical supply voltage and for the CxD300 the indications are found on the rear side. Here, three of the terminals are marked with "V+", "GND" and "V-" (clearly power inputs). The last two terminals of the green connector (CxD300) is marked with "GND" and "out" (clearly speaker outputs).
You say you have "I+,G,I-,G,Out", is that for the green connector block?

Next, you have two white connector blocks with 5 and 8 pins respectively. Somewhere here we have to look for the input.

Murray, would it be possible for you to post a photo of the rear side of the CxD250 board so I can see some of the PCB tracks?

Last edited by FauxFrench; 29th July 2018 at 02:27 PM.
  Reply With Quote
Old 29th July 2018, 09:57 PM   #6
mek1130 is offline mek1130
diyAudio Member
 
Join Date: Jun 2012
Default CxD250-HP

The pic's are the ones I'm using. Here is the Cx250 board but the schematic is not very clear : See insert.
Attached Images
File Type: jpg 8241_CXD-250_1.jpg (51.5 KB, 79 views)
  Reply With Quote
Old 29th July 2018, 10:39 PM   #7
FauxFrench is offline FauxFrench  France
diyAudio Member
 
Join Date: Dec 2017
Location: The mountains, calm and quiet.
Fine. You have "V+", "GND", "V-" (power supply connections) and "GND", "Out" (speaker output connections).
Then input: You have "+In", "GND" and "-In". That must be the input terminals. Since there are three, it is likely to be a balanced input (two counter-phases and a ground. If you do not have a balanced signal from the source, try with your smart-phone (not connected to the charger / floating) using the "+In" and "-In" and low volume on the smart-phone.
Finally "Mute" and "Sleep": Assume they are connected on the board such that the amplifier is active by default. You may measure with a volt-meter to see if these two inputs are pulled high by the board. If so, you may try to pull them low (to ground) through 1K resistors.
Let's see if you can get some sound out of one amplifier.
Don't forget to check that the supply voltages are right when turned ON.

Last edited by FauxFrench; 29th July 2018 at 10:42 PM.
  Reply With Quote
Old 29th July 2018, 11:01 PM   #8
mek1130 is offline mek1130
diyAudio Member
 
Join Date: Jun 2012
This Cx250hp looks very similiar to the 300.
  Reply With Quote
Old 30th July 2018, 07:12 AM   #9
FauxFrench is offline FauxFrench  France
diyAudio Member
 
Join Date: Dec 2017
Location: The mountains, calm and quiet.
At least for marking of the connection terminals.
The CxD250 has a number of control and monitoring pins that are not on the CxD300. Connecting them correctly may be the challenge.

Did you receive any kind of documentation when you bought the CxD250+SMPS320?
  Reply With Quote
Old 30th July 2018, 07:47 AM   #10
mek1130 is offline mek1130
diyAudio Member
 
Join Date: Jun 2012
Thank you, I'll test all the voltages.I swapped out the amp as I fried it! Turned the preamp too high by accident. fissle then pop/smoke.
  Reply With Quote

Reply


CxD250-HP / SMPS320 Help!Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Connex SMPS500RxE and CxD250 HP wiring diagram ZachAttack420 Class D 4 14th August 2019 05:57 AM
Connex CxD250-HP: Aux voltage pinout Berendzen Class D 3 8th November 2018 10:20 PM
Connexelectronic CxD250-HP + SMPS500RxE motorica Class D 2 19th July 2014 10:42 PM


New To Site? Need Help?

All times are GMT. The time now is 02:42 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki