Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Class D Switching Power Amplifiers and Power D/A conversion

What is wrong with TPA3255?
What is wrong with TPA3255?
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th February 2019, 05:55 PM   #761
chermann is offline chermann  Austria
diyAudio Member
 
Join Date: Jan 2017
Location: Vienna
Quote:
Originally Posted by doctormord View Post
I don't have that Power-Off-Pop feature on my implemenation of TPA32XX, neither 51 nor 55. The Pop comes from a race condition in fall-times of the power rails and can most likely avoided/tuned if the detection level for the voltage-supervisor is set tight to the supply voltage. If the level is to close to "nominal voltage", the amp will mute on high power with a weak supply. The EVMs solution with feed-forward capacitors is more prone to this effect as it kinda boosts dips in supply voltage change.


Using a TPS3802K33DCK, the threshold voltage for the SVS is 2.93V. The resistor divider 27k+3k3 then trips at about 27V.

Trip levels for other voltages:

34.9V: 36k + 3k3
32.2V: 33k + 3k3
30.3V: 30k9 + 3k3
29.6V: 30k + 3k3
27V: 27k + 3k3
24.2V: 24k + 3k3
22.5V: 22k + 3k3
20.7V: 20k + 3k3

So for a 36V system you may try 33k or 36k instead of 27k.

Hi doc

i use 27k , a zener 4Z7 and 28Vpower for the start...... but its not working. VDD is 2,754Volt. then i checked the 3k3 for the divider....its not 3k3 --> 3562R
reset an TPS "ARK" is still 0Volt...ok....i have no 3k3 at home
i try shortly to push 33V into it--> VDD is about 2.945V but the TPS"ARK" is still doing nothing=> Reset is 0V so the pin 18 of the TPA is 0V--> no sound
curious is that the MR of the TPS "ARK" is "open" but its about 2,74Volt??
did i miss something???


thx
chris
  Reply With Quote
Old 12th February 2019, 09:32 PM   #762
doctormord is offline doctormord  Germany
diyAudio Member
 
doctormord's Avatar
 
Join Date: Oct 2007
The levels are 2.87 2.93 2.99 (min type avg), so maybe yours not hitting 2.93V exactly. So either increase the 3k3 a bit or decrease the 27k. It's all written in the datasheet (TPS..)
  Reply With Quote
Old 13th February 2019, 08:35 AM   #763
chermann is offline chermann  Austria
diyAudio Member
 
Join Date: Jan 2017
Location: Vienna
Quote:
Originally Posted by doctormord View Post
The levels are 2.87 2.93 2.99 (min type avg), so maybe yours not hitting 2.93V exactly. So either increase the 3k3 a bit or decrease the 27k. It's all written in the datasheet (TPS..)

thanks doc..
  Reply With Quote
Old 13th February 2019, 12:38 PM   #764
chermann is offline chermann  Austria
diyAudio Member
 
Join Date: Jan 2017
Location: Vienna
...thank you Doc...its working


changed R1 to 22kR 1% and at 29,25V the circuit is working
at the R2(3562) its 2,986V...so its in between the tolerance.


the out pop is still audible "loud" compared to the power on plop. in my lab i use a small 4 ohm speaker. will see/hear at my good speakers what happend when the amp is ready...


thx
chris
  Reply With Quote
Old 13th February 2019, 01:21 PM   #765
doctormord is offline doctormord  Germany
diyAudio Member
 
doctormord's Avatar
 
Join Date: Oct 2007
Interesting.. i haven't noticed any problems/plop with my amps. So something must be different for the 12V rails on yours.
  Reply With Quote

Reply


What is wrong with TPA3255?Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
TPA3255 - all about DIY, Discussion, Design etc. lms Class D 980 Yesterday 06:20 PM
My 1st Class-D Amp -TPA3255 with PFFB JohnnyInBris Class D 19 13th August 2018 03:26 PM
FS: TPA3251 TPA3255 2.0 BTL Amplifier doctormord Swap Meet 11 13th August 2017 08:14 PM
TPA3255 Amplifier for Car Audio System GABRIELITEDEVIL Class D 6 1st January 2017 10:37 PM
Wrong Voltage / current on BoZ... or Wrong Measuring ? gionag Pass Labs 8 14th May 2008 12:24 PM


New To Site? Need Help?

All times are GMT. The time now is 07:44 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki