Go Back   Home > Forums > >

Kicker ZX1500.1 protects when driven hard
Kicker ZX1500.1 protects when driven hard
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools
Old Yesterday, 06:52 PM   #21
peeby is offline peeby
diyAudio Member
 
Join Date: May 2020
No, using the secondary ground.

Using the scope, the rail seems to "Freak out" right at the point of amp shutdown, hard to tell if it is prior or post to shut down.
  Reply With Quote
Old Yesterday, 07:28 PM   #22
PapaZBill is offline PapaZBill  United States
diyAudio Member
 
PapaZBill's Avatar
 
Join Date: Oct 2013
Location: Yale, Oklahoma
Have you tried to vary voltage w/o signal as Russell suggested in post #15?

I believe I have seen an issue with the UVP back in the day. Take voltage measurements around U2-TL494. Use power ground for black probe. Also check around Q28-KTC4401 and D30-1N5237B-8.2v zener diode.

The noise may be the cause of a burnt ground trace and be be why the amp is shutting down. You will have to examine the bottom side of PCB to determine. This was not an uncommon problem and is easily fixed.
__________________
Any sufficiently advanced technology is indistinguishable from magic.

Arthur C. Clarke
  Reply With Quote
Old Yesterday, 09:58 PM   #23
peeby is offline peeby
diyAudio Member
 
Join Date: May 2020
Varying voltage the amp shuts off when decreasing supply voltage at 9.5 volts.

Cant find any burned traces.

Voltage across zener D30 is 8.1V. Q28 checks ok in circuit.
  Reply With Quote
Old Yesterday, 11:15 PM   #24
PapaZBill is offline PapaZBill  United States
diyAudio Member
 
PapaZBill's Avatar
 
Join Date: Oct 2013
Location: Yale, Oklahoma
Post the DC volts around U2

Did you examine the bottom side of PCB?
__________________
Any sufficiently advanced technology is indistinguishable from magic.

Arthur C. Clarke
  Reply With Quote
Old Yesterday, 11:40 PM   #25
peeby is offline peeby
diyAudio Member
 
Join Date: May 2020
The voltage around U2 are normal. Pin 3 is staying at 0v and the chip is producing PWM on 9 and 10.

So I just figured out even with no load on the speaker outputs the amp will while increasing sine wave input, start to draw excessive current and shut down at the same point everytime. Pin 3 on U2 stays at 0V, then there is a transient spike on Pin 3 and it shuts down.
  Reply to this post

Reply


Kicker ZX1500.1 protects when driven hardHide this!Advertise here!
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kicker KX600.4 protects and led alternately flashing nonprof Car Audio 14 1st June 2016 05:20 AM
Kicker ZX1500.1 without gate drive. Randy62 Car Audio 7 29th May 2013 06:47 PM
kicker zx1500 mosfet question ksweet420 Car Audio 9 11th March 2013 10:12 PM
kicker zx1500.1 output inductor? shane300zx Car Audio 9 2nd August 2011 09:58 AM
Kicker zx1500.1 not working Andrew123654 Car Audio 12 19th October 2010 01:04 PM


New To Site? Need Help?

All times are GMT. The time now is 03:57 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Copyright ©1999-2021 diyAudio
Wiki