Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

American Bass VFL 110.1 protection after relay
American Bass VFL 110.1 protection after relay
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th September 2019, 05:49 PM   #31
barber02 is offline barber02  United States
diyAudio Member
 
Join Date: Jun 2018
Location: Georgia
The trigger level doesn’t clean up the drive signal in any of the modes other than make it worse if you go too far in one direction or the other.

Adjusting the hold off to about 4.6us does clean it up a little bit but not much.
Attached Images
File Type: jpg CEE61A6A-56F4-47D2-817F-1D2F16AC71B0.jpg (883.9 KB, 14 views)
  Reply With Quote
Old 13th September 2019, 03:12 PM   #32
barber02 is offline barber02  United States
diyAudio Member
 
Join Date: Jun 2018
Location: Georgia
I pulled the output mosfets from this amp and it no longer goes into protection. Iím still reading 1.5 vdc at the speaker terminals.

This is the drive signal on the low side and high drives. I was wondering if this looks normal before I go any further with this. The drive signal looks the same at the pads of the mosfets as it does coming out of the driver board measured before it reaches the motherboard.

Probe is 1x, scope is set to 5v/div, 5us

Thanks for your input.

David
Attached Images
File Type: jpg A5F49615-009B-4D72-884D-07EE4A6FE985.jpg (980.4 KB, 10 views)
File Type: jpg E4A430BE-3754-41EB-A630-A8C621224F1F.jpg (694.3 KB, 9 views)
  Reply With Quote
Old 13th September 2019, 03:46 PM   #33
twilliar is offline twilliar  United States
diyAudio Member
 
Join Date: Aug 2019
Location: Washington
I would revisit the drive card (do you get excessive hot spots when powered on), check the pull-down and gate resistors and double-check the output transistors. Not many ways for DC to get to the output if the output transistors are being driven correctly.
  Reply With Quote
Old 13th September 2019, 04:07 PM   #34
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
You initially stated that the amp had DC on it's output but the waveforms you've posted show nothing that would produce significant DC offset and the amp is remaining on long enough for you to get the images of the waveforms. What has changed?
__________________
Anyone who purchased the repair tutorial, email me (babin_perry@yahoo.com) if you want to download the latest version.
  Reply With Quote
Old 13th September 2019, 05:18 PM   #35
barber02 is offline barber02  United States
diyAudio Member
 
Join Date: Jun 2018
Location: Georgia
All I did was remove the output mosfets.

Then I powered up the amp to look at the wave forms and that’s the pictures I posted today.

As for yesterday...

When I was taking the scope images before I removed the outputs all I did was lower the voltage to the amp from 14 volts to 10 volts. The DC to the output would slowly rise to 3 volts before the protection circuit kicked in. That would usually take about a minute. At 14 volts the DC would rise in a matter of seconds.

David
  Reply With Quote
Old 13th September 2019, 07:09 PM   #36
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Is there any DC voltage on the RCA shields?
__________________
Anyone who purchased the repair tutorial, email me (babin_perry@yahoo.com) if you want to download the latest version.
  Reply With Quote

Reply


American Bass VFL 110.1 protection after relayHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
American Bass VFL 500.1 Deadly Sones Car Audio 36 20th October 2014 01:04 AM
American bass megael9 Car Audio 19 20th May 2014 12:12 AM
American bass protection mode Austin texans Introductions 1 15th October 2013 02:39 PM
American Bass sq300 Jailbreak Car Audio 1 22nd August 2013 06:49 PM
American Bass VFL-500.1 mike49504 Car Audio 5 7th January 2011 11:07 PM


New To Site? Need Help?

All times are GMT. The time now is 06:34 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki