Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

HFI1500D Power Fets Blow After Remote is Disconnected
HFI1500D Power Fets Blow After Remote is Disconnected
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th September 2019, 03:47 AM   #1
djeokis is offline djeokis
diyAudio Member
 
Join Date: Jul 2019
Default HFI1500D Power Fets Blow After Remote is Disconnected

Looking for help on my HFI1500D Amp. The amps turns on normal, no over heating no current gain, just fine, once i disco the remote, my power fets blow. Amp is using IRFZ44N for the power. Nothing happens to the audio. It only blows the ones from the Power Terminal side.
I have replaced the transistors from the driver module and the OP amps. ( 1D, P2D )

Any help will be appreciated.
Thanks
  Reply With Quote
Old 6th September 2019, 04:00 AM   #2
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If you don't get any answers, post a photo of the entire power supply section and another of the PS control section.
__________________
Anyone who purchased the repair tutorial, email me (babin_perry@yahoo.com) if you want to download the latest version.
  Reply With Quote
Old 6th September 2019, 04:25 AM   #3
djeokis is offline djeokis
diyAudio Member
 
Join Date: Jul 2019
Here are some Pics
Click the image to open in full size.
Click the image to open in full size.
Click the image to open in full size.
Click the image to open in full size.
  Reply With Quote
Old 6th September 2019, 05:31 AM   #4
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
To upload photos click the following:

Go Advanced
Manage Attachments
Browse
Upload

Repeat as necessary

Preview post to see how the post will look.

Click Submit Reply to send it to the forum.
__________________
Anyone who purchased the repair tutorial, email me (babin_perry@yahoo.com) if you want to download the latest version.
  Reply With Quote
Old 6th September 2019, 06:29 AM   #6
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
They're not posted correctly.
__________________
Anyone who purchased the repair tutorial, email me (babin_perry@yahoo.com) if you want to download the latest version.
  Reply With Quote
Old 6th September 2019, 06:38 AM   #7
djeokis is offline djeokis
diyAudio Member
 
Join Date: Jul 2019
Attached Images
File Type: jpg FormatFactory20190905_210853.jpg (499.1 KB, 3 views)
File Type: jpg FormatFactory20190905_210902.jpg (572.5 KB, 3 views)
File Type: jpg FormatFactory20190905_210914.jpg (765.5 KB, 5 views)
File Type: jpg FormatFactory20190905_210926.jpg (718.6 KB, 7 views)
  Reply With Quote
Old 6th September 2019, 06:48 AM   #8
djeokis is offline djeokis
diyAudio Member
 
Join Date: Jul 2019
Here is a pic of the whole amp. My apologies for previous posts..
Attached Images
File Type: jpg FormatFactory20190905_234543.jpg (540.0 KB, 18 views)
  Reply With Quote
Old 6th September 2019, 06:59 AM   #9
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Do you have a scope?

Did you check the value of the gate resistors to confirm that they're within tolerance?
__________________
Anyone who purchased the repair tutorial, email me (babin_perry@yahoo.com) if you want to download the latest version.
  Reply With Quote
Old 6th September 2019, 07:02 AM   #10
djeokis is offline djeokis
diyAudio Member
 
Join Date: Jul 2019
Yes. I do.
  Reply With Quote

Reply


HFI1500D Power Fets Blow After Remote is DisconnectedHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hfi1500d help Colorado8804 Class D 6 23rd June 2019 06:49 AM
NAD fuses, slow blow or fast blow? AllCaster Solid State 3 25th October 2009 06:11 PM
Remote mounting fets Safe_Cracker Class D 1 14th February 2009 07:47 AM
DC offset after power disconnected Pooley Chip Amps 10 25th September 2008 11:33 PM
Just had a power cap blow! azira Parts 19 24th June 2004 09:28 AM


New To Site? Need Help?

All times are GMT. The time now is 12:34 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki