Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

SPL BTX1200 Weird things with output.
SPL BTX1200 Weird things with output.
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 21st May 2019, 05:30 PM   #1
JanzzLV is offline JanzzLV
diyAudio Member
 
Join Date: May 2019
Default SPL BTX1200 Weird things with output.

Hello! I have a SPL BTX1200 amplifier for my cars subwoofer, it turns on well, green light goes on. The problem is with the output. At first i thought that the output is not working at all as i had no sound, nothing at all. When i was touching the wires to the channels, on the first moment when i connected the other wire, it made a "bass" for a second. Then i attached them completely and when i was switching between "LPF/FULL/HPF" it did the "bass" for a second each time i switched to HPF again. Later, i decided to try to crank the volume up, set the HU to play only to the subwoofer and try again, It's a 2 channel amp, when bridged, it was very very quiet and the sound was awful (when HU was on almost max), on the first channel aswell, but on the second channel it sounded a lot louder, but the sound is awful, a lot of weird noses. If i am increasing the gain on the amp, subwoofer starts to sound louder, but still very bad quality. Under 25 volume (which is very high for me), doesn't give any sound at all. Only if i crank it up to 30-35(max). The amplifier was put in a shelf for 1.5 years, now it is doing this thing. What could be the reason? Subwoofer is fully functional itself, i tested it with another amp before.
  Reply With Quote
Old 21st May 2019, 05:39 PM   #2
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Does it do anything strange with no RCAs plugged in?

Have you checked the shield ground on your head unit?
__________________
Anyone who purchased the repair tutorial, email me (babin_perry@yahoo.com) if you want to download the latest version.
  Reply With Quote
Old 21st May 2019, 05:45 PM   #3
JanzzLV is offline JanzzLV
diyAudio Member
 
Join Date: May 2019
Quote:
Originally Posted by Perry Babin View Post
Does it do anything strange with no RCAs plugged in?

Have you checked the shield ground on your head unit?
If no rcas plugged in, no weird sounds etc. It's quiet. If i pull out the black one from the amp, still the sound remains the same, plugging it back doesn't change anything. I haven't checked the shield ground on HU, but i had a different amp a week ago and it was perfectly working with that one.
  Reply With Quote
Old 21st May 2019, 09:11 PM   #4
JanzzLV is offline JanzzLV
diyAudio Member
 
Join Date: May 2019
I just noticed that every time i turn on the HU, the subwoofer pops (i don't know how to describe it, like puffs few times) no matter if something is playing or no.
  Reply With Quote

Reply


SPL BTX1200 Weird things with output.Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird Rega output omnivor Digital Source 8 24th April 2014 03:59 PM
SRC4192 weird output afo Digital Line Level 2 5th March 2013 08:47 AM
Bad things about using a CC output stage besides inefficiency? Fusion916 Solid State 0 11th September 2012 09:35 PM
Weird things with lm3886 (brainGT-kit) michielbeijer Chip Amps 4 14th January 2007 03:58 PM
Things important to be said..helped by Mr. John Mateus to express things. destroyer X Solid State 22 31st July 2006 07:21 PM


New To Site? Need Help?

All times are GMT. The time now is 10:32 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki