Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Once	again need help fixing Orion HCCA 225 Digital Reference
Once	again need help fixing Orion HCCA 225 Digital Reference
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th February 2019, 05:16 AM   #1
Chopperbuilder is offline Chopperbuilder  United States
diyAudio Member
 
Join Date: May 2018
Location: St. Louis
Default Once again need help fixing Orion HCCA 225 Digital Reference

Perry, if you see this, I once again started working on the the Orion HCCA 225 Digital Reference that you were helping with before... the thread "Again needing help fixing Orion HCCA Digital Reference". I found the circuit board itself had continuity from the capacitors having leaked electrolyte, which was what was causing the problem with the muting circuit.

I recently acquired another circuit board for it. The transformer and few of the power Mosfet's were blown on it. I replaced the transformer with the one from my board, also some resistors, diodes, ceramic capacitors, etc... I also replaced all the electrolytic capacitors, power Mosfet's and output Mosfet's using new parts. So...I then put power to the amp and it powers up. I shut it down connect the RCA's and one speaker. It works great. I shut it down and connected the another speaker to the other channel. It still works great. I let it play for a bit. Shut it down and do a visual inspection of the board...all looks good. So I power it back up again but this time it takes a few seconds to power up (red light to come on). I shut it down and powered it back up and it immediately comes on. I then shut it down, waited a few minutes and powered it back up and it again takes a few seconds to power up. So at this point I shut it down, waited about 10 minutes and then tried to power it back up but now it no longer powers up at all. I checked the center legs of the power Mosfet's and they do have 12 volts. Nothing on the other legs. Also noticed the center legs on both sides of the board are +12 volts... Any ideas on what I should check?
  Reply With Quote
Old 5th February 2019, 05:26 AM   #2
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Post a photo of the area around the two opto-couplers. They are likely beige 6-legged ICs.
  Reply With Quote
Old 5th February 2019, 05:59 AM   #3
Chopperbuilder is offline Chopperbuilder  United States
diyAudio Member
 
Join Date: May 2018
Location: St. Louis
I replaced the opto-coupler with the yellow circle around it from my other board, thinking it may be the problem. I did not replace the other one.
Attached Images
File Type: jpg 20190205_003541.jpg (463.4 KB, 79 views)
File Type: jpg 20190205_003600.jpg (766.7 KB, 75 views)
File Type: jpg 20190205_003541-1.jpg (468.3 KB, 73 views)

Last edited by Chopperbuilder; 5th February 2019 at 06:10 AM.
  Reply With Quote
Old 5th February 2019, 06:15 AM   #4
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Post the DC voltage on all of the pins of the opto-coupler you replaced.
  Reply With Quote
Old 5th February 2019, 06:39 AM   #5
Chopperbuilder is offline Chopperbuilder  United States
diyAudio Member
 
Join Date: May 2018
Location: St. Louis
I believe I am numbering the pins correctly...
1 - +1.5 volts
2- 0 volts
3- 0 volts - doesn't seem to have any continuity at all
4- +12.08 volts
5- +12.26 volts
6- +12.75 volts
Attached Images
File Type: jpg 20190205_003541-2.jpg (646.2 KB, 71 views)

Last edited by Chopperbuilder; 5th February 2019 at 06:49 AM.
  Reply With Quote
Old 5th February 2019, 06:42 AM   #6
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Did you put the numbers on the wrong IC or did you circle the wrong one?
  Reply With Quote
Old 5th February 2019, 06:50 AM   #7
Chopperbuilder is offline Chopperbuilder  United States
diyAudio Member
 
Join Date: May 2018
Location: St. Louis
I just corrected the photo. I numbered the wrong one.
  Reply With Quote
Old 5th February 2019, 06:55 AM   #8
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
What is the DC voltage on the 3 legs of the MPSA06 in front of pin 4 of the opto-coupler?

What is the DC voltage on both terminals of the thermostat (metallic device under the board)?
  Reply With Quote
Old 5th February 2019, 07:06 AM   #9
Chopperbuilder is offline Chopperbuilder  United States
diyAudio Member
 
Join Date: May 2018
Location: St. Louis
MPSA06:
+12.26 volts - leg closest to IC
+12.09 volts - center leg
+11.42 volts - leg furthest from IC


Thermostat:
+11.42 volts on both terminals.
  Reply With Quote
Old 5th February 2019, 07:09 AM   #10
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Those are OK. The next thing to check is the voltage on all pins of the 494. Copy and paste the following.


Pin 1:
Pin 2:
Pin 3:
Pin 4:
Pin 5:
Pin 6:
Pin 7:
Pin 8:
Pin 9:
Pin 10:
Pin 11:
Pin 12:
Pin 13:
Pin 14:
Pin 15:
Pin 16:
  Reply With Quote

Reply


Once	again need help fixing Orion HCCA 225 Digital ReferenceHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Again needing help fixing Orion HCCA 225 Digital Reference Chopperbuilder Car Audio 123 13th July 2018 02:27 AM
Help fixing Orion HCCA 225 Digital Reference Chopperbuilder Car Audio 9 18th May 2018 09:30 PM
Orion 250 HCCA Digital Reference Gioba Car Audio 4 15th October 2013 01:13 PM
orion 2100 hcca digital reference timwebb Car Audio 1 10th March 2013 07:09 PM
Orion 225 Hcca digital reference Bunn Swap Meet 0 30th January 2009 12:25 PM


New To Site? Need Help?

All times are GMT. The time now is 12:31 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki