Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Kicker CXA300.4 no audio troubleshooting help.
Kicker CXA300.4 no audio troubleshooting help.
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 30th October 2018, 06:39 PM   #1
rhempz01 is offline rhempz01  United States
diyAudio Member
 
Join Date: Nov 2016
Location: Milford Delaware
Default Kicker CXA300.4 no audio troubleshooting help.

I have a kicker 4 channel with no audio at the speaker terminals. The amplifier start normally and seems to be working it draws .68amps of current.
Attached Images
File Type: jpg 15409247137195713983427525578188.jpg (996.3 KB, 39 views)
  Reply With Quote
Old 31st October 2018, 02:58 AM   #2
PapaZBill is online now PapaZBill  United States
diyAudio Member
 
PapaZBill's Avatar
 
Join Date: Oct 2013
Location: Yale, Oklahoma
Are the rail voltages present? The +/- 15 volts to the preamp?

Check the voltage between speaker and power ground. It should be 0 volts. If not the zero ohm resistor/jumper is open.
__________________
Any sufficiently advanced technology is indistinguishable from magic.

Arthur C. Clarke
  Reply With Quote
Old 31st October 2018, 03:16 AM   #3
rhempz01 is offline rhempz01  United States
diyAudio Member
 
Join Date: Nov 2016
Location: Milford Delaware
i pulled it apart and it has a blown 5402 diode, several capacitors, the power supply is shorted, a cap id blown on the class d board. the 4r7 resistor in the remote curcuit is burnt. Its so many componts, I may leave this one a parts amp.
  Reply With Quote
Old 31st October 2018, 06:13 PM   #4
PapaZBill is online now PapaZBill  United States
diyAudio Member
 
PapaZBill's Avatar
 
Join Date: Oct 2013
Location: Yale, Oklahoma
What your describing is a result of under rated power cables and improper fusing, It's not uncommon to see this in the repair department. There may be a burnt trace on the bottom side. This will require replacing all four IRFZ46N's, Three 2200uf/25v caps, maybe a smaller value cap in the same area. P39-4.7 ohm is tied to Q17-2SB772 and Q3_2N4403 which may be shorted. Possible RP87-0 ohm resistor and repairing trace. Possible a shorted output.

This is your call and I think the daughter boards are worth salvage, among other things.

BTW, there is no class D board on this amp. This is a Class A/B amp and does not require a class D circuit. Are you referring to the daughter board in the power supply section, or the Input/Preamp board?
__________________
Any sufficiently advanced technology is indistinguishable from magic.

Arthur C. Clarke
  Reply With Quote
Old 31st October 2018, 06:50 PM   #5
rhempz01 is offline rhempz01  United States
diyAudio Member
 
Join Date: Nov 2016
Location: Milford Delaware
I removed the capacitors, and the diode, the 4.7ohm resistors is burnt and open. All four power supply mosfets. I do have all the required parts. So I'll attempt it. The only reason I said that is I still can't get the other one work. There is also an exploded cap on the daughter board possibly, a 100uf 16v-25v. We'll see how it goes. Maybe it will help me with the other one.
  Reply With Quote
Old 31st October 2018, 10:08 PM   #6
rhempz01 is offline rhempz01  United States
diyAudio Member
 
Join Date: Nov 2016
Location: Milford Delaware
It was a 10uf 25v cp4. I don't have drive at the ps mosfets now. Open pnp drivers? Amp has no power supply mosfets in curcuit and in protection.
  Reply With Quote
Old 1st November 2018, 02:08 AM   #7
PapaZBill is online now PapaZBill  United States
diyAudio Member
 
PapaZBill's Avatar
 
Join Date: Oct 2013
Location: Yale, Oklahoma
What is the locator of the 10uf/25v cap?

Post a tight picture of the daughter board,component side and the bottom side of the main board.

There may be a burnt trace on the bottom side that could be causing no drive.

The edited picture I posted show three arrows.

One arrow shows a zero ohm resistor that tie the other two arrows together. Speaker and Power Grounds. Check the resistor and the two arrows test points with an ohmmeter. You should see near zero ohms between them. If these two points are open it will cause a voltage drop that will cause muting and other issues.
Attached Images
File Type: jpg 15409247137195713983427525578188.jpg (942.9 KB, 29 views)
__________________
Any sufficiently advanced technology is indistinguishable from magic.

Arthur C. Clarke
  Reply With Quote
Old 1st November 2018, 02:47 AM   #8
rhempz01 is offline rhempz01  United States
diyAudio Member
 
Join Date: Nov 2016
Location: Milford Delaware
.4 ohms from ground. And the resistor tests .3ohms. I think it's good. The resistor that exploded is "cp4" I replaced it. Along with everything else the 2200 25v power supply capacitors. Amp stays in protection.
  Reply With Quote
Old 1st November 2018, 02:49 AM   #9
rhempz01 is offline rhempz01  United States
diyAudio Member
 
Join Date: Nov 2016
Location: Milford Delaware
Daughter board front.
Attached Images
File Type: jpg 1541040455566584395648591406542.jpg (782.9 KB, 24 views)
  Reply With Quote
Old 1st November 2018, 02:50 AM   #10
rhempz01 is offline rhempz01  United States
diyAudio Member
 
Join Date: Nov 2016
Location: Milford Delaware
Daughter card rear
Attached Images
File Type: jpg 1541040573211655027829456374108.jpg (645.7 KB, 24 views)
  Reply With Quote

Reply


Kicker CXA300.4 no audio troubleshooting help.Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kicker CXA300-4 Won't power on. rhempz01 Car Audio 8 25th July 2018 07:08 PM
Kicker ZX750.1 troubleshooting resistors bejagutn Car Audio 16 15th May 2016 03:54 PM
JL Audio 300/4 Low Audio Output Troubleshooting Tip kds9591 Car Audio 3 25th December 2012 01:09 PM
Kicker and Hi-Vi , car audio, max spl, jadenlinkletter Subwoofers 3 30th March 2005 03:29 PM


New To Site? Need Help?

All times are GMT. The time now is 08:37 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki