Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Rockford Fosgate power 300 mosfet
Rockford Fosgate power 300 mosfet
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th October 2018, 11:40 PM   #1
chipper is offline chipper  United States
diyAudio Member
 
Join Date: Oct 2008
Location: Los Angeles
Send a message via MSN to chipper Send a message via Yahoo to chipper
Default Rockford Fosgate power 300 mosfet

Got a power 300 with a bad power supply. One buz10 went bad when I applied power and remote. Is there a reason for that to open? And what’s direct replacement for buz10? Thanks!
__________________
Feel the PUNCH
  Reply With Quote
Old 6th October 2018, 12:07 AM   #2
chipper is offline chipper  United States
diyAudio Member
 
Join Date: Oct 2008
Location: Los Angeles
Send a message via MSN to chipper Send a message via Yahoo to chipper
Here’s the board
Attached Images
File Type: jpg 6762B6E1-0345-4A01-98E2-C4CDDC2B459F.jpg (1,020.1 KB, 80 views)
File Type: jpg A62073AF-9DF9-4986-8BE4-68BFD548366D.jpg (987.5 KB, 77 views)
__________________
Feel the PUNCH
  Reply With Quote
Old 6th October 2018, 01:42 AM   #3
Old'n'Cranky is offline Old'n'Cranky  Australia
diyAudio Member
 
Join Date: Aug 2009
Looks like a hell of a lot of corrosion throughout the board.
  Reply With Quote
Old 6th October 2018, 07:16 AM   #4
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Assuming that there were no problems in the audio section...
heatsink coating failing
age (most likely)
bad connections on the gate terminals of one of the PS FETs
shorted rectifier or transformer

Replace the FETs with more modern FETs. The IRFZ44 with 100 ohm gate resistors should be good enough.
  Reply With Quote
Old 10th March 2019, 10:56 AM   #5
Josheep is offline Josheep
diyAudio Member
 
Join Date: Mar 2015
Hi guys much the same problem, one buz10 is toasted. I didn’t apply power, it just came to me like that. I just wanted to check how the IRFZ44 worked out for you chipper, and Perry when you say 100ohm gate resistors I haven’t found a schematic so without wanting to sound like too much of a muppet which resistors on the board are they?
  Reply With Quote
Old 10th March 2019, 04:13 PM   #6
jkrokenberger is offline jkrokenberger  United States
diyAudio Member
 
Join Date: Jun 2018
I used these as direct replacements for BUZ10's and had good success without changing the gate resistors. From this seller also. Some sellers send authentic parts, some don't - I got good parts from this seller.

Harris N-Channel Power MOSFET, 50v, 25A - Lot of 10 | eBay
  Reply With Quote
Old 10th March 2019, 04:18 PM   #7
jkrokenberger is offline jkrokenberger  United States
diyAudio Member
 
Join Date: Jun 2018
The parts I linked to are similar in spec to the BUZ10 so don't expect any more out of them. The IRFZ44 is a stronger part and will be more reliable but takes the added work of changing the gate resistors.

So long as the work is done well and the amp is given good electrical with a load it was designed for you will have no issues with either.
  Reply With Quote
Old 10th March 2019, 09:54 PM   #8
Josheep is offline Josheep
diyAudio Member
 
Join Date: Mar 2015
Thanks jkrokenberger, gutted that that’s a US seller as I’m UK based. I’m not after anything extra just to get the thing running (without compromising the sound it would already of had), I’m happy to build in some extra resilience though so if you/anyone knows of a schematic or could point me in the right direction I’d be well happy to change the resistors and stick in some IRFZ44’s.
  Reply With Quote
Old 11th March 2019, 12:02 AM   #9
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Please don't post in a repair thread that was started by someone else unless you are trying to help them.

Start a new thread.
  Reply With Quote
Old 13th March 2019, 02:04 PM   #10
Josheep is offline Josheep
diyAudio Member
 
Join Date: Mar 2015
Quote:
Originally Posted by Perry Babin View Post
Please don't post in a repair thread that was started by someone else unless you are trying to help them.

Start a new thread.
Apologies, will do. Got a bit overexcited to see the same fault and jumped on board
  Reply With Quote

Reply


Rockford Fosgate power 300 mosfetHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rockford fosgate power 1000 mosfet chipper Car Audio 31 8th December 2017 11:49 PM
Rockford Fosgate POWER 650 MOSFET harrysetiawanh Car Audio 3 13th May 2017 03:59 PM
Rockford Fosgate Power 300 Mosfet seankane Car Audio 21 2nd February 2013 09:49 PM
rockford fosgate power 650 mosfet mike49504 Car Audio 43 24th March 2011 10:21 PM
rockford fosgate power 300 mosfet mike49504 Car Audio 26 23rd December 2009 04:06 AM


New To Site? Need Help?

All times are GMT. The time now is 04:40 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki