Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

optidrive 700x2
optidrive 700x2
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 4th April 2018, 02:49 PM   #1
megael9 is offline megael9
diyAudio Member
 
Join Date: Oct 2009
optidrive 700x2
Default optidrive 700x2

Amp came to me with 2 blowing mosfets. 1 C5242, AND 1 A1962.
After replacing these parts, I noticed that one channel have -75 volts.
All signals are present at the mosfets gates.
any idea?
Attached Images
File Type: jpg IMG_00071.jpg (361.0 KB, 25 views)
__________________
fluke 50 mhz scope,35 amp power supply,0.5-12v adj power supply, fluke 179,hot air desolder gun, merit multyfuntion signal tracer/generator.
  Reply With Quote
Old 5th April 2018, 07:03 AM   #2
MarioRestucci is offline MarioRestucci  Italy
diyAudio Member
 
MarioRestucci's Avatar
 
Join Date: Aug 2012
Location: NAPOLI
The 2 components you found are BJT transistors, they are not mosfets.
Probably the drivers of the malfunctioning channel will also be burned.
Uninstall them and check for short junctions.
WARNING! it may not be the only problem.
Try taking a close-up photo of the channel area that does not work.
  Reply With Quote

Reply


optidrive 700x2Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Lanzar OPTIDRIVE 700X2 Formas Car Audio 10 24th July 2016 03:13 AM
Lanzar Optidrive 2500 KriszXJR Car Audio 2 26th January 2016 03:09 AM
Need Help With Lanzar OptiDrive KansasKowboy Car Audio 2 1st April 2010 02:41 PM
Lanzar Optidrive 6200 LORNECALIFORNIA Car Audio 2 18th January 2008 02:03 AM
Schematics Lanzar Optidrive 100 Tms gcu Swap Meet 0 26th November 2005 04:20 PM


New To Site? Need Help?

All times are GMT. The time now is 09:19 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright ©1999-2020 diyAudio
Wiki