Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Help with Crossfire BMF 600.2
Help with Crossfire BMF 600.2
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th January 2017, 12:11 AM   #1
kiermee is offline kiermee  Trinidad and Tobago
diyAudio Member
 
Join Date: Jan 2010
Default Help with Crossfire BMF 600.2

Hey All,

I am here to ask your assistance with another repair. The amp is a crossfire BMF 600.2. It's a two channel amp.

Problem I am having , when the amp is powered up it turns on normal and plays normal, but once I turn it off and try to turn it back on it does not come back on. It has one green led and this would give a slight blink as the amp it trying to start. It I disconnect the B+ and leave off for a while 10 mins or more and reconnect and then power back up it turns on normal. If I then turn off and try to turn on it does not come back on.

There was a problem intially where a 5.6 ohm base resistor for a C4467 transistor went open. I changed it along with the the transistor. Everything else seems ok.

Seems as though something has to discharge before the amp can power up again.

Any assistance with this will be greatly appreciated.

Thanks in advance.
  Reply With Quote
Old 9th January 2017, 12:32 AM   #2
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Post a photo of the board.
__________________
Anyone who purchased the repair tutorial, email me (babin_perry@yahoo.com) if you want to download the latest version.
  Reply With Quote
Old 9th January 2017, 02:05 AM   #3
kiermee is offline kiermee  Trinidad and Tobago
diyAudio Member
 
Join Date: Jan 2010
Thanks for your quick response. Please see attached.

If you require any other info please let me know .

Thanks again

Please let me know if you got the pics I sent six
Attached Images
File Type: jpg image.jpg (793.6 KB, 53 views)
  Reply With Quote
Old 9th January 2017, 02:07 AM   #4
kiermee is offline kiermee  Trinidad and Tobago
diyAudio Member
 
Join Date: Jan 2010
Here are three more
Attached Images
File Type: jpg image.jpg (717.2 KB, 54 views)
  Reply With Quote
Old 9th January 2017, 02:09 AM   #5
kiermee is offline kiermee  Trinidad and Tobago
diyAudio Member
 
Join Date: Jan 2010
I am sending one pic at a time not getting to upload all
Attached Images
File Type: jpg image.jpg (815.9 KB, 50 views)
  Reply With Quote
Old 9th January 2017, 04:47 PM   #6
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Is the voltage different on pins 1 and 7 of IC 502 when it powers up normally and when it won't power up?
__________________
Anyone who purchased the repair tutorial, email me (babin_perry@yahoo.com) if you want to download the latest version.
  Reply With Quote
Old 9th January 2017, 08:46 PM   #7
kiermee is offline kiermee  Trinidad and Tobago
diyAudio Member
 
Join Date: Jan 2010
I measured the voltages to ground, see below:

On normal startup

Pin 1 = 4.84V
Pin 7 = 4.92V

When it won't power up

Pin 1 = 0.112V constant

Pin 7 = pulsing from 0.095V to 4.92V
  Reply With Quote
Old 9th January 2017, 10:53 PM   #8
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I've been trying to find a similar amp but I can't find one that uses the 494 and an op-amp that has the outputs high normally. I'll keep looking.
__________________
Anyone who purchased the repair tutorial, email me (babin_perry@yahoo.com) if you want to download the latest version.
  Reply With Quote
Old 10th January 2017, 12:13 AM   #9
kiermee is offline kiermee  Trinidad and Tobago
diyAudio Member
 
Join Date: Jan 2010
Ok thanks I greatly appreciate all you assistance here.
  Reply With Quote
Old 11th January 2017, 12:59 PM   #10
kiermee is offline kiermee  Trinidad and Tobago
diyAudio Member
 
Join Date: Jan 2010
Hey Perry any luck as yet?
  Reply With Quote

Reply


Help with Crossfire BMF 600.2Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: Pair of CineMag CMOB-4H 600:600 Line Output Transformers Steve Eddy Swap Meet 3 22nd December 2016 10:09 PM
FS: NEW Jensen JT-11-YMPC Output Transformer 600:600 Perfect for any v-out DAC! wireswithgain Swap Meet 10 11th July 2015 09:41 PM
Crossfire bmf 1700d kiermee Car Audio 20 1st April 2015 12:24 AM
New Vishay AUR audio series BMF resistors Damon Hill Parts 0 17th November 2013 05:04 AM
FS cinemag transformers nickel CMOQ-2H 600:600 Gluca Swap Meet 10 6th March 2013 06:01 PM


New To Site? Need Help?

All times are GMT. The time now is 04:36 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright ©1999-2020 diyAudio
Wiki