Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

rubicon 2500 problem any one can help?
rubicon 2500 problem any one can help?
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th April 2015, 02:29 PM   #1
hadidin is offline hadidin  Iraq
diyAudio Member
 
Join Date: Jul 2008
Default rubicon 2500 problem any one can help?

hi i have problem with that amp every thing looks ok but i dont have clear voice on output terminal something like windy noise i detect some heating on driver borad i changes all driver transistors with 2sd667 and 2sb647 and i lost output at all,
anybody can help me please???
thanks
  Reply With Quote
Old 10th April 2015, 02:44 AM   #2
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Which 'driver' transistors did you replace on the driver board?
  Reply With Quote
Old 10th April 2015, 06:59 AM   #3
hadidin is offline hadidin  Iraq
diyAudio Member
 
Join Date: Jul 2008
a1275 and c2388 i think small pack transistors i measure voltage on c/e about 75 volt and i replace with this transistors
but i tested after removing and transistors are ok
  Reply With Quote
Old 10th April 2015, 07:08 AM   #4
hadidin is offline hadidin  Iraq
diyAudio Member
 
Join Date: Jul 2008
i forget something i inject signal from my function generator to amp and i test signal on "IN" pin of driver board with oscilloscope and looks good just have some amplify on signal no distortion
signal: 0.5vpp 38hz
  Reply With Quote
Old 10th April 2015, 07:51 AM   #5
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Did you twist the legs around so that they matched the original transistors (which have a different pin configuration)?
  Reply With Quote
Old 10th April 2015, 03:51 PM   #6
hadidin is offline hadidin  Iraq
diyAudio Member
 
Join Date: Jul 2008
no have same pin configuration
  Reply With Quote
Old 10th April 2015, 03:58 PM   #7
hadidin is offline hadidin  Iraq
diyAudio Member
 
Join Date: Jul 2008
have this amp service manual or any schematic....
at least driver board???
thanks for reply
  Reply With Quote
Old 14th April 2015, 07:15 AM   #8
hadidin is offline hadidin  Iraq
diyAudio Member
 
Join Date: Jul 2008
nobody can help me?
  Reply With Quote

Reply


rubicon 2500 problem any one can help?Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Soundstream Rubicon 2500 brandes.cm Car Audio 1 23rd June 2013 04:37 PM
Soundstream Rubicon 1.2500 in protect bigpun4fubu Car Audio 57 7th August 2012 01:25 AM
soundstream rubicon picasso 10.2 overload problem russdeanlee Car Audio 12 1st February 2012 04:04 PM
Soundstream Rubicon 502 Repair Problem Blazemore Car Audio 24 29th January 2010 09:18 PM
Soundstream Rubicon 702 Output transistor Problem? tyu527 Car Audio 10 29th August 2008 07:37 AM


New To Site? Need Help?

All times are GMT. The time now is 09:59 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki