Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

CROSSFIRE XP600D need PWM DLI4060B ic
CROSSFIRE XP600D need PWM DLI4060B ic
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 15th November 2011, 12:37 PM   #1
Hectorscaraudio is offline Hectorscaraudio  United States
diyAudio Member
 
Join Date: Nov 2010
Location: San Benito , Texas
Default CROSSFIRE XP600D need PWM DLI4060B ic

Need PWM output ic DLI4060B 24 pin is this a lost cause amp ?
  Reply With Quote
Old 15th November 2011, 12:49 PM   #2
pergo is offline pergo  Italy
diyAudio Member
 
pergo's Avatar
 
Join Date: Dec 2008
rarely it fails.
Look at the IR2113 beside. It often fails
  Reply With Quote
Old 15th November 2011, 01:02 PM   #3
Hectorscaraudio is offline Hectorscaraudio  United States
diyAudio Member
 
Join Date: Nov 2010
Location: San Benito , Texas
Thanks .
  Reply With Quote
Old 16th November 2011, 02:39 AM   #4
Hectorscaraudio is offline Hectorscaraudio  United States
diyAudio Member
 
Join Date: Nov 2010
Location: San Benito , Texas
There is no IR2113, heres a pic of the output side, negative output mosfets don't have voltage -6.0V drain. Positive mosfets have 46 volts on the drains .
Attached Images
File Type: jpg xp600d prego.jpg (71.6 KB, 186 views)
  Reply With Quote
Old 16th November 2011, 03:38 AM   #5
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
With the FETs in or out of the circuit?

That IC is fairly well isolated from the FETs in most amps. Check the driver transistors and the diodes in that area.
  Reply With Quote
Old 16th November 2011, 03:49 AM   #6
Hectorscaraudio is offline Hectorscaraudio  United States
diyAudio Member
 
Join Date: Nov 2010
Location: San Benito , Texas
FETs were out out circuit . Ok will check .
  Reply With Quote
Old 16th November 2011, 03:54 AM   #7
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Does the amp use N and P-channel outputs or all N-channel outputs?
  Reply With Quote
Old 16th November 2011, 04:18 AM   #8
Hectorscaraudio is offline Hectorscaraudio  United States
diyAudio Member
 
Join Date: Nov 2010
Location: San Benito , Texas
Yes both N and P channel output fets.
  Reply With Quote
Old 16th November 2011, 04:35 AM   #9
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If it uses N and P outputs, the drains should be directly connected. Check for broken inductors, open traces, bad solder connections and pulled vias.
  Reply With Quote
Old 22nd November 2011, 01:27 PM   #10
Hectorscaraudio is offline Hectorscaraudio  United States
diyAudio Member
 
Join Date: Nov 2010
Location: San Benito , Texas
I installed the output fets and the when I power up the amp , it draws 20 amps of current . Plus I was rereading this thread, the 640s gate pins had +6 volts not -6 volts . This has to be why the amp goes red line full amps . Bad drivers but they look good ? Oh and Perry like you said about lnductors the power supply transformer was making a high pitch noise but stopped. I tryed powering the amp and twisting on all inductors but no good , fuse would short out still . Power supply fets heat up and only 640s not 9640s .

Last edited by Hectorscaraudio; 22nd November 2011 at 01:30 PM.
  Reply With Quote

Reply


CROSSFIRE XP600D need PWM DLI4060B icHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Crossfire bmf1000d jordan_ciaramit Car Audio 1 8th September 2011 02:23 PM
Crossfire CFA602 mike49504 Car Audio 18 12th November 2010 07:01 AM
simple ic for 0-100% duty cycle PWM sss Power Supplies 6 2nd June 2010 01:34 PM
push-pull PWM IC chimi Power Supplies 19 4th September 2008 09:32 AM
Need HELP for Crossfire VR4000D JoergST Car Audio 2 4th December 2006 12:13 PM


New To Site? Need Help?

All times are GMT. The time now is 04:13 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki