Go Back   Home > Forums > >

Analogue Source Turntables, Tonearms, Cartridges, Phono Stages, Tuners, Tape Recorders, etc.

Problem with Pioneer TX-608 Tuner (1980)
Problem with Pioneer TX-608 Tuner (1980)
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools
Old 5th May 2021, 02:12 PM   #21
Vintagelover is offline Vintagelover  Belgium
diyAudio Member
 
Join Date: Apr 2014
The problem is solved! You're the best!
I'm very happy with my fixed vintage radio.

Repairing things can be very satisfying

Long live diyaudio!

Vintagelover
  Reply With Quote
Old 5th May 2021, 06:28 PM   #22
anatech is offline anatech  Canada
diyAudio Moderator
 
anatech's Avatar
 
Join Date: Jun 2004
Location: Georgetown, On
Problem with Pioneer TX-608 Tuner (1980)
Hi Vintagelover,
Everyone tries to be helpful.

What part # did you use?

-Chris
__________________
"Just because you can, doesn't mean you should" © my Wife
  Reply With Quote
Old 5th May 2021, 07:04 PM   #23
Vintagelover is offline Vintagelover  Belgium
diyAudio Member
 
Join Date: Apr 2014
My local store didn’t have a TIP41A, B or C. But he came up with a BD243C. That did the job.
  Reply With Quote
Old 5th May 2021, 07:15 PM   #24
anatech is offline anatech  Canada
diyAudio Moderator
 
anatech's Avatar
 
Join Date: Jun 2004
Location: Georgetown, On
Problem with Pioneer TX-608 Tuner (1980)
Hi Vintagelover,
That part has very low gain. Probably overkill for the job. If you do run into performance issues, like poor regulation or excessive supply noise, try a TIP41 or one of these (or similar). I did a search on Digikey and you now have time to order something more appropriate. The device is fine at a 3 amp rating for collector current. 1 amp would do it, but I'm leaving room for charging capacitance when you switch on. A TO-126 part might possibly work as well, but heat dissipation would be your limiting factor.

-Chris
__________________
"Just because you can, doesn't mean you should" © my Wife
  Reply With Quote
Old 7th May 2021, 06:32 PM   #25
Vintagelover is offline Vintagelover  Belgium
diyAudio Member
 
Join Date: Apr 2014
Thank you, I’ll look into it
  Reply to this post

Reply


Problem with Pioneer TX-608 Tuner (1980)Hide this!Advertise here!
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pioneer SA 608 Low volume on right chanel bobyblg Solid State 3 12th January 2021 11:43 AM
Pioneer SA-608 Blown Fuse Vintagelover Solid State 11 14th November 2020 06:25 AM
Onkyo TX-SR 608 start problem sippo Solid State 1 30th December 2015 12:07 PM
Pioneer SA-608 phono stage hum JohanH Solid State 6 22nd January 2015 12:09 PM
pioneer sa 608 amplifier peter hawthorne Solid State 2 4th October 2007 02:30 PM


New To Site? Need Help?

All times are GMT. The time now is 11:46 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Copyright ©1999-2021 diyAudio
Wiki