Go Back   Home > Forums > > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

AKSA Builders of market proven kits and modules at sound quality to rival the best in high end

Reply
 
Thread Tools Search this Thread
Old 24th September 2018, 08:35 AM   #1
saf is offline saf  Portugal
diyAudio Member
 
Join Date: Sep 2009
Location: Porto
Default Old dog - new shed

Hiall !

Now for something completly NEW, or maybe not so, but nevertheless exciting!

I concluded a new build, or should i say a old new build. I had my LifeForce55 in the closet for some years now, and i decided that it did not deserve this.
So out it came, and i designed a brand new casing for it.
I thank Hugh for a new PSU pcb, i had the original completly destroyed due to miss-design issues on the old chassis. The casing came in yesterday and the will was such, that i built it again yesterday from scratch !!!

So....remember de Maya ? Here is its Little "older" brother :

Click the image to open in full size.

Click the image to open in full size.

Click the image to open in full size.

Click the image to open in full size.

I honestly prefer the Maya look. I opted for a black version this time, first to differenciate it from the Maya, but also to give it a try. The black is nice, but very very susceptible to scratches and dust. It never looks pristine, like the anodized aluminium. But i am happy.

It is still missing the handles, i am working on them. Also did not put the front LED in. Hugh, can you help here ? Where should i connect the LED for the LF55, and what resistor values ? Sorry...very lazy I ah thinking of a RED color red.

What do you think ?
Cheers
Filipe
  Reply With Quote
Old 24th September 2018, 10:23 AM   #2
AKSA is offline AKSA  Australia
diyAudio Member
 
Join Date: Sep 2001
Location: Melbourne, Australia
Filipe,

I think that there is a possibility that the Maya is indeed very sensitive to input signal, and it might show up as crackles and plops when other domestic appliances switch on an off. Try this: Put in a 3.3nF 100V filmcap across the output binding posts. It might alter inputs through the speaker leads, which are often an issue in sensitive amps.

Ah, how I remember the Lifeforce! That was a blast from the past!

An LED: run a 15k from the positive rail to the anode of a green/blue/red led (choose what you like), and the katod of the led, the short lead, should connect to ground.

Alternative, use TWO 15k resistors, one from positive rail (after the fuse) and one from negative rail, and then pos side resistor to anode of LED and the other negative resistor to the katod of the LED.

Then when your power is up and running for the module, the LED will be on. Blue has 2.6V across it, Green 2V, and Red 1.6V. They are very useful as voltage references.

Cheers,

Hugh
__________________
Aspen Amplifiers P/L (Australia)
www.aksaonline.com
  Reply With Quote

Reply


Old dog - new shedHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cleaning the shed Rude1 Everything Else 0 13th May 2018 09:07 AM
Could anyone shed any light on this amp for me? dwjames Tubes / Valves 25 21st August 2014 09:30 PM
Shed a little light pls:) msj965 Full Range 8 7th September 2013 10:18 AM
DIY Shed shedding qusp Swap Meet 11 6th May 2012 06:04 PM


New To Site? Need Help?

All times are GMT. The time now is 08:43 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki