White noise and slight crackles in one amp channel

One amplifier channel has much more which noise and some crackling compared with the other channel. My intuition, which can be wrong, tells me that since the bases of the differential pair are the most sensitive parts, the crackling and stronger noise might be generated by some component connected to the differential pair bases. The are two electrolytic capacitors, one on the inverting side and the other on the non-inverting part. One is quite large, 2200uF and the other an AC blocking capacitor of only 10uF.

Do common electrolytic capacitors cause white noise? I am suspecting a capacitor might be the culprit. I am also suspecting the differential pair might be from different batches, and hence, might not be matched.
 
The schematic for LTSpice is attached. One channel works without issues. The channel with issues has a 'hiss' with random crackling sounds. The loudness of the hiss and crackling is quite low. It is barely audible from I meter away from the loudspeaker. The working channel does not have this issue.
 

Attachments

  • future_lec_ian_2022_07_04_BJT_and_thermistor_VBE_multiplier_amp_circuit1.asc
    16.4 KB · Views: 58
  • 2023-09-06-135136_1366x717_scrot.png
    2023-09-06-135136_1366x717_scrot.png
    33.4 KB · Views: 125
Heat issues can be eliminated. All power transistors are in good contact with a heatsink. I am suspecting the differential pair are not well matched. I think, it is good if I buy two transistors from the same batch to minimise the chance of mismatch.

My humble hypothesis is that an electrolytic capacitor may be responsible. The input differential pair are connected to an electrolytic capacitor. There is a large, 2200uF, capacitor grounding the inverting input, and the input, is connected to a 10uF capacitor.
 
This is a minor issue which is noticeable only at very low volumes. Since, the other channel does not manifest the issue, I am concluding this issue can be corrected. The most sensitive parts of the amplifier are the differential pair because they supply current to the current mirror and VAS. The VAS itself is extremely sensitive due to being driven by the output impedance of a transistor wired as a current mirror. My intuition and logic tells me that since the differential pair are the most sensitive components, the problem is somewhere near them. A component is generating more noise than it should. My hypothesis is some capacitor or a transistor may be the culprit. This amplifier channel also has the lowest DC offset out of the two channels. The other channel has more DC offset, yet it is silent with a white noise level that is barely audible in a silent environment with my ear only a few centimeters away from a large speaker (12 inch diameter).