Tube curves tracer

This old topic is closed. If you want to reopen this topic, contact a moderator using the "Report Post" button.
Depanatoru said:
I use WindowsXP and I can't install your program . After I choose the location where to install , an error message appears : "Type Mismatch Une erreure d'installation inattendue s'est produite! "


Windows unatempted error :devilr:

I will do some some tests on a machine not having VB already installed and report results asap.
Probably a missing file.

Sorry !

It seems that the COMDLG32.OCX file cannot be copied in "Winsyspath" directory.
I don't know why.
Could this be caused by an anti virus protection ?

Manually moving this file from "InstallV109\Support" to Winsyspath (usually C:\WINDOWS\System32) allows the TCT.exe to be run.
Still dont ask me why, but the machine on wich I've tested allready has some other VB6 generated programs allready installed.

The file "InstallV109\Support\G1LookUp.txt" must be copied in the directory where TCT.exe resides.

Some helps from Windows specialists greatly appreciated.

Thanks in advance.

I don't know about COMDLG32.OCX , but I ran into a similar problem with MSCOMM32.OCX using VB6 student version. It needed a key copied into the Registry. And the OCX component had to be registered with Windows using REGSVR32.exe. But this was for using it in VB6 at the source/compile time. Not sure about run time/object file requirements.

astouffer said:
I got the same error on XP with SP2 and no anti virus running. No errors are shown in the event viewer. COMDLG32.OCX is already in system32 and my version is, the same as the one supplied.

Many thanks for investigations.

May I dare to ask you to check if all the files referenced in the "InstallV109\setup.lst" were copied at their right locations ?

This files are supplied in "InstallV109\Support".
I'm quite sure than copying them manually should solve the prob, but I dislike.

Unfortunatly I do not own other installer than the one supplied with VB6.

Looks like you have to register COMDLG32.OCX:

REGSVR32 %Systemroot%\System32\comdlg32.ocx



Then you have to restart windows for it to take effect.

It could be that your installer is already registering it, but it is not warning the user that Windows has to be restarted for this to take effect.
This old topic is closed. If you want to reopen this topic, contact a moderator using the "Report Post" button.