Telequipment S54 help please!

Hi All,
I recently got one of these and i cannot work out what's up with it!!!
It has a time/cm function, however whenever i switch it from "EXT" on the dial to anything else it dies straight away (picture goes).... which doesn't sound right to me, this is with AC on the input and it stays in one "line" up and down on the screen, i.e. no time/div if that makes sense?
Not sure why, but whenever i switch off "EXT" it just loses picture! It comes straight back on when switched to EXT....

Any ideas????

Thanks
Aaron
P.S. I understand it's got a few valves in it - is it possible some have gone?!
 
NUTTTR said:
Hi All,
I recently got one of these and i cannot work out what's up with it!!!
It has a time/cm function, however whenever i switch it from "EXT" on the dial to anything else it dies straight away (picture goes).... which doesn't sound right to me, this is with AC on the input and it stays in one "line" up and down on the screen, i.e. no time/div if that makes sense?
Not sure why, but whenever i switch off "EXT" it just loses picture! It comes straight back on when switched to EXT....

Any ideas????

Thanks
Aaron
P.S. I understand it's got a few valves in it - is it possible some have gone?!

I guess you mean external signal? That's normal, if you take it from EXT you are supposed to provide a trigger for the internal sawtooth generator. You can do that in two ways: Internal Trigger takes a sample from whatever you have on the X input(s), and External Trigger lets you supply a separate signal to trigger the sawtooth.
Then there may also be a control for trigger level and trigger polarity. Or even Auto Trigger.
Try setting to Ext Trigger and supply the same signal that you have on the X input to the Ext trigger connector. Make sure the time/div is in the ballpark for the input signal frequencey. Then play with Trigger level and/or polarity and you'll probably be OK.

Jan Didden
 
Pictures:

First:

[IMGDEAD]http://www.behavingbadly.net/fm/DSC02877.JPG[/IMGDEAD]

Second: This one shows the "adapter" it has on the front of the unit - coax connection?

[IMGDEAD]http://www.behavingbadly.net/fm/DSC02879.JPG[/IMGDEAD]


So, i'm assuming what you are saying is that i should hook the input to the coax connection on the front? (the adapter)???

The control with the sec/cm control doesn't do anything at all unless it's on EXT it doesn't display anything!

Aaron
 

dhaen

diyAudio Moderator Emeritus
2002-06-10 12:01 pm
U.K.
www.keystrobe.co.uk
Telequipment were the "poor man's Tektronix". These low cost scopes (of this age) had very poor triggering even when new, compared with modern scopes. Make sure the Trig level-Stability is rotated to the "auto" position. Press the "int" button. Connect the calibrator into the Y input, and see if it'll trigger.
In the days when I used to use this kind of scope it was customary to use an external trigger pulse whenever possible.