RPi 3B+, kali, piano 2.1 - no sound

beppe2672

Member
2019-12-15 3:36 pm
Hi people,
I'm having some issues. I purchased a allo kali+piano 2.1 in the hope of being able to build a RPi based 2.1 web radio player that also allows me to use airplay. after 2 days of trying to get this to work its still not made a sound. Ive tried several versions of volumio, multiple iterations of /boot/config.txt, alsaplayer if deffinately not muted, still no joy. The hardware seems to go through the motions and I'm not getting any error messages in volumio. Anyone able to help?

Thanks in advance.
 

beppe2672

Member
2019-12-15 3:36 pm
Heres a bit more info.

/boot/config.txt
initramfs volumio.initrd
gpu_mem=32
max_usb_current=1
dtparam=audio=off
audio_pwm_mode=2
dtparam=i2c_arm=on
disable_splash=1
dtparam=i2s=on
dtdebug=1

#### Volumio i2s setting below: do not alter ####

dtoverlay=allo-piano-dac-plus-pcm512x-audio



**** List of PLAYBACK Hardware Devices ****
card 0: PianoDACPlus [PianoDACPlus], device 0: PianoDACPlus multicodec-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0
 

DRONE7

Member
2008-08-21 11:12 am
Tried again with moode today, fresh install using the config setting linked above. Still nothing, then removed my kali, again fresh install and again, no sound. Starting to think I’ve been supplied with a faulty piano 2.1.

So starting with the piano 2.1 and MoOde....have you downloaded and installed the Allo firmware and rebooted ? is the rpi compatibility switch set to on ?

if so then in MoOde... M>Configure>Audio and check the driver and chip options. There should be output options for stereo/mono/2.1/and 2.2 as well as sub settings. If not then perhaps you do have a faulty Piano board.

If there are options select the outputs you want to use and connect the appropriate cables.... is there sound ?

If yes report and we can go to adding the Kali...