rockford fosgate symmetry epx2

mike49504

Member
2006-09-22 8:32 am
wondering if anyone knows about this unit the main brain comes on but the rdat (display) is dead wondering if anyone knows what i need to replace in the unit to make it work again since landis wants 155.00 for repair and i already have 250.00 into the unit when i bought it off ebay the guy said it was new and the display is dead
 

jol50

Member
2007-11-08 2:14 am
Don't know a thing about that unit, but I did have a home stereo the other day that suffered a large impact in the box. It knocked the display around on its cheap clip and blew the power trace loose. That was all that was wrong with it. It only had very small damage where the metal case comes to the front face, but no damage on the front thus I figure it was in the box damage. There is also one on ebay guy says control got in door of car and broke cable.
 
mike49504 said:
wondering if anyone knows about this unit the main brain comes on but the rdat (display) is dead wondering if anyone knows what i need to replace in the unit to make it work again since landis wants 155.00 for repair and i already have 250.00 into the unit when i bought it off ebay the guy said it was new and the display is dead

Well, the cable could be bad. Also, one of the internal regulators could have come unsoldered. Replace the filter caps while you're in there...everything gets very hot under normal operation and these caps break down...sometimes causing low output voltage. Also, go around to all the RCA connectors and resolder them...many will already to broken.
 

mike49504

Member
2006-09-22 8:32 am
wondering if the problemis in the display it sekf or in the main brain unit i was testing the ics in the display unit and there are 2 of the same chips and 1 of them was re4ading all negitive numbers on allpins and the other was reading allpositive numbers wondering if that might be whgere the problem is
 
mike49504 said:
wondering if the problemis in the display it sekf or in the main brain unit i was testing the ics in the display unit and there are 2 of the same chips and 1 of them was re4ading all negitive numbers on allpins and the other was reading allpositive numbers wondering if that might be whgere the problem is

The display unit is rarely bad...your readings are likely the result of some other problem. Did you check what I specified in the previous post?
 

mike49504

Member
2006-09-22 8:32 am
i checked the cable and replaced caps thats not it so i checked an ic chip lmc1992ccn with my meter on ac voltage and the reading are

Pin 1: .152
Pin 2: .186
Pin 3: 16v
Pin 4: .22
Pin 5:.392
Pin 6: -0.17
pin 7:-0.14
pin 8:no reading
Pin 9:-.222
Pin 10:-.222
Pin 11:-.220
Pin 13: -1.452
Pin 14: -1.447
pin 15: no reading
pin 16: .624
pin 17 .151
pin 18: .407
Pin 19:-.014
Pin 20: -.013
pin 21: no reading
Pin 22: -.140
Pin 23: -.178
Pin 24: -.225
Pin 25: -.151
Pin 26:-1.435
Pin 27: -1.431
Pin 28 no reading

wondering if this chip is bad or from reading still working properly any help would greatly be appericated and this chip is in the main unit not the display
 
Reading on AC voltage, eh? :whazzat: You need to switch to DC, since those are the voltages inside the unit. The LMC1992 is a digital audio controller that performs the actual input switching and some EQ functions.
But did you check to see if you have the correct voltages from the regulators...You're not answering this very key question. The regulators may not be functioning. The DC-DC power supply may not be functioning properly.
Do you have any troubleshooting experience at all? From what I can tell, you're shooting in the dark. :confused: I have an EPX² unit here, but I'm not opening it to guide you until you can just follow basic instructions.
 

mike49504

Member
2006-09-22 8:32 am
sorry i meant dc not ac was tierdwhen i posted yes i checked all the regulatirs in the ubit and they all seem to check ok and yes i have trouble shooting experance i work on amps like everyday but when it comes to the symmetry im new to the unit since its got like topaz circuits and stuff like that
 
mike49504 said:
sorry i meant dc not ac was tierdwhen i posted yes i checked all the regulatirs in the ubit and they all seem to check ok and yes i have trouble shooting experance i work on amps like everyday but when it comes to the symmetry im new to the unit since its got like topaz circuits and stuff like that

TOPAZ is a marketing gimmick. It doesn't change the basic nature of electronics. You do not have Vcc (pin 28) for that IC, so I suggest looking up the datasheet for the parts you are testing and deducing what power supplies are not functioning. You should have either 12V or +15V at pin 28.