Rivera M60

Status
This old topic is closed. If you want to reopen this topic, contact a moderator using the "Report Post" button.
Have you worked on amps before? The reason I ask is that since you replaced the tubes, one of the next things to do is check all voltages, high voltage B+, bias and heater voltages. If these are off, the amp can't operate properly. Here's a good resource for fixing amps: New Page 1 Look to the upper left and click on "tube amp debug page". If you haven't done this or are not very experienced, then this is not the amp to learn on. The voltages inside can KILL YOU and the schematic for this amp is complicated.
 
So true about finding problems. Here are the schematics. As I said, they are complicated. I'd be tempted to check those voltages I listed above since you've replaced the tubes.

On the pramp schemo, the hi/low inputs don't translate directly to ch1 and 2. The different levels are because of the switching jacks and how those 33k grid stoppers are switched. You can see that both hi and low inputs are sent to the same input tube. So you can have hi/low for both channels. Those LDRs labeled PH 1-6 then switch to different signal paths and gain structures.

I can trace out some of the signal paths but a lot of this amp is over my head. But at least you have the schematics.

View attachment Rivera M60 pre.pdf

View attachment Rivera M60 pwr..pdf
 
Status
This old topic is closed. If you want to reopen this topic, contact a moderator using the "Report Post" button.