RF BD1000.1 repair

I have a bd1000.1 that I'm finally getting around to repairing. I was the original owner, bought new from the dealer. Years back I remember there was no drama with it... worked well,. Just suddenly went into protect the moment you turned it on and that was it.

Opened it up... saw c59 and c60 caps have vented out the top - removed them. Also found J105 (one of the two 16-18awg solid U shaped bars) was loose. Looks like one end wasn't soldered at all and the other end burned. Cleaned it all up and soldered both sides well. I couldn't spot them on the schematic but they appear to bring input power to the opposite side of the board.

Amp turns on now. Protect light comes on for a few seconds and then goes out as voltage builds. Is that normal? It reaches 86v.

I don't have suitable replacements for c59/60 yet. Can I put a light load on it to test it without them, or should I wait?
Last edited:
The capacitors don't have to fit the board, for now, just something that will handle the voltage and is near in capacitance.

It's normal for the protect LED to go out after a few seconds. At that point, you should see rail-rail switching on the output transistors and get audio at the speaker output.

Was the amp working normally, until you had the broken connection on the jumper and the caps failed?

I don't have a good sub for the output transistors (if these are damaged) so you should power up through a B+ limiter (at the least) to help protect the amp. Also closely watch the temperature of the output transistors while it's on and outside the heatsink.
I honestly don’t know the order of the way things happened - all I remember is years ago it was fine, suddenly stopped working, and sat on the shelf since. Opened it up now years later and here we are.

All testing so far has been through a series 10a fuse on b+. Nothings got hot but haven’t tried any load yet. I haven’t removed them yet to verify but they all measure the same within their groups. If the fuse has survived as is that’s a good sign though.

Sounds like a load is a bad idea without c59/60. Ok hopefully I can scrounge something up.
Got the caps in. Protect light still goes off after a few seconds. Logo-power light red

Wanted to hook up load but noticed -0.91v dc offset on speaker terminals. Dropped to about -0.85 after a few min. Seems excessive, or am I mistaken?

Nothing is getting hot and it’s still outside the heat sink. Measurements of some random opamps I’ve seen you ask for before with negative probe on B-

1: 0
2: -0.001
3: 0.002
4: -9.73
5: 0
6: 5.62
7: 9.89
8: 0

1: 0
2: 0.045
3: 0.002
4: -9.74
5: 0
6: -5.56
7: 9.96
8: 0.002

1: 0.006
2. -5.09
3: -0.104
4: -9.66
5: 0
6: 7.60
7: 9.96
8: 0.001
So I took a gamble and connected a small mid to it. Cone drops as expected from the dc offset. A sort of screeching static is emitted without any input. With input the noise is still there. Music plays but is distorted. After a couple minutes playing all the big power supply and output gets we’re still room temp.

I noticed u11 getting warm. With everything disconnected but power u11 reads
1: 0.057
2: 0.063
3: -0.033
4: -9,67
5: 0.063
6: 0.062
7: -0.119
8: 9.94
Been a long time since I used my bass mechanik cds….

With the mid still, at 50hz input it plays just fine. In fact, oddly enough … using a disc man portable cd player, the tone covers up any noise. When I stop the track the dc offset and screechy static noise does not return until 2-3 seconds later. Strange! Driver issue?

I assume it needs to go back in the heat sink and remove the fuse for the sub load?
Ok so it’s back in the heat sink and loaded with a dvc8 driver so 4 ohm total. This time power supply is higher, 14.3v as opposed to a 4s lithium polymer battery (high 12v)

The idle 0.9v offset is still there and actually climbs higher with volume change - caught it as high as -2v at one point. It spikes on volume change but seems to settle at about -1.4v

The longer it’s left running the hotter u11 gets. Also noticing q15 and q16 getting hot as well. R44 gets way too hot to touch. - suspect that’s what’s causing the slight odor but hard to tell

No perceptible heat from the ps or output fets when in heatsink
The heating is normal. I don't have exact temperatures but I wouldn't be too concerned at this point.

Confirm that C67 isn't defective.

There's a chance that U11 is getting too hot but I think you need to determine if everything else is working properly before thinking about changing any ICs. You need to test with a load up to clipping. The first test can be without a load but probably won't tell you anything,
I didn’t look at the schematic until you said c67. C67/r44 is just a transient filter right… shouldn’t be conducting much let alone getting that hot.

Removed c67. It’s not shorted, measures open with ohmmeter and cap meter shows value within tolerance. If it’s conducting enough to heat up a 2w resistor like that, makes me wonder if power side isn’t as good as I thought it was. I’ll have to scope out the power supply too.

Thinking about getting a dummy load resistance to make testing life a bit easier