Power supply clicking won't start

mzzj

Member
2005-07-02 8:17 pm
65N 25E
argonrepublic said:
I have an ADAT Power supply is not starting up just clicking. I can't find any specs or schematics. Brother has Camera. Would anybody care to help me through this problem? I have a meter, soldering and desoldering tools.
Thanks
I Suppose it is SMPS?
If so:
1. dried electrolytic caps, especially vcc filtering cap for controller ic)xx3842, xx3842,++. Located in primary side of pwr supply, good quality pic would help giving more specific advice.
2. output diodes shorted or output caps blown up and shorted.
3. output protection SCR/TAZ shorted
4. somebody trying to test power supply without proper minimum load.

99% of clicking power supplies are fixed after checking those.

And remember safety, you can die, set your house on fire or even worse break your equipment. Check big mains filtering caps on power supply with multimeter, they can have up to 400V after disconnect for a loong time. Discharge with power resistor, light bulb or something similar(not your $$$ Erem pliers or screwdriver)
 
I too am having problems with this Adat black face supply.
I brought the adat with the power supply not working.
The previous owner tried too repair it, but ended up using
wrong parts & values. What makes it harder is, I found a schematic, but it is not the same revision as mine.
Mine is a REV C.

I ended up changing all solid state devices, and a few electro's,
I fired the unit up using a 100watt lamp in series with the power cord.
All was looking good, the adat lit up. I checked my DC volts and set the master adjustment. I removed the series 100 watt lamp
and but directly on the mains.
All seamed ok, but I noticed the front level meters spiking,
which made me concerned about the power supply still not being OK.
I loaded a tape into the Adat, and within a few seconds it blew
the internal 2 amp fuse.
I started to fault find and found the mosfet shorted,
I replaced the mosfet, and retested the unit with the test lamps
in circuit. My unit has extra components not shown on the schematic. If any one has any info on these power supplys could they forward it on to me thanks.
I am trying to find out why the mosfet blew


Brendan
 

jeroengreece

Member
2008-01-18 12:42 pm
hi all,

I have 2 blackface adat's with the same problem.

My power supplies are dks-606u rev c. I do not have schematics of the power supply and was wondering if some of you solved the issue before I start replcacing parts.
Optically I can't see any blown capaciters. But as the power supply sometimes starts I do suspect capacitors. But most off the time I just hear the mosfet clicking.

Should I replace c109 100uF /50V or the mosfet or....?

Thx for any help
 
ADAT Power supply issues

The first problem I had was finding the correct circuit, even alesis
were vague in this department.

The power supply in mine is a HIGain DKS-606u
I ended up changing the 6N60 mosfet (Large burnt hole in side)
also the UC3842 switchmode IC regulator (or something like that)
But the problem I had when I got it going was the .33ohm resistor
(part R115) it was flashing over to the mosfet, with a almight crack.
I found that the .33ohm was tracking over to the mosfet.
I cleaned up the carbon around the area, and made sure the side
of the resistor which was tracking to be far away to the mosfet as poss. (Ie solder the component so little to no lead exposed)
I also changed the opto. and a few diodes in the process of fault finding.

I have attached the circuit which I found on the net.
for a alesis service manual, contact alesis.
 
Hi there,

After fixing it I would like to inform you what the problem was:

After replacing c109 with a new 100uF 63 Volt 105"C it worked again. This capacitor is used to start the oscilator. Mine had lost capacity but was not totally broken. This is normal due to heat and time. Because of the los of capacity there was to much riple which stopped the oscilator from working. After replacing it all was fine.

Hope this helps some out there...
;)
 

Artspoke

Member
2009-04-24 2:05 am
We just had a power outage - about 20 blocks of residential and commercial properties. While the power was off, I shut everything off in the studio. When the power got turned back on, everything came back to life, except my old blackface ADATs - both of them, kaput.

Once I discovered that the fuses were intact, I started to get worried. With the cases open, I could hear some clicking that resembled what you described, so I went to Radio Shack, and for $1.29 each, I got the last two 100uF / 50V caps in the shop. It fixed both of them! C109!!

Thank you soooo much - I am at least one of the people out there that your post helped.