Philips 308 turntable

I have a Philips 308 Electronic turntable which works fine. But the cartridge has a bad contact or something because sometimes, the right channel goes off. If I touch or move the cartridge a bit , there is a noise and the channel is back On.

The cartridge seems like the original one and this turntable is more than 15/20 years old I guess. I think I need to change the cartridge. Otherwise, the table is not so bad.

Question:

1- Does anybody know anything about this turntable model. Is it any good? I found a photo of a similar table.

2-What type/brand of cartridge could I buy to replace the old philips cartridge.

3- Should I expect a good improvement with a new cartridge.

4- Is there any tweeks I can do to improve the sound of this turntable or should I just change it for something better.

That's a lot of questions! I need advise
F
 

Attachments

  • turn.jpg
    turn.jpg
    53.3 KB · Views: 236
Thanks for the info

The turntable model is Philips 312
The cartridge is a 401. It looks kind of bad. I will surely change it.

I don't know about the type needed (P-mount, standard) I do I know? The actual cartridge has 4 little pins at the rear but no screws or anything. It just kind of "fit in" when I push it in.

I will post a photo soon.
F
 
Its been many years but I seem to remember the headshell slides in with 4 contacts - (am I even close?) and these connections sometimes became a little 'flakey' - just clean and adjust/tweek as needed.

Also I think this table also had a mute switch mechanically activated by the lift (boy its been a long time) - if so check it as well.

I do remeber the touch speed switchs would sometimes get dirty enough to cause problems, just clean.

Happy listening
 
"Its been many years but I seem to remember the headshell slides in with 4 contacts - (am I even close?) and these connections sometimes became a little 'flakey' - just clean and adjust/tweek as needed. "

Exactly. I will clean those

Don't know about the Mute swich. I don't think mine has that.

F
 

jaudio

Member
2004-10-29 1:31 am
Dont use P mount

I used a old Grado,It sound very good.

This is a 212 I paid $5. It was a little noisy until I changed powersupply(outboard). It had a broken power switch that was changed.

I find a second 212 broken of course from that I got a desent dustcover.
 

Attachments

  • p5060010[1].jpg
    p5060010[1].jpg
    96.2 KB · Views: 151