Phase linear 400 driver replacement

The Donk!

Member
2008-02-24 4:48 am
I'm rebuilding one channel in a PL-400

One channel already has OnSemi's in it. (MJ15015s)

I 'm going to use MJ15024s for the other channel.

However, I have searched High and Low for a sub for the drivers mounted right underneath the finals.

And no one seams to talk about them.

They are Motorola SJ2741's

Any idears on this.

And if I some how read what I'm trying to find out here, on this site already and didn't realize. My bad.
 

wg_ski

Member
2007-10-10 5:21 pm
Finding original spec drivers is going to be a real SB. RCA410's, RCA1B05's or 2N5240's are going to be rare - and probably fake if you find them. When I've replaced drivers, I just use the same as whatever the outputs were replaced with. Just make sure the replacements don't have fT's above about 6 MHz or particularly high beta. I have used MJ15024, 2SD424, 2SD555, and VCEO-selected 2N3773.
 

wg_ski

Member
2007-10-10 5:21 pm
djk said:
"One channel already has OnSemi's in it. (MJ15015s)"

Get those out of there (only rated at 120V)!



I would at least test them to make good and sure there's no leakage at 150 volts. Whoever fixed it last may have checked this - the VCBO is 200V and most of them will take this C to E. They're good for 3A at 60V, which is probably better than the RCAs or the PL909's (but not the 15024).

They have the same p- poor beta curve as the 2N3055 and only a 2 MHz fT. This would tend to keep stability problems at bay.
 
It's a class B amp - don't recall the factory method for setting the bias. The manual pages are doubtless floating about.

But it has so much feedback and so little bias that it may not matter much within reason - especially if you can't find the xover notch on a scope...

Personally, I'd want the same devices in both channels... but for casual stuff, probably makes no diff...

_-_-bear
 

djk

R.I.P
2001-02-04 4:23 am
USA
"the VCBO is 200V and most of them will take this C to E. "

The reverse biased CE voltage is 200V, but that does not describe an audio amplifier. You must use the Vceo, which is only 120V.

I have had failures with the MJ15015 with only ±57V.

If you expect them to work in a PL400 they need to be checked for 170V minimum.
 

djk

R.I.P
2001-02-04 4:23 am
USA
I would never buy a semiconductor from eBay.

Take the seller from HK:

http://cgi.ebay.com/10pcs-PNP-MJ150...oryZ4666QQssPageNameZWDVWQQrdZ1QQcmdZViewItem

Date code wrong (became ON Semiconductor in 1999).

http://cgi.ebay.com/2-X10-MJ15024-M...yZ109457QQssPageNameZWDVWQQrdZ1QQcmdZViewItem

Case style wrong.

http://cgi.ebay.com/200-MOTOROLA-PN...yZ109457QQssPageNameZWDVWQQrdZ1QQcmdZViewItem

Case style wrong.

http://cgi.ebay.com/2-X-MJ21193-2-X...oryZ4666QQssPageNameZWDVWQQrdZ1QQcmdZViewItem

Well, they finally got their markings sorted out, and the case of the one on the left sort of looks correct.

Would you buy

ANYTHING

from these people?

I also buy 100 lot trays only from authorized distributors.

I have MJ15024 and MJ15015/16 on hand in 200+ quantity.

If someone wants sets to re-do their PL400/700,
Peavey CS800, BGW 500/750, Crown 300A, etc, let me know.