Laser Replacement VRDS 10

Hello, Fellas. I've just had to replace the laser assembly in an old Teac VRDS10 (original) and it still won't read discs. I've tried to tweeak the settings using the potentiometers on the servo board to no avail. Sometimes the disc will spin and stay spinning for a few seconds while the laser tries to tead the TOC (then stops) and sometimes the disc will not spin at all.
Has anyone had to set up a player from scratch and knows what those (5) pots do? They are labled 'F-Gain', 'T-Gain','S-Bal', 'T-Bal' & 'F-Bal'.

The Teac uses the same transport as some Copeland, Wadia and Krell players, and the same laser as some Denon and Sony units. If you have one, maybe you can help.

Cheers, Dan.
 

Attachments

  • teac innards1.jpg
    teac innards1.jpg
    73.4 KB · Views: 621
Oh. I have nought but a simple multimeter. Do you have any idea what the 'F, T and S' stand for? One controlls the speed of rotation one probably the laser intensity/focus. I have plenty of time on my hands to experiment with different settings but seem to be getting nowhere. Is it possible I have done irrepairable damage to one of the control chips, maybe through static or mishandling?

Dan.
 
Dan,

Just a quick question if your new to the game, when you replaced the laser head, did you remove the Anti–Static protection “Solder Bridge” on the Head / Flex cable?

This Solder Bridge “shorts out” the Laser diode to prevent damage from static discharge until the head is ready to be installed in the player.

F = Focus

T = Tracking

S? (Servo or sledge)?

John
 
Cheers, Jon. Yes i've de-soldered the bridge. I thought it looked different to the one i took out. Thought first of all it was to make it compatible with different machines but soon realised there was no laser present on power-up so worked it out from that.

Since de-soldering the bridge i've handled the ribbon cable. The laser is still present but could I have damaged it that way? The case is not earthed in any way to the mains so I haven't been making any special effort to ground the machine or myself while working on it.. Oops!

There are various points on the circuit boards to earth the boards to the chassis. If that is the only means of grounding these boards, (and they're currently just sitting out of the box on my kitchen worktop) maybe that's why it isn't working? Although I find this hard to believe, I shall link all the boards to ground and try that.

Cheers to everyone who's contributing to this thread, btw. I really would love to see this machine up and running again.

Dan.
 

moamps

diyAudio Member
2002-10-11 8:15 am
Croatia
www.moxtone.com
Hi Dan,

I have a few hints regarding Tascam CD laser pickup replacement and adjustment. First, you need an oscilloscope to do this properly. Although certain testing can be done without the scope, if something is dead wrong you won't be able to spot the problem by using only DVM. Here's what you can do without the scope.

After you have replaced the pickup, it's usually enough to do some fine tuning (if any) to get the CD up and running again. If you can remember the correct trimmer positions prior to the replacement, then set the trimmers exactly as they were before you go on. If you don't remember the original positions, set all trimmers in the middle.

Now, put back everything except the upper and bottom covers.
With the player in off position, check with your finger to see if the laser pickup moves easily in and out.
Pull the laser pickup out as far as it goes and switch the player on while observing the pickup movement. Usually, the laser pickup reaches the end of its inward travel and then the laser lens (actuator) moves up and down three or four times.
The only adjustment you can do with the DVM is the Sled balance adjustment. Find SD pin on the test connector and connect DVM to it in DC voltage position (second probe to the ground). With the player in on position and no disc loaded, adjust zero reading using S.BAL trimmer.

Then load an undamaged disc and push play. If the CD doesn't work, you have a sort of failure that cannot be repaired without the scope, IMHO. If the CD works, you can do some additional adjustments but first things first. ;)

Regards,
Milan
 
Right. Sorry it's taken so long to make this update. I've rebuilt the unit and it was still spinning the disc for about 5 seconds, trying to read the TOC then stopping. I've just managed to get the thing spinning continuously but it still won't read the disc. In fact it won't play, pause find a different track or even stop when i ask it to! I've adjusted the focus pot till the player is nearly silent in operation, so i know it's focusing okay on the disc and the transport has been built back to it's usual rigidness so I know that's not a problem.

Anyone help me from here in?

Cheers, Dan.
 
The only part i've replaced is the laser, a straight swap old for new but the machine is still playing up because of some 'tweaking' i did to the servo pots trying to get the old laser to work properly. I have been sat literaly for hours just adjusting these five pots randomly. I'm begining to think that the problem is no longer with the laser and more with the firmware.

Audiofanatic: I really apreciate the offer. Do you think it's within your powers to ressurect this lame beast?
 
Dan

Audiofanatic: I really apreciate the offer. Do you think it's within your powers to ressurect this lame beast?

I've manage to repair all brands or audio gear, incl. KRELL, Mark Levinson, PLINIUS, Classé & Spectral pre and power amps and many more. And TEAC is my CD brand, so If you need it fixed, just let me know ;)

BTW nothing fancy about the above brands, rather complicated for nothing, Spectral and Plinius are the best among the others.

Best regards,

Audiofanatic ;)
 
Audiofanatic. I have a holiday to pay for in the next six weeks so I really can't afford to spend any more money, for shipping to Norway and back, on this project for the time being but as soon as I come home, assuming I haven't fixed the problem, I would take you up on your very kind and generous offer. Thank you.

In your experience, would you say there is a narrow window in which the value of these potentiometers allow the machine to operate? I mean with the hours i have spent tweaking these pots I would have thought I might have 'accidently' found the correct positions.

I shall persivere with the player. One last thing: There is a pot on the laser mech itself. Could this be the culprit? I haven't tried this one yet because i can barely see it, let alone attack it with a screwdriver!!

Cheers, Dan.
 

Attachments

  • eviloffrankensteinszd.jpg
    eviloffrankensteinszd.jpg
    11.3 KB · Views: 288
Norway???

Hi Dan,

Why don't you make this Utrecht? The Netherlands?
Via the tunnel I'll be a trip of max, 4 hours!

DON'T TOUCH THAT POT!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

I'll be glad to help you if you don't manage to get it running again before you leave.

Keep all pots in the middle (centre possition) if everything is OK it should work!
Do yourself one BIG favour, don't trimm the other pots PLEASE!!!!!!

All the Best,



Audiofanatic ;)
 
Hey I'm tempted to make that trip!

Ok, Ok, Ok, I won't touch the laser pot!

Tried that too, keeping all the pots in the middle. It doesn't work. Must be something else That's making it go wrong. Damn, just forked out £60 on a new laser!

I'll keep you updated. Thanks for all advice so far....

Cheers, Dan.

Old tread
But look at the prices now for a Kss151a

[IMGDEAD]http://www.gate-usa.com/wsjoe/kss1514.jpg[/IMGDEAD]

Sony stopped making the lasers
now it`s up to ... second hands .... with all problems

Kss151a | eBay
 

sfc1000

Member
2011-01-02 12:16 am
Hi all,

I installed a cmk-3,2 in my cmk4,0 Copland cda-288. So far it's been playing with difficulties, sometimes skipping, sometimes making cracking noises in the speakers, skipping and jumping. Sometimes having trouble reading toc and playing. And then again, sometimes playing well, except the noise. I've skipped the filter in the digital out area, before going into the Copland DAC board.
So, assuming that works, I am now focusing on the laser adjustment, because I also had to take out the laser and swap for another in my tries to make it play (I have another cmk-3,2 drive.
So, reading the vrds-10 servicemanual, I am now looking into adjusting the laser sled to 0 Volt as the manual says. Before touching the pot, I measured 0,033 Volt on TP4 pin 1 and 2.
Is that close enough to 0 or should it be dead zero, as in 0,00 Volt?
I will not go further before I know this for sure.

Kind regards,
SFC1000